You are not logged in.

#1 2023-01-27 16:26:22

jbreese321
Member
Registered: 2022-01-24
Posts: 31

[SOLVED] Can't boot into arch, UEFI not working

I've recently reinstalled windows on my system and when I did that it wiped my grub entries.My system is using UEFI with GPT partitions. I've tried  using the command

"grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=GRUB"

  and 

"grub-mkconfig -o /boot/grub/grub.cfg"

, but it's not creating any new entries in NVRAM. I've also tried creating new entries with efibootmgr. The exact command I used was

efibootmgr --create --disk /dev/sdb --part 1 --loader /boot/efi/--label "Arch Linux" --unicode

. That did not work either. When I selected the entry within uefi, it just blinked once and returned me the uefi screen. I tried using bcfg next and ran the following command

bcfg boot add 1 fs0:\vmlinuz-linux "Arch Linux"

successfully. . I was unable to run the second entry listed in the wiki 

bcfg boot -opt 1 "root=/dev/sdb1 initrd=\initramfs-linux.img"

, I got an error of invalid argument. I looked in my uefi entries and found  an entry in UEFI, but whenever I run it I my computer goes into kernel panic mode.

Last edited by jbreese321 (2023-01-28 18:08:41)

Offline

#2 2023-01-27 16:34:38

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,397

Re: [SOLVED] Can't boot into arch, UEFI not working

In your grub-install command, "--efi-directory=esp" is invalid. You have to give it the actual directory. For the efibootmgr command, "-loader /boot/efi/" is invalid, that's a dir, not an exectuable.

Online

#3 2023-01-27 16:37:05

jbreese321
Member
Registered: 2022-01-24
Posts: 31

Re: [SOLVED] Can't boot into arch, UEFI not working

I wasn't expecting someon to respond so quick. I was still editing my post sorry.

Offline

#4 2023-01-27 16:38:29

jbreese321
Member
Registered: 2022-01-24
Posts: 31

Re: [SOLVED] Can't boot into arch, UEFI not working

The output of fdisk is the following:

https://imgur.com/a/w6j7CuW

Offline

#5 2023-01-27 16:40:22

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,397

Re: [SOLVED] Can't boot into arch, UEFI not working

"--efi-directory=/boot/efi" isn't valid, either, given that fdisk output.

Online

#6 2023-01-27 16:42:42

jbreese321
Member
Registered: 2022-01-24
Posts: 31

Re: [SOLVED] Can't boot into arch, UEFI not working

I'm confused what should my --efi-directory  be set to?

Offline

#7 2023-01-27 16:49:20

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 19,360

Re: [SOLVED] Can't boot into arch, UEFI not working

Given the fdisk output, after you chrooted it would be "/boot". You need to pass the mount point of the ESP partition, not a subdirectory.

Offline

#8 2023-01-27 16:52:10

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,397

Re: [SOLVED] Can't boot into arch, UEFI not working

From https://wiki.archlinux.org/title/GRUB#Installation

"Mount the EFI system partition and in the remainder of this section, substitute esp with its mount point."

Online

#9 2023-01-28 17:02:03

jbreese321
Member
Registered: 2022-01-24
Posts: 31

Re: [SOLVED] Can't boot into arch, UEFI not working

I was able to boot into my Linux partition. Thanks!

Offline

Board footer

Powered by FluxBB