You are not logged in.

#1 2023-03-08 18:38:40

Cbhihe
Member
Registered: 2017-04-09
Posts: 228

[SOLVED] Faulty key input parse on display

Hello, since exactly 2023.02.24, I have had an intermittent issue with key combinations to display accentuated letters, eg. á é è ô ü etc.
Regular updates including kernel updates have not changed a thing. When I boot key combis work as expected, but at some point (usually hours later) what was supposed to be displayed as á unexpectedly becomes 'a. ü becomes "u, etc.   My only workaround so far is to reboot.
The HOST has only been subjected to regular update with sudo pacman -Syu. Nothing new has been installed explicitly.

> cat /etc/vconsole.conf
KEYMAP=es
XKBLAYOUT=es,jp,cn
XKBVARIANT=,,

Japanese hiragana and katakana as well as Chinese pinyin input modes work flawlessly.

> pacman -Ss input | sed -n '/xorg/d;/\[installed\]/s/\[installed\]$//p'
extra/anthy 9100h-6
extra/ibus 1.5.28-1
extra/libcdio 2.1.0-3
extra/libinput 1.22.1-1
extra/libxi 1.8-3
extra/potrace 1.16-2
community/evtest 1.35-1
community/ibus-anthy 1.5.14-1

When the anomaly appears, I tried to "sudo loadkeys es" and also to "sudo localectl set-keymap --no-convert es" but to no avail.

I have also revised key bindings, but I see nothing out the ordinary and in any case nothing that has changed over the last 3 months.

> less ~/.xbindkeysrc
# toggle mouse-pad on/off
#   Control + Magic + p
"(/opt/scripts/toggle_touchpad.sh &)"
    Control+Mod4 + p + Release

# send cursor selection to browser's default search engine; execute the search
#   Control + Magic + s
"(/opt/scripts/search_that.sh &)"
    Control+Mod4 + s + Release

# screen area shot, sent directly to 'Pictures' directory
#   Shift + Print
"(/usr/bin/gnome-screenshot -a &)"
    m:0x1 + c:107

# screen area shot, sent directly to 'UI clipboard'
#  Control + Shift + Print
"(/usr/bin/gnome-screenshot -ac &)"
    m:0x1 + c:50

Any pointers anyone ?

Last edited by Cbhihe (2024-02-05 18:00:13)


I like strawberries, therefore I'm not a bot.

Offline

#2 2023-03-08 21:37:34

seth
Member
Registered: 2012-09-03
Posts: 54,252

Re: [SOLVED] Faulty key input parse on display

> cat /etc/vconsole.conf
KEYMAP=es
XKBLAYOUT=es,jp,cn
XKBVARIANT=,,

vconsole has no impact on XKB

what was supposed to be displayed as á unexpectedly becomes 'a. ü becomes "u, etc.

That's gonna be some deadkey input that's supposed to produce this? You type "'" and "a" and that ideally becomes á?
Compare

setxkbmap -print -query

between the good and bad condition and please post your Xorg log, https://wiki.archlinux.org/title/Xorg#General

Offline

#3 2023-03-16 12:42:04

Cbhihe
Member
Registered: 2017-04-09
Posts: 228

Re: [SOLVED] Faulty key input parse on display

Sorry, for not following up immediately, I had actually prepared a full response with requested info, but waited for the issue to manifest itself after the linux (6.2.2.arch1-1 -> 6.2.2.arch2-1) kernel update I installed on 2023.03.10. We are now at  6.2.6.arch1-1.

and I am scuttling my earlier prepared response, as it seems that the issue disappeared with kernel and kernel related updates. So I mark this thread as [SOLVED] even though there actually was no solution applied. 

what was supposed to be displayed as á unexpectedly becomes 'a. ü becomes "u, etc.

That's gonna be some deadkey input that's supposed to produce this? You type "'" and "a" and that ideally becomes á?

Yes, the keyboard has dead-keys incorporated so most diacriticals in West-European languages are covered. It's a standard issue "Spanish-International" QWERTY thing.

Compare

$ setxkbmap -print -query

between the good and bad conditions.

   Good:

xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete"  };
    xkb_symbols   { include "pc+es+jp:2+us:3+inet(evdev)+level3(ralt_switch)"   };
    xkb_geometry  { include "pc(pc105)" };
};
rules:      evdev
model:      pc105
layout:     es,jp,us
variant:    ,,
options:    lv3:ralt_switch

When everything is well, my ~/.local/share/xorg/Xorg.1.log shows:

$ grep -e "EE\|WW" ~/.local/share/xorg/Xorg.1.log
[    25.693] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    25.693] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    25.705] (WW) Warning, couldn't open module intel
[    25.705] (EE) Failed to load module "intel" (module does not exist, 0)
[    25.707] (WW) Falling back to old probe method for fbdev
[    25.707] (EE) open /dev/fb0: Permission denied
[    25.707] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support 

and the complete Xorg.1.log is here

    Bad:

xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"      };
    xkb_compat    { include "complete"      };
    xkb_symbols   { include "pc+es+jp:2+us:3+inet(evdev)+level3(ralt_switch)"       };
    xkb_geometry  { include "pc(pc105)"     };
};
rules:      evdev
model:      pc105
layout:     es,jp,us
variant:    ,,
options:    lv3:ralt_switch

When the issue manifests itself, my ~/.local/share/xorg/Xorg.1.log shows:

$ grep -e "EE\|WW" ~/.local/share/xorg/Xorg.1.log
[    20.517] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    20.517] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    20.533] (WW) Warning, couldn't open module intel
[    20.533] (EE) Failed to load module "intel" (module does not exist, 0)
[    20.535] (WW) Falling back to old probe method for fbdev
[    20.535] (EE) open /dev/fb0: Permission denied
[    20.535] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   955.601] (EE) event13 - DLL07BE:01 06CB:7A13 Touchpad: kernel bug: Touch jump detected and discarded.
[  2780.382] (EE) event13 - DLL07BE:01 06CB:7A13 Touchpad: kernel bug: Touch jump detected and discarded.
[  3887.621] (EE) event13 - DLL07BE:01 06CB:7A13 Touchpad: kernel bug: Touch jump detected and discarded.

and the complete Xorg.1.log is here
I believe the last 3 lines are there because I forgot to disable the touchpad when typing this post.

Last edited by Cbhihe (2023-03-16 18:04:11)


I like strawberries, therefore I'm not a bot.

Offline

#4 2023-03-18 22:30:05

Cbhihe
Member
Registered: 2017-04-09
Posts: 228

Re: [SOLVED] Faulty key input parse on display

Still trying to make sense of what's happening, and reading on Xorg, I did two things that may quite well be unrelated to the key combination failures issue:
I uninstalled xf86-video-fbdev and xf86-video-vesa and rebooted (thinking I did not need either drivers.

Before and after rebooting the only difference in output of  Xorg -configure is that mention of the the vesa and fbdev drivers disappeared from the drivers' list shown below:

$ Xorg -configure

X.Org X Server 1.21.1.7
X Protocol Version 11, Revision 0
Current Operating System: Linux HOST 6.2.6-arch1-1 #1 SMP PREEMPT_DYNAMIC Mon, 13 Mar 2023 17:02:08 +0000 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=0f2397cc-ee76-44b54238a2 rw loglevel=3 quiet mds=full acpi_rev_override=1 acpi_osi=Linux resume=/dev/disk/by-uuid/c1e198e1-db13-4834-9b86-f2d415
 
Current version of pixman: 0.42.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/USER/.local/share/xorg/Xorg.0.log", Time: Sat Mar 18 22:58:19 2023
List of video drivers:
        nvidia
        modesetting
xf86EnableIO: failed to enable I/O ports 0000-03ff (Operation not permitted)
(++) Using config file: "/home/USER/xorg.conf.new"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"


Xorg is not able to detect your mouse.
Edit the file and correct the Device.

Xorg has configured a multihead system, please check your config.

Your xorg.conf file is /home/USER/xorg.conf.new
To test the server, run 'X -config /home/USER/xorg.conf.new'

(EE) Server terminated with error (2). Closing log file.

The "multihead" mention seems right as I use the Gnome "Displays" applet to drag and place my correctly detected external monitor relative to the built-in one.

I suppose that Xorg not detecting my mouse pointer is no issue, but "xf86EnableIO: failed to enable I/O ports 0000-03ff (Operation not permitted)" and ultimately "(EE) Server terminated with error (2)." are more troubling.  I looked at a number of hits on the net including this Arch linux forum post, but could not  relate them to either my issue or the output of  Xorg -configure ...

EDIT:
Also, I see that several things co-exist on that box that may be redundant if I understood well the wiki:

extra/libevdev 1.13.0-1 [installed]
extra/xf86-input-evdev 2.10.6-3 (xorg-drivers) [installed]

and

extra/libinput 1.22.1-1 [installed]
extra/xf86-input-libinput 1.2.1-1 (xorg-drivers) [installed]

If libinput or its wrapper xf86-input-libinput are drop in replacement for libevdev or extra/xf86-input-evdev can I remove the two latter ones ?

Last edited by Cbhihe (2023-03-19 10:47:12)


I like strawberries, therefore I'm not a bot.

Offline

#5 2023-03-19 09:06:52

seth
Member
Registered: 2012-09-03
Posts: 54,252

Re: [SOLVED] Faulty key input parse on display

There're three layouts, es,jp,us - there's no toggle defined but depending on what layout is currently active, the deadkeys obviously won't work (because they're not part of eg. the default US layout)
Since

Japanese hiragana and katakana as well as Chinese pinyin input modes work flawlessly.

you're probably also using some https://wiki.archlinux.org/title/Input_method ?

=> define a group toggle and see whether cycling the layouts gets you the desired behavior, https://wiki.archlinux.org/title/Xorg/K … rd_layouts

Offline

#6 2023-03-19 16:50:52

Cbhihe
Member
Registered: 2017-04-09
Posts: 228

Re: [SOLVED] Faulty key input parse on display

Background:   now on kernel 6.2.7-arch1-1
____________________________________________

Yes, there are two IMEs installed in the Gnome ecosystem of the host. They are:
     - ibus-anthy (Anthy for Japanese), and
     - ibus-libpinyin (Libpinyin for Chinese)
as shown below:

$ pacman -Ss ibus-* | grep -e "/ibus" | grep -i installed
extra/ibus 1.5.28-1 [installed]
community/ibus-anthy 1.5.14-1 [installed]
community/ibus-libpinyin 1.15.0-1 [installed]

Following the "Input Method" wiki, I checked the three environment variables in /etc/environment:

GTK_IM_MODULE=xim
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus

and changed the first "Input Method Framework" to ibus, as described in the ibus section of the wiki.

I had set the keyboard layout group toggle key combi a long time ago in /etc/X11/xorg.conf.d/00-keyboard.conf, but just checked that it had no effect.
I am also surprised by the output (from earlier in this thread) of $ setxkbmap -print -query as it shows the 3 layouts as "es,jp,us" and not as "es,jp,cn". 
The  //etc/X11/xorg.conf.d/00-keyboard.conf file shows the correct layouts though, with "cn" in third position...

Does anybody know why this is so ?

$ cat /etc/X11/xorg.conf.d/00-keyboard.conf
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
    →        Option "XkbLayout" "es,jp,cn"
        Option "XkbModel" "pc105"
        Option "XkbVariant" ",,"
        Option "XkbOptions" "grp:win_space_toggle"
EndSection

so I went ahead and replaced the 2 last option lines with:

Option "XkbVariant" "qwerty,,"
Option "XkbOptions" "grp:lalt_lshift_toggle"

... rebooting and reporting further....
________________________________________________

After reboot the toggle key combi (Option "XkbOptions" "grp:lalt_lshift_toggle") does not work.

Neither does switching input methods with a kbd shortcut, as defined in the IBus wiki). There the method consists in setting an IBus preference, accessible from terminal by issuing $ ibus-setup.  There I tried successively to set the <Alt><Shift>Right and <Shift><Super>i keyboard shortcuts as "Next Input Method" under the General tab ... to no avail.

No clue as to why neither of those two key combi methods work.

Last edited by Cbhihe (2023-03-19 18:22:57)


I like strawberries, therefore I'm not a bot.

Offline

#7 2023-03-19 20:47:09

seth
Member
Registered: 2012-09-03
Posts: 54,252

Re: [SOLVED] Faulty key input parse on display

The  //etc/X11/xorg.conf.d/00-keyboard.conf file shows the correct layouts though, with "cn" in third position...

Does anybody know why this is so ?

the Gnome ecosystem of the host

Gnome is gonna steamroll its own config over the X11 configuration when the session starts.

After reboot the toggle key combi (Option "XkbOptions" "grp:lalt_lshift_toggle") does not work.

Which is probably reflected by

setxkbmap -print -query

On the further approach: establish a functional base, only "es" layout, no ibus.
Then introduce the other layout(s) one by one, finally ibus to see at which point (iff still) things break.

Offline

#8 2024-02-05 17:58:39

Cbhihe
Member
Registered: 2017-04-09
Posts: 228

Re: [SOLVED] Faulty key input parse on display

Resurrecting and simultaneously closing this issue as [SOLVED] (kinda).

@Seth: I had followed your suggestion to start with a clean slate only with one layout (in this case "es") no ibus and adding things little by little.
Just with this minimum config, the issue remained unchanged.
Now almost a year later and on Kernel 6.7.3-arch1-2, the issue finally disappeared going from kernel 6.6.10 to 6.7.0.
Now everything seems to have gone back to normal...
I still have no clue why things went sideways 11 months ago, so not very satisfactory a conclusion.


I like strawberries, therefore I'm not a bot.

Offline

Board footer

Powered by FluxBB