You are not logged in.

#1 2023-03-11 13:06:53

Registered: 2013-09-02
Posts: 31

[Solved] Unable to use my 2 daisy chained monitors with Xorg

Hi everyone,

P.S. I will update this top post with more info if requested in replies.

I am currently facing multiple issues with both Xorg and Wayland session under Plasma.
This thread is regarding the Xorg issue.

My machine is an ASUS laptop with dual GPU (AMD integrated and NVIDIA discrete) and I've always used Xorg for my session until Plasma 5.27.
At that point I tried using Wayland daily.

Due to issues I have in my Wayland session, I tried switching back to Xorg which worked perfectly before.
Here I find out this massive issue.

So, my setup is like this:
2nd monitor <-- DisplayPort --> 1st monitor <-- DisplayPort over USB-C --> Laptop

For unknown reasons, the 1st monitor works but display only the first frame it is presented.
It is like no new content is drawn to it. Monitor 2 works as intended.

Disabling monitor 1 just let laptop and monitor 2 behave as normal.
Disabling monitor 2 makes monitor 1 work sometimes, it is a 25% chance to work. Not sure why.
I checked `journalctl` and there is no major issue reported in the logs. I have honestly no clue where to look for.

I do have the following installed:
- Kernel: linux, linux-lts (both with the issue)
- AMD drivers: mesa, xf86-video-amdgpu, vulkan-radeon
- NVIDIA drivers: nvidia-dkms
- Plasma: the normal packages

Any suggestions of what / where should I look?

Last edited by ItachiSama (2023-03-14 18:55:22)


#2 2023-03-14 18:54:12

Registered: 2013-09-02
Posts: 31

Re: [Solved] Unable to use my 2 daisy chained monitors with Xorg

I figured out the issue was for the NVIDIA driver.

I downgraded all relevant NVIDIA packages to 525.60.11 and all started working again.

Marking this as solved.


Board footer

Powered by FluxBB