You are not logged in.

#1 2023-03-13 00:08:33

Registered: 2022-11-01
Posts: 4

AMDGPU Won't Allow Me To Set Fan Speed - 7900 XTX

Hello Everyone,

So I happen to purchased 7900 XTX not too long ago and I have been working non-stop to use it for Neural Net development and I noticed that my AMDGPU is not cooling down at 80 degree Celsius with a fan speed set to 5%. I have tried to set the pwn1_enable and pwn1 flags for setting the fan speed.

Running the followings as **ROOT** shell, not sudo:

echo "1" > /sys/class/drm/card0/device/hwmon/hwmon5/pwm1_enable
cat /sys/class/drm/card0/device/hwmon/hwmon5/pwm1_enable
# returns 2

echo "128" > /sys/class/drm/card0/device/hwmon/hwmon5/pwm1
cat /sys/class/drm/card0/device/hwmon/hwmon5/pwm1
# returns 0

I have tried literally every tools, software, documentation, and even AMDGPU module parameters set at boot with: "amdgpu.ppfeaturemask=0xffffffff amdgpu.hw_i2c=1" in grub in GRUB_CMDLINE_LINUX parameters.

None of them make any difference and I am scratching my head here.

I have tried reading the following docs and Q/A: … untu-20-04 … ith-amdgpu

At this point, I am seriously considering ripping off the fan from my AMD GPU and mount a custom one to turn my card into a literal jet turbine to cool it down whether it wants to or not.

This is on threadripper 1950x, 7900 XTX AMD GPU card, 128 GB of DDR4 RAM, 4 TB NVMe, Latest Arch Linux updated (Literally updated today), and so forth.

I am hoping to hear any other advice before I have to do something drastic to solve this issue, please and thank you.

Last edited by LinuxDevCenti (2023-03-13 00:12:34)


#2 2023-03-18 17:25:57

Registered: 2022-11-01
Posts: 4

Re: AMDGPU Won't Allow Me To Set Fan Speed - 7900 XTX

Update: I have tried literally everything to tell the AMD GPU 7900 XTX to turn on the fans and it refuses to. I am ordering the parts to turn my GPU into a literal jet turbine. Wish me luck.


Board footer

Powered by FluxBB