You are not logged in.

#1 2023-03-16 21:36:15

rosslaird
Member
Registered: 2017-08-23
Posts: 9

[SOLVED] Why is my /sbin/init process called init 2015?

My system shows a process with the following name:

/sbin/init 2015'

What does the 2015 signify, and why does it have a single quotation mark after it? My understanding is that that process should just be called:

/sbin/init

The only other place I can find this 2015 with a single quotation mark is in my kernel parameters, where it is part of:

acpi_osi='Windows 2015'

Not sure if this is related in any way, but I wonder about it, as there are various proposed solutions to the question of which types of quotation marks should be used for this parameter.

Last edited by rosslaird (2023-03-17 18:45:33)

Offline

#2 2023-03-16 22:15:17

seth
Member
Registered: 2012-09-03
Posts: 52,621

Re: [SOLVED] Why is my /sbin/init process called init 2015?

It probably comes form the acpi_osi parameter and a quoting error.

cat /proc/cmdline

Online

#3 2023-03-17 00:05:45

rosslaird
Member
Registered: 2017-08-23
Posts: 9

Re: [SOLVED] Why is my /sbin/init process called init 2015?

Thanks for confirming my tentative hunch about this. I escaped the string and added double quotation marks:

\"Windows 2015\"

That takes care of the init process (no longer showing 2015), but it results in cmdline output that shows just the escape character (and not "Windows 2015"):

root=UUID=XXXX rw loglevel=3 quiet ibt=off nvidia_drm.modeset=1 acpi_osi=\ initrd=\initramfs-linux.img

However if I remove the escape character but keep the double quotation marks, grub-mkconfig halts (because of the nested double quotation marks). And if I replace the double quotation marks with single quotation marks (escaped or not), this results in either the empty escape character as above or the issue I started with (2015'). I wonder what the correct format could be?

Last edited by rosslaird (2023-03-17 01:10:25)

Offline

#4 2023-03-17 06:34:39

seth
Member
Registered: 2012-09-03
Posts: 52,621

Re: [SOLVED] Why is my /sbin/init process called init 2015?

Please post /proc/cmdline w/ the escapes and explain how and where exactly you add the parameters.
Ftr, https://wiki.archlinux.org/title/Kernel_parameters

Online

#5 2023-03-17 06:46:49

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,771
Website

Re: [SOLVED] Why is my /sbin/init process called init 2015?

This works for me:

$ grep acpi /etc/default/grub                                                
GRUB_CMDLINE_LINUX="acpi=\"Windows 2015\""
$ doas grub-mkconfig 2>/dev/null | awk '/acpi/&&/linux/'
	linux	/arch/boot/vmlinuz-linux-lts root=UUID=452d4552-9dee-4eef-850a-29a3fbdd2827 rw rootflags=subvol=arch acpi="Windows 2015" loglevel=3 quiet
		linux	/arch/boot/vmlinuz-linux-lts root=UUID=452d4552-9dee-4eef-850a-29a3fbdd2827 rw rootflags=subvol=arch acpi="Windows 2015" loglevel=3 quiet
		linux	/arch/boot/vmlinuz-linux-lts root=UUID=452d4552-9dee-4eef-850a-29a3fbdd2827 rw rootflags=subvol=arch acpi="Windows 2015" loglevel=3 quiet
$

Reference: https://unix.stackexchange.com/question … line-linux ← top link for 'acpi_osi='Windows 2015' linux' at startpage.com.

Offline

#6 2023-03-17 08:22:20

Raynman
Member
Registered: 2011-10-22
Posts: 1,539

Re: [SOLVED] Why is my /sbin/init process called init 2015?

rosslaird wrote:

as there are various proposed solutions to the question of which types of quotation marks should be used for this parameter.

The kernel docs (linked from Archwiki page) only mention double quotes; grub-mkconfig uses shell scripts, so the double quotes need to be escaped as Head_on_a_Stick shows, or you can use single quotes for the grub variable:

GRUB_CMDLINE_LINUX='acpi="Windows 2015"'

Offline

#7 2023-03-17 17:18:14

rosslaird
Member
Registered: 2017-08-23
Posts: 9

Re: [SOLVED] Why is my /sbin/init process called init 2015?

Thanks for all the help, everyone. I always try to get as far as I can on my own, and when I get stuck the community responses really help me narrow things down. In this case, I was getting mixed up between my grub config and my rEFInd config. But I think I'm getting closer. Here's what I'm seeing:

$ cat /proc/cmdline
root=UUID=XXXX rw loglevel=3 quiet ibt=off nvidia_drm.modeset=1 acpi_osi=! 'acpi_osi=Windows 2015' i915.enable_guc=2 initrd=\initramfs-linux.img

Does the wrapping of the second acpi string above seem right? The 2015' appended to /sbin/init (my original issue) is back with this setup.
Here's what I have in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 acpi_osi=! acpi_osi=\"Windows 2015\" quiet ibt=off nvidia_drm.modeset=1 lsm=landlock,lockdown,yama,integrity,apparmor,bpf"
GRUB_CMDLINE_LINUX="i915.enable_guc=2"

Also, I've been using acpi_osi=, whereas others in this thread are using acpi=. I'm not sure what that implies or which one I should be using (I'm on a Dell XPS from 2015).

Last edited by rosslaird (2023-03-17 17:27:56)

Offline

#8 2023-03-17 18:44:57

rosslaird
Member
Registered: 2017-08-23
Posts: 9

Re: [SOLVED] Why is my /sbin/init process called init 2015?

My issue is clearly not about /sbin/init but rather about the way I am configuring and booting my system with rEFInd. I need to dig into that a bit more to get some clarity about what I'm doing and what results. (The kernel parameters have the intended result if I use the rEFInd option that loads grub directly, but they do not work -- so far -- with any other rEFInd boot option). I'm going to mark this thread as resolved. As usual, user error is the main problem. This is why I resist posting to the forum for help: I always know the answer is going to be user error, or user ignorance... Thanks for all the pointers. They've helped me figure out where to go from here.

Last edited by rosslaird (2023-03-17 19:16:40)

Offline

#9 2023-03-17 21:17:56

seth
Member
Registered: 2012-09-03
Posts: 52,621

Re: [SOLVED] Why is my /sbin/init process called init 2015?

I've been using acpi_osi=, whereas others in this thread are using acpi=.

I think HoaS flubbed that and Raynman copypasta'd the flub.
It's "acpi_osi", but the specific token is irrelenvant to the subject at hand.

My issue is … about the way I am configuring and booting my system with rEFInd.

https://wiki.archlinux.org/title/REFInd … parameters
There's a note on quotes.

This is why I resist posting to the forum for help: I always know the answer is going to be user error

So what? At the end of the day you want the problem solved and two brains are better than none wink

Online

#10 2023-03-17 21:41:54

rosslaird
Member
Registered: 2017-08-23
Posts: 9

Re: [SOLVED] Why is my /sbin/init process called init 2015?

Thanks. And sheesh, the rEFIfind note is right there, in plain view, showing my exact use case!

Offline

Board footer

Powered by FluxBB