You are not logged in.

#1 2023-03-17 17:19:25

Registered: 2023-03-17
Posts: 2

[SOLVED] GRUB installation after hardware change /EFI Dependency error

Dear all,

I am running my Arch installation(s) for several years now and always found help here on the forums or on the wiki for every imaginable issue. So, first of all: BIG THANKS to all the developers and the Arch community!

But now...


I had to migrate a hard drive with an Arch installation after killing a laptop by spilling water on it... the new laptop is essentially the same model (Thinkpad T460s). On startup initially nothing happened but I was able to boot from a liveUSB-Arch, run tests on the HDD to confirm that it's not broken and mount it. After some reading here I learned that I probably have to re-install my GRUB bootloader to update the drive UUIDs in the GRUB configuration. However, after trying my best doing so following the GRUB wiki article the boot process runs into a [DEPEND] Dependency failed for /boot/efi error and then falls into emergency mode.


After opening nvme0n1p3 with

cryptsetup luksOpen /dev/nvme0n1p3 arch

the partitioning looks like

|-- nvme0n1p1  [EFI partition, "EF00" partition type according to gdisk]
|-- nvme0n1p2  [boot partition]
|-- nvme0n1p3  [LVM on LUKS encrypted "main" partition]
    |-- arch
        |-- vg0-SWAP
        |-- vg0-ROOT
        |-- vg0-HOME
        |-- vg0-USR

I then mounted vg0-ROOT, chrooted into it and mounted the boot and EFI partition within the chroot environment:

root@archiso # mount /dev/vg0/ROOT /root
root@archiso # arch-chroot /root
[root@archiso /] # mount /dev/nvme0n1p2 /boot
[root@archiso /] # mount /dev/nvme0n1p1 /boot/efi

grub-mkconfig executes without any error, so does the following

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Arch

After exiting the chroot environment and rebooting, GRUB is working, I can finally unlock the LUKS drive as usual and Arch seems to boot normally. Until the error message

A start job is running for /dev/disk/by-uuid/9992-1704 ...
[TIME] Timed out waiting for device /dev/disk/by-uuid/9992-1704
[DEPEND] Dependency failed for /boot/efi
[DEPEND] Dependency failed for Local File System
[DEPEND] Dependency failed for File System Check on /dev/disk/by-uuid/9992-1704

appears and the system falls into emergency mode.

Indeed, there is no 9992-1704 UUID under /dev/disk/by-uuid/. According to the blkid output the UUID of the nvme0n1p1 EFI partition is A0D2-73DE. However, none of these UUIDs is mentioned in the grub.cfg.

Which mistake did I do setting up GRUB here?


PS: Don't know if this is a newbie issue, sry wink

Last edited by TinkerToadie (2023-03-17 18:20:22)


#2 2023-03-17 18:03:47

Registered: 2012-09-01
Posts: 10,189

Re: [SOLVED] GRUB installation after hardware change /EFI Dependency error

That error is long past GRUB. Check /etc/fstab.


#3 2023-03-17 18:19:42

Registered: 2023-03-17
Posts: 2

Re: [SOLVED] GRUB installation after hardware change /EFI Dependency error

Changed the UUID of the EFI partition in the /etc/fstab from 9992-1704 to A0D2-73DE. Problem solved... That was rediculously easy, thank you!

Last edited by TinkerToadie (2023-03-17 18:21:04)


Board footer

Powered by FluxBB