You are not logged in.

#1 2023-03-16 11:40:21

kuri0
Member
Registered: 2023-03-16
Posts: 7

Help debugging weird program hangs

Since last week I have been experiencing the weird problem that certain programs hang or timeout but only under very specific conditions. The programs for which the problem occur as far as I have noticed are,

(1) Firefox: It takes several minutes to start while before it was just almost instantly. After it starts it behaves pretty much normal.
(2) RabbitMQ: It's very slow to respond. So slow that certain programmes that I am running that depend on it timeout. Also when shutting down the system there is a message that a stop job is still running for RabbitMQ and this might take several minutes before the system actually shuts down.

I thought these problems started after performing a system upgrade last Friday (10-03-23), but I tried downgrading all the packages to a snapshot of the repository from an earlier date (06-03-23) on which I had last upgraded my system and when I thought I remembered that everything was still working normally but after the downgrade the problems were still there, so I just upgraded everything to the most recent version again. As I mentioned the problems only occur under very specific conditions, namely when connected to my home WiFi network and while simultaneously connected to a VPN. If I turn off the VPN all the problems disappear. Also when I am connected to my university WiFi network all the problems disappear even if I am simultaneously connected to the same VPN.

I tried debugging it myself but it's difficult to figure out exactly what's happening. I wasn't able to find any logs from Firefox that might explain what is happening but I did find a lot of these lines in the systemd journal which come from RabbitMQ:

 rabbitmq[839]: /usr/lib/erlang/erts-13.1.3/bin/inet_gethost[839]: WARNING:Timeout waiting for child process to die, ignoring child (pid = 18943) 

There seems to be one of these lines approximately every minute if I am connected to my home network and the VPN at the same time. If I disconnect the VPN or am on the university network they stop appearing. Also I noticed that running

 dnsdomainname 

from inetutils it hangs under the conditions where I am experiencing the problems and otherwise it returns immediately.

Does anyone know what I could try to further diagnose this problem?

Offline

#2 2023-03-16 13:37:52

seth
Member
Registered: 2012-09-03
Posts: 38,696

Re: Help debugging weird program hangs

problems only occur … when connected to my home WiFi network and while simultaneously connected to a VPN. If I turn off the VPN all the problems disappear. Also when I am connected to my university WiFi network all the problems disappear even if I am simultaneously connected to the same VPN.

dnsdomainname …  hangs under the conditions where I am experiencing the problems and otherwise it returns immediately

Compare

ip a
ip r
dig google.com

in those contexts and also post

hostnamectl
resolvectl

Last edited by seth (2023-03-16 13:38:49)

Offline

#3 2023-03-17 14:14:22

kuri0
Member
Registered: 2023-03-16
Posts: 7

Re: Help debugging weird program hangs

Thanks for your reply! Here are the outputs for the 4 different context:

At home, no VPN (no problems):

> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 34:c9:3d:79:8c:27 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.220/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20f3
       valid_lft 42987sec preferred_lft 42987sec
    inet6 fde8:1cee:5c22::bb2/128 scope global dynamic noprefixroute 
       valid_lft 42992sec preferred_lft 42992sec
    inet6 fde8:1cee:5c22:0:75d:18b5:c4ab:c2a3/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::954a:5eb5:e00:5f74/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

> ip r
default via 192.168.1.1 dev wlp0s20f3 proto dhcp src 192.168.1.220 metric 600 
192.168.1.0/24 dev wlp0s20f3 proto kernel scope link src 192.168.1.220 metric 600 

> dig google.com

; <<>> DiG 9.18.12 <<>> google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60378
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;google.com.			IN	A

;; ANSWER SECTION:
google.com.		67	IN	A	142.251.39.110

;; Query time: 10 msec
;; SERVER: 127.0.0.53#53(127.0.0.53) (UDP)
;; WHEN: Thu Mar 16 21:45:24 CET 2023
;; MSG SIZE  rcvd: 55

> resolvectl
Global
           Protocols: +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
    resolv.conf mode: foreign
Fallback DNS Servers: 1.1.1.1#cloudflare-dns.com 9.9.9.9#dns.quad9.net
                      8.8.8.8#dns.google 2606:4700:4700::1111#cloudflare-dns.com
                      2620:fe::9#dns.quad9.net 2001:4860:4860::8888#dns.google
          DNS Domain: lan

Link 2 (wlp0s20f3)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6 mDNS/IPv4 mDNS/IPv6
         Protocols: +DefaultRoute +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 192.168.1.1
       DNS Servers: 192.168.1.1
        DNS Domain: lan

At home, with VPN (problems):

> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 34:c9:3d:79:8c:27 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.220/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20f3
       valid_lft 42711sec preferred_lft 42711sec
    inet6 fde8:1cee:5c22::bb2/128 scope global dynamic noprefixroute 
       valid_lft 42717sec preferred_lft 42717sec
    inet6 fde8:1cee:5c22:0:75d:18b5:c4ab:c2a3/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::954a:5eb5:e00:5f74/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
4: wgivpn: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1420 qdisc noqueue state UNKNOWN group default qlen 1000
    link/none 
    inet 172.27.186.235/32 scope global wgivpn
       valid_lft forever preferred_lft forever

> ip r
default via 192.168.1.1 dev wlp0s20f3 proto dhcp src 192.168.1.220 metric 600 
192.168.1.0/24 dev wlp0s20f3 proto kernel scope link src 192.168.1.220 metric 600 

> dig google.com

; <<>> DiG 9.18.12 <<>> google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16505
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;google.com.			IN	A

;; ANSWER SECTION:
google.com.		300	IN	A	142.250.179.206

;; Query time: 33 msec
;; SERVER: 127.0.0.53#53(127.0.0.53) (UDP)
;; WHEN: Thu Mar 16 21:47:30 CET 2023
;; MSG SIZE  rcvd: 55


> resolvectl
Global
           Protocols: +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
    resolv.conf mode: foreign
Fallback DNS Servers: 1.1.1.1#cloudflare-dns.com 9.9.9.9#dns.quad9.net
                      8.8.8.8#dns.google 2606:4700:4700::1111#cloudflare-dns.com
                      2620:fe::9#dns.quad9.net 2001:4860:4860::8888#dns.google
          DNS Domain: lan

Link 2 (wlp0s20f3)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6 mDNS/IPv4 mDNS/IPv6
         Protocols: +DefaultRoute +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 192.168.1.1
       DNS Servers: 192.168.1.1
        DNS Domain: lan

Link 4 (wgivpn)
    Current Scopes: DNS
         Protocols: +DefaultRoute +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 10.0.254.2
       DNS Servers: 10.0.254.2
        DNS Domain: ~.

At university, no VPN (no problems):

> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 34:c9:3d:79:8c:27 brd ff:ff:ff:ff:ff:ff
    inet 145.107.133.246/23 brd 145.107.133.255 scope global dynamic noprefixroute wlp0s20f3
       valid_lft 2361sec preferred_lft 2361sec
    inet6 fe80::469b:36ef:a47a:4826/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

> ip r
default via 145.107.132.1 dev wlp0s20f3 proto dhcp src 145.107.133.246 metric 20600 
145.107.132.0/23 dev wlp0s20f3 proto kernel scope link src 145.107.133.246 metric 600 

> dig google.com

; <<>> DiG 9.18.12 <<>> google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20587
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;google.com.			IN	A

;; ANSWER SECTION:
google.com.		172	IN	A	142.251.36.14

;; Query time: 6 msec
;; SERVER: 127.0.0.53#53(127.0.0.53) (UDP)
;; WHEN: Fri Mar 17 15:08:30 CET 2023
;; MSG SIZE  rcvd: 55


> resolvectl
Global
           Protocols: +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
    resolv.conf mode: foreign
  Current DNS Server: 1.1.1.1#cloudflare-dns.com
Fallback DNS Servers: 1.1.1.1#cloudflare-dns.com 9.9.9.9#dns.quad9.net
                      8.8.8.8#dns.google 2606:4700:4700::1111#cloudflare-dns.com
                      2620:fe::9#dns.quad9.net 2001:4860:4860::8888#dns.google

Link 2 (wlp0s20f3)
    Current Scopes: LLMNR/IPv4 LLMNR/IPv6 mDNS/IPv4 mDNS/IPv6
         Protocols: -DefaultRoute +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported

At university, with VPN (no problems):

> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 34:c9:3d:79:8c:27 brd ff:ff:ff:ff:ff:ff
    inet 145.107.133.246/23 brd 145.107.133.255 scope global dynamic noprefixroute wlp0s20f3
       valid_lft 2301sec preferred_lft 2301sec
    inet6 fe80::469b:36ef:a47a:4826/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
5: wgivpn: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1420 qdisc noqueue state UNKNOWN group default qlen 1000
    link/none 
    inet 172.27.180.250/32 scope global wgivpn
       valid_lft forever preferred_lft forever

> ip r
default via 145.107.132.1 dev wlp0s20f3 proto dhcp src 145.107.133.246 metric 600 
145.107.132.0/23 dev wlp0s20f3 proto kernel scope link src 145.107.133.246 metric 600 

> dig google.com

; <<>> DiG 9.18.12 <<>> google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26905
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;google.com.			IN	A

;; ANSWER SECTION:
google.com.		300	IN	A	142.250.179.142

;; Query time: 23 msec
;; SERVER: 127.0.0.53#53(127.0.0.53) (UDP)
;; WHEN: Fri Mar 17 15:09:27 CET 2023
;; MSG SIZE  rcvd: 55


> resolvectl
Global
           Protocols: +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
    resolv.conf mode: foreign
Fallback DNS Servers: 1.1.1.1#cloudflare-dns.com 9.9.9.9#dns.quad9.net
                      8.8.8.8#dns.google 2606:4700:4700::1111#cloudflare-dns.com
                      2620:fe::9#dns.quad9.net 2001:4860:4860::8888#dns.google

Link 2 (wlp0s20f3)
    Current Scopes: LLMNR/IPv4 LLMNR/IPv6 mDNS/IPv4 mDNS/IPv6
         Protocols: -DefaultRoute +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported

Link 5 (wgivpn)
    Current Scopes: DNS
         Protocols: +DefaultRoute +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 10.0.254.2
       DNS Servers: 10.0.254.2
        DNS Domain: ~.

And once the output of hostnamectl (since it was the same in all contexts apart from the Boot ID, probably since I rebooted between switching contexts):

> hostnamectl
 Static hostname: arnold-laptop
       Icon name: computer-laptop
         Chassis: laptop ?
      Machine ID: dfab8acf47c74776bd41c60f56a32dad
         Boot ID: eb1b7b737b654d7e9c50e422d57e5de8
Operating System: Arch Linux
          Kernel: Linux 6.2.6-arch1-1
    Architecture: x86-64
 Hardware Vendor: HP
  Hardware Model: HP EliteBook 830 G7 Notebook PC
Firmware Version: S70 Ver. 01.01.07

Offline

#4 2023-03-17 17:06:05

seth
Member
Registered: 2012-09-03
Posts: 38,696

Re: Help debugging weird program hangs

home+vpn has dig respond in 33ms
The obvious difference is that the uni network doesn't provide a local DNS, so uni+vpn only has the VPN DNS and the fallback.

What if you reject the dhcp provided DNS server?
(for NM, add "ignore-auto-dns=yes" to the connection)

Offline

#5 2023-03-17 20:06:35

kuri0
Member
Registered: 2023-03-16
Posts: 7

Re: Help debugging weird program hangs

seth wrote:

home+vpn has dig respond in 33ms
The obvious difference is that the uni network doesn't provide a local DNS, so uni+vpn only has the VPN DNS and the fallback.

What if you reject the dhcp provided DNS server?
(for NM, add "ignore-auto-dns=yes" to the connection)

I can try this, sure. It might very well be that the timeouts are caused by the VPN firewall blocking any DNS requests to get the hostname of the laptop (because those are directed at the lan DNS domain perhaps). I was actually already using this ignore-auto-dns for the university network because otherwise I wasn't able to connect to any university services while being connected to the VPN on the university network (because all DNS requests to university domains would be routed to the university's local DNS server which would then be blocked by the firewall of the VPN). If this fixes the problem I am still curious why I am now all of a sudden having these problems while I wasn't having any problems before (also not while being at home connected to the VPN).

Offline

#6 2023-03-17 21:23:31

seth
Member
Registered: 2012-09-03
Posts: 38,696

Re: Help debugging weird program hangs

I am still curious why I am now all of a sudden having these problems while I wasn't having any problems before

Since last week I have been experiencing

What happened last week?
Updates? To what?
Or did you change the resolver (to resolved) or its config?

Offline

#7 2023-03-19 21:47:39

kuri0
Member
Registered: 2023-03-16
Posts: 7

Re: Help debugging weird program hangs

seth wrote:

home+vpn has dig respond in 33ms
What if you reject the dhcp provided DNS server?
(for NM, add "ignore-auto-dns=yes" to the connection)

This indeed solves the problem, so thanks for the suggestion! Do you know if there's a way to switch this ignore-auto-dns option automatically based on whether you're connected to the VPN or not? Because if not connected I would still like to use the home router as primary DNS server.

seth wrote:

What happened last week?
Updates? To what?
Or did you change the resolver (to resolved) or its config?

On the morning of Friday the 10th I think I remember that everything still worked without problems while connected to the VPN at home and then on Saturday I was starting to experience problems. And in between those moments I upgraded the system, i.e.

 pacman -Syu 

The packages that were upgraded on that day are,

[2023-03-10T20:48:24+0100] [ALPM] upgraded alsa-plugins (1:1.2.7.1-1 -> 1:1.2.7.1-2)
[2023-03-10T20:48:24+0100] [ALPM] upgraded hwdata (0.367-1 -> 0.368-1)
[2023-03-10T20:48:24+0100] [ALPM] upgraded systemd-libs (253.1-2 -> 253.1-3)
[2023-03-10T20:48:24+0100] [ALPM] upgraded systemd (253.1-2 -> 253.1-3)
[2023-03-10T20:48:24+0100] [ALPM] upgraded libmfx (23.1.0-1 -> 23.1.3-2)
[2023-03-10T20:48:24+0100] [ALPM] upgraded libxau (1.0.11-1 -> 1.0.11-2)
[2023-03-10T20:48:24+0100] [ALPM] upgraded libxdmcp (1.1.4-1 -> 1.1.4-2)
[2023-03-10T20:48:24+0100] [ALPM] upgraded libice (1.1.1-1 -> 1.1.1-2)
[2023-03-10T20:48:24+0100] [ALPM] upgraded libedit (20210910_3.1-2 -> 20221030_3.1-1)
[2023-03-10T20:48:24+0100] [ALPM] upgraded sdl2 (2.26.3-1 -> 2.26.4-1)
[2023-03-10T20:48:24+0100] [ALPM] upgraded v4l-utils (1.22.1-1 -> 1.24.1-1)
[2023-03-10T20:48:25+0100] [ALPM] upgraded ffmpeg (2:5.1.2-2 -> 2:6.0-3)
[2023-03-10T20:48:25+0100] [ALPM] upgraded gtk-update-icon-cache (1:4.10.0-1 -> 1:4.10.0-3)
[2023-03-10T20:48:25+0100] [ALPM] upgraded chromium (110.0.5481.177-1 -> 111.0.5563.64-2)
[2023-03-10T20:48:25+0100] [ALPM] upgraded cmake (3.25.2-1 -> 3.25.3-1)
[2023-03-10T20:48:26+0100] [ALPM] upgraded firefox (110.0.1-1 -> 110.0.1-3)
[2023-03-10T20:48:26+0100] [ALPM] upgraded imath (3.1.6-2 -> 3.1.7-1)
[2023-03-10T20:48:26+0100] [ALPM] upgraded openexr (3.1.5-1 -> 3.1.6-1)
[2023-03-10T20:48:26+0100] [ALPM] upgraded gegl (0.4.42-2 -> 0.4.42-3)
[2023-03-10T20:48:26+0100] [ALPM] upgraded ghostscript (10.0.0-5 -> 10.0.0-6)
[2023-03-10T20:48:26+0100] [ALPM] upgraded gstreamer (1.22.0-4 -> 1.22.1-2)
[2023-03-10T20:48:26+0100] [ALPM] upgraded gst-plugins-base-libs (1.22.0-4 -> 1.22.1-2)
[2023-03-10T20:48:26+0100] [ALPM] upgraded gst-plugins-base (1.22.0-4 -> 1.22.1-2)
[2023-03-10T20:48:26+0100] [ALPM] upgraded libde265 (1.0.11-1 -> 1.0.11-2)
[2023-03-10T20:48:26+0100] [ALPM] upgraded opencv (4.7.0-5 -> 4.7.0-6)
[2023-03-10T20:48:26+0100] [ALPM] upgraded gmic (3.2.1-2 -> 3.2.1-3)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-aeson (2.1.1.0-19 -> 2.1.2.0-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-aeson-pretty (0.8.9-118 -> 0.8.9-119)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-bitvec (1.1.3.0-37 -> 1.1.3.0-38)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-pandoc-types (1.23-8 -> 1.23-9)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-vector-algorithms (0.9.0.1-37 -> 0.9.0.1-38)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-mono-traversable (1.0.15.3-114 -> 1.0.15.3-115)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-conduit (1.3.4.3-29 -> 1.3.4.3-30)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-conduit-extra (1.3.6-61 -> 1.3.6-62)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-xml-conduit (1.9.1.1-175 -> 1.9.1.1-176)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-citeproc (0.8.1-12 -> 0.8.1-13)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-commonmark-pandoc (0.2.1.3-9 -> 0.2.1.3-10)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-doctemplates (0.11-8 -> 0.11-9)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-haddock-library (1.10.0-204 -> 1.10.0-205)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-hslua-aeson (2.2.1-34 -> 2.2.1-35)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-hslua (2.2.1-33 -> 2.2.1-34)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-hslua-module-doclayout (1.0.4-83 -> 1.0.4-84)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-hslua-module-path (1.0.3-42 -> 1.0.3-43)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-hslua-module-version (1.0.3-39 -> 1.0.3-40)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-http2 (3.0.3-27 -> 3.0.3-28)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-ipynb (0.2-80 -> 0.2-81)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-libyaml (0.1.2-283 -> 0.1.2-284)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-skylighting-core (0.13.2.1-6 -> 0.13.2.1-7)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-skylighting-format-ansi (0.1-41 -> 0.1-42)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-skylighting-format-blaze-html (0.1.1-37 -> 0.1.1-38)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-skylighting-format-context (0.1.0.2-6 -> 0.1.0.2-7)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-skylighting-format-latex (0.1-41 -> 0.1-42)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-skylighting (0.13.2.1-7 -> 0.13.2.1-8)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-texmath (0.12.6-6 -> 0.12.6-7)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-yaml (0.11.11.0-1 -> 0.11.11.0-2)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-pandoc (3.0.1-13 -> 3.0.1-14)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-pandoc-lua-marshal (0.2.0-8 -> 0.2.0-9)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-pandoc-lua-engine (0.1-18 -> 0.1-19)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-servant (0.19.1-23 -> 0.19.1-24)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-wai-logger (2.4.0-205 -> 2.4.0-207)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-simple-sendfile (0.2.30-344 -> 0.2.30-345)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-warp (3.3.24-6 -> 3.3.24-7)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-wai-extra (3.1.13.0-54 -> 3.1.13.0-56)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-wai-app-static (3.1.7.4-118 -> 3.1.7.4-119)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-servant-server (0.19.2-28 -> 0.19.2-29)
[2023-03-10T20:48:27+0100] [ALPM] upgraded haskell-pandoc-server (0.1-19 -> 0.1-20)
[2023-03-10T20:48:27+0100] [ALPM] upgraded hdf5 (1.12.2-1 -> 1.12.2-2)
[2023-03-10T20:48:27+0100] [ALPM] upgraded imagemagick (7.1.0.62-1 -> 7.1.1.2-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded inetutils (2.3-1 -> 2.4-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded python-ipykernel (6.21.2-1 -> 6.21.3-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded python-urllib3 (1.26.12-1 -> 1.26.13-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded python-jupyterlab_server (2.19.0-1 -> 2.20.0-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded python-markdown-it-py (2.1.0-1 -> 2.2.0-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded jupyter-server (2.3.0-1 -> 2.4.0-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded libbpf (1.0.1-1 -> 1.1.0-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded libnm (1.42.2-1 -> 1.42.4-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded qt5-base (5.15.8+kde+r181-1 -> 5.15.8+kde+r182-1)
[2023-03-10T20:48:27+0100] [ALPM] upgraded openal (1.23.0-1 -> 1.23.0-2)
[2023-03-10T20:48:27+0100] [ALPM] upgraded libopenshot (0.3.0-2 -> 0.3.0-3)
[2023-03-10T20:48:27+0100] [ALPM] upgraded libwpe (1.14.1-1 -> 1.14.1-2)
[2023-03-10T20:48:27+0100] [ALPM] upgraded libxfont2 (2.0.6-1 -> 2.0.6-2)
[2023-03-10T20:48:27+0100] [ALPM] upgraded libxvmc (1.0.13-1 -> 1.0.13-2)
[2023-03-10T20:48:28+0100] [ALPM] upgraded linux (6.2.2.arch1-1 -> 6.2.2.arch2-1)
[2023-03-10T20:48:28+0100] [ALPM] upgraded lmdb (0.9.30-2 -> 0.9.30-3)
[2023-03-10T20:48:28+0100] [ALPM] upgraded mlt (7.12.0-4 -> 7.14.0-2)
[2023-03-10T20:48:28+0100] [ALPM] upgraded pcsclite (1.9.9-2 -> 1.9.9-3)
[2023-03-10T20:48:28+0100] [ALPM] upgraded networkmanager (1.42.2-1 -> 1.42.4-1)
[2023-03-10T20:48:28+0100] [ALPM] upgraded openscenegraph (3.6.5-17 -> 3.6.5-18)
[2023-03-10T20:48:28+0100] [ALPM] upgraded openvpn (2.6.0-1 -> 2.6.1-1)
[2023-03-10T20:48:28+0100] [ALPM] upgraded pandoc-cli (0.1-20 -> 0.1-21)
[2023-03-10T20:48:28+0100] [ALPM] upgraded pulseaudio-alsa (1:1.2.7.1-1 -> 1:1.2.7.1-2)
[2023-03-10T20:48:28+0100] [ALPM] upgraded python-fonttools (4.38.0-1 -> 4.39.0-1)
[2023-03-10T20:48:28+0100] [ALPM] upgraded python-mpmath (1.2.1-5 -> 1.3.0-1)
[2023-03-10T20:48:28+0100] [ALPM] upgraded python-pydantic (1.10.5-1 -> 1.10.6-1)
[2023-03-10T20:48:30+0100] [ALPM] upgraded tensorflow (2.11.0-2 -> 2.12.0rc1-1)
[2023-03-10T20:48:31+0100] [ALPM] upgraded python-tensorflow (2.11.0-2 -> 2.12.0rc1-1)
[2023-03-10T20:48:31+0100] [ALPM] upgraded python-tqdm (4.64.1-2 -> 4.65.0-1)
[2023-03-10T20:48:31+0100] [ALPM] upgraded qt5-webengine (5.15.12-3 -> 5.15.13-1)
[2023-03-10T20:48:31+0100] [ALPM] upgraded systemd-sysvcompat (253.1-2 -> 253.1-3)
[2023-03-10T20:48:31+0100] [ALPM] upgraded virtualbox-host-modules-arch (7.0.6-11 -> 7.0.6-12)

Downgrading these packages didn't fix the problem though. The only other thing I recently changed was that I changed the SSID of my home WiFi network and changed the authentication from WPA2/WPA3 mixed compatibility mode to WPA3 only. But I think I was already using that on the Friday morning without problems (although I don't remember that with 100% certainty).

Offline

#8 2023-03-20 09:14:31

seth
Member
Registered: 2012-09-03
Posts: 38,696

Re: Help debugging weird program hangs

Try "resolvectl revert wlp0s20f3" to remove the NIC specific DNS server
"resolvectl dns wlp0s20f3 192.168.1.1" should™ allow you to add it back (but that's interpreting the manpage, I don't use resolved at all)

Offline

#9 2023-03-21 11:27:25

kuri0
Member
Registered: 2023-03-16
Posts: 7

Re: Help debugging weird program hangs

Wouldn't that set the DNS server globally for the WiFi link instead of being connection specific (i.e. different DNS server for different WiFi networks)?

Offline

#10 2023-03-21 13:42:41

seth
Member
Registered: 2012-09-03
Posts: 38,696

Re: Help debugging weird program hangs

I don't use resolved at all

But afaics you'll use the global DNS config, ie. the fallback servers (and mayhaps the VPN one on that device)

An issue w/ your setup might be that the VPN adds a virtual NIC but doesn't move the default route to that (but I guess redirects the traffic w/ an ip table entry)
If this isn't inevitable, you might be able to avoid the DNS dance by using the proper interface for the VPN.

Offline

#11 2023-03-22 22:22:42

kuri0
Member
Registered: 2023-03-16
Posts: 7

Re: Help debugging weird program hangs

seth wrote:

I don't use resolved at all

But afaics you'll use the global DNS config, ie. the fallback servers (and mayhaps the VPN one on that device)

An issue w/ your setup might be that the VPN adds a virtual NIC but doesn't move the default route to that (but I guess redirects the traffic w/ an ip table entry)
If this isn't inevitable, you might be able to avoid the DNS dance by using the proper interface for the VPN.

Okay, thanks for your suggestions! I'll look into that.

Offline

Board footer

Powered by FluxBB