You are not logged in.

#1 2023-03-13 12:49:01

snakehater
Member
Registered: 2023-03-13
Posts: 7

[SOLVED] System logs covering login

I use emptty-git from the aur and my system logs cover both the motd and the login "page". I do not want to silence the logs at boot.

How do I make my system start the display-manager service lastly and/or silence logs AFTER the display-manager has started? I get a feeling that it already starts last but output from the bluetooth, wlan and itpsd services are piped through the same stdout as emptty-git.

Below is a picture to further explain my issue:

Showcase

Last edited by snakehater (2024-03-05 16:35:56)

Offline

#2 2023-03-13 13:18:15

schard
Forum Moderator
From: Hannover
Registered: 2016-05-06
Posts: 2,021
Website

Re: [SOLVED] System logs covering login

The kernel is printing the log messages to TTY1 where you apparently also run your console login.
You have the following options.

1) Disable kernel logging to the console entirely.
2) Implement a service that alters the kernel log level once getty is being started to suppress messages from thereon.

I have no clue what display-manager you're talking about. The issue is entirely TTY-related.
However, a service with a respective dependency on $DISPLAY_MANAGER might solve this issue as well.


macro_rules! yolo { { $($tokens:tt)* } => { unsafe { $($tokens)* } }; }

Offline

#3 2023-03-22 09:11:04

snakehater
Member
Registered: 2023-03-13
Posts: 7

Re: [SOLVED] System logs covering login

I made a service to invoke `sysctl kernel.printk='0 4 0 4'` after the service `display-manager.service`, after this the problem is solved.

Last edited by snakehater (2023-03-22 09:11:27)

Offline

Board footer

Powered by FluxBB