You are not logged in.

#1 2006-11-20 01:30:19

Registered: 2006-11-11
Posts: 13

Intel IPW3934 wireless lan adaptor

I've followed the Wiki wireless setup for this. Everything looks alright, except the adaptor isn't recognised.

At boot, STARTING NETWORK gives error:
SET failed on device eth2. No such device.

iwconfig gives:
lo        no wireless extensions.
eth0      no wireless extensions.
irda0     no wireless extensions.
eth1      no wireless extensions.
sit0      no wireless extensions.

Directory  /sys/class/net contains only the sub-dirs:
eth0/  eth1/   irda0/   lo/   sit0/

(eth0 being my wired LAN adaptor and eth1 the ieee1394 port)

and dmesg gives:
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno>
ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux, 1.0.12dmpr
ipw3945: Copyright(c) 2003-2006 Intel Corporation
ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection
eth0: Tigon3 [partno(BCM95752m)(PCI Express) 10/100/1000BaseT Ethernet 00:16:36:6a:4b:0e
tg3: eth0: Link is up at 100 Mbps, full duplex.
eth1394: eth1: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00061b002023a42f]

For some reason, the 3945 adaptor  isn't  assigned the interface name  eth2, or anything else.

/etc/rc.conf contains lines:
MODULES=(fglrx ipw3945)
#wlan_eth2="eth2 essid My_WLAN key xxxxxxxxxxxxxx"
INTERFACES=(lo eth0 eth2)
DAEMONS=(syslog-ng network netfs ipw3945d crond)

and /etc/conf.d/wireless contains lines:
wlan_eth2="eth2 mode managed essid My_WLAN key xxxxxxxxxxxxx"

lsmod produces:
ipw3945               201252  1
ieee80211              29640  1 ipw3945
ieee80211_crypt         5120  1 ieee80211

lspci -vb produces:
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
        Subsystem: Intel Corporation Thinkpad X60s
        Capabilities: [140] Device Serial Number cd-86-9a-ff-ff-02-13-00

and ps -ax gives:
1111 ?        R<    19:40 [ipw3945/0]
1112 ?        S<     0:00 [ipw3945/1]
1113 ?        S<     0:00 [ipw3945/0]
1114 ?        S<     0:00 [ipw3945/1]
3251 ?        S      0:00 /sbin/ipw3945d --quiet

I'd appreciate any help with what's going on here.  If the ipw3945 module is loading, and the adaptor is identified, MAC address and all, (as lspci above indicates), how come it doesn't get assigned the next interface name available, i.e. eth2?


Board footer

Powered by FluxBB