You are not logged in.

#1 2023-04-11 08:44:54

Cromagnon31
Member
Registered: 2023-04-11
Posts: 2

[REQUEST]php-sysvsem

Hello,

php-sysvsem is expected since Nextcloud 26.0.

This package does not exists in official packages of php-* suite.

Package exists in AUR's but as php82-* which implies to install php82  & php82-* packages and change Nginx/Nextcloud configuration.

Can you expect us to introduce this package?


Cromagnon31


Il vaut mieux un qui sait que dix qui cherchent / Better one who knows than ten looking.

Offline

#2 2023-04-11 08:58:38

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,828
Website

Re: [REQUEST]php-sysvsem

0 ✓ srv ~ $ LANG=C pacman -Qo /usr/lib/php/modules/sysvsem.so
/usr/lib/php/modules/sysvsem.so is owned by php 8.2.4-2
0 ✓ srv ~ $ 

Offline

#3 2023-04-11 10:30:35

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 11,585

Re: [REQUEST]php-sysvsem

It's also present in php-legacy ( currently at version 8.1.17 ) which is mentioned as required for nextclould on archwiki page for nextcloud .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#4 2023-04-11 12:09:09

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,828
Website

Re: [REQUEST]php-sysvsem

With the nextcloud 26 update, you can run nextcloud with php 8.2 as provided by the php package.

Offline

#5 2023-04-12 07:33:00

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 11,585

Re: [REQUEST]php-sysvsem

Ok, so the proposed solution is to run

pacman -Syu php

.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#6 2023-04-12 08:09:24

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,828
Website

Re: [REQUEST]php-sysvsem

Since OP already appears to be running Nextcloud ("since Nextcloud 26.0"), they should also already be running either php or php-legacy, both of which ship the extension in question.
Apart from enabling it in the respective php.ini no further action should be necessary.

0 ✓ srv ~ $ grep -n sysvsem /etc/php/php.ini
949:extension=sysvsem
0 ✓ srv ~ $ 

Last edited by schard (2023-04-12 08:11:44)

Offline

#7 2023-04-12 13:12:47

Cromagnon31
Member
Registered: 2023-04-11
Posts: 2

Re: [REQUEST]php-sysvsem

@shard

Thanks for your help but I feel a little silly...


Il vaut mieux un qui sait que dix qui cherchent / Better one who knows than ten looking.

Offline

Board footer

Powered by FluxBB