You are not logged in.

#1 2023-05-01 07:45:15

mhdry
Member
Registered: 2021-07-25
Posts: 1

meta package 'base-devel' causes problems with Ansible

Since the recent switch to the base-devel meta package, there is both a (new) meta package and the (old) package group:

$ pacman -Sgg base-devel
base-devel binutils
base-devel gcc
base-devel libtool

This causes problems when deploying an Arch Linux system with Ansible, see the bug report under: pacman: Install of group base-devel does not install member package make #6290

Offline

#2 2023-05-01 09:27:13

nl6720
The Evil Wiki Admin
Registered: 2016-07-02
Posts: 579

Re: meta package 'base-devel' causes problems with Ansible

You should open a bug report against those three packages asking for them to be removed from the group.

Offline

#3 2023-05-01 10:31:37

Allan
Pacman
From: Brisbane, AU
Registered: 2007-06-09
Posts: 11,346
Website

Re: meta package 'base-devel' causes problems with Ansible

A bug report already exists.

Offline

#4 2023-05-01 13:17:21

nl6720
The Evil Wiki Admin
Registered: 2016-07-02
Posts: 579

Re: meta package 'base-devel' causes problems with Ansible

Presumably that's FS#78108.

Looks like it's fixed in gcc 13.1.1-1, binutils 2.40-5 and libtool 2.4.7+4+g1ec8fa28-3 that are currently in the testing repo.

Offline

Board footer

Powered by FluxBB