You are not logged in.

#1 2023-05-21 11:35:50

From: Lund, Sweden
Registered: 2006-04-04
Posts: 215

archinstall stuck

Hey. I been  away for like 15 years and now been trying to install archlinux for like 12 hours. I found some solutions to a similar problem but they dont seem to work. It might have to do with gpg keys?

Ive tried:

killall gnu-gpg
pacman -Sy
pacman-key --init
pacman-key --populate archlinux

pacman -Syy archlinux-keyring

No error at this point. This is where it always got stuck during the archinstall.

However after running archinstall again it still gets stuck on the same problem:

installing archlinux-keyring.  100%
==> Appending keys from archlinux.gpg

If I do ctrl+c it says:

Could not strap in package: ['.../pacstrap' -C ...pacman.conf ... archinstall... etc]
Would you like to re-try this download: Y
mount: ... already mounted
==> Error: Failed to setup chroot /mnt/archinstall

I even tried this on two different laptops and both show the exact same problem if that's and indication of something.

If I try

           pacman -Syu

it says not enough space even though Im telling the partitioner to use the entire partition of 80gb.

Any ideas?

Last edited by riwa (2023-05-21 11:52:31)

If you must have must. Have must.
- DKE supporters about this wonderful swedish soda.


#2 2023-05-21 12:50:28

Registered: 2019-05-19
Posts: 6

Re: archinstall stuck

I'm not exactly sure but it looks like gpg issue.

Can you try

pgconf --kill gpg-agent

instead of killing process.


#3 2023-05-21 12:54:47

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 12,047

Re: archinstall stuck

Mod note: moving to archinstall subforum.

Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


#4 2023-05-21 12:57:00

Inspector Parrot
Registered: 2011-11-29
Posts: 29,754

Re: archinstall stuck

Note that the arch repos just underwent a substantial change yesterday and most mirrors are still lagging.  While the symptoms you describe do not really point to this as related, I do expect that all attempts to installed over the weekend would fail (at the pacstrap stage).

Last edited by Trilby (2023-05-21 12:57:16)

"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman


Board footer

Powered by FluxBB