You are not logged in.

#1 2023-05-22 17:24:54

laudin
Member
Registered: 2017-01-28
Posts: 16

[SOLVED] Ethernet not working RTL8111/8168/8411

I try to use my integrated ethernet, but it does not work. It does not even show up in

sudo ip link

.

This is part of lspci -v

05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
	Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
	Flags: fast devsel, IRQ 80, IOMMU group 14
	I/O ports at f000 [size=256]
	Memory at fe904000 (64-bit, non-prefetchable) [size=4K]
	Memory at fe900000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 01
	Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
	Capabilities: [170] Latency Tolerance Reporting
	Capabilities: [178] L1 PM Substates
	Kernel modules: r8169

I have also tries to follow https://wiki.archlinux.org/title/Networ … 8111/8168B where an ethernet device shows up in "ip link", but because the system stops responding for multiple second in short intervals if have not tried if ethernet is working which that configuration.

EDIT:
I forgot to mention that r8169 does not even occur anywhere in dmesg, so it seems that it will not be used, even if i try it manually with modprobe (but it is listed in lsmod).

Here are the logs for r8168:

[   16.083146] r8168: loading out-of-tree module taints kernel.
[   16.083246] r8168: module verification failed: signature and/or required key missing - tainting kernel
[   16.085068] r8168 Gigabit Ethernet driver 8.051.02-NAPI loaded
[   16.235157] r8168: This product is covered by one or more of the following patents: US6,570,884, US6,115,776, and US6,327,625.
[   16.237176] r8168  Copyright (C) 2022 Realtek NIC software team <nicfae@realtek.com> 
[   16.255408] r8168 0000:05:00.0 enp5s0: renamed from eth0
[   28.299686] r8168 0000:05:00.0 enp5s0: test_phy_ocp ResetPhyType = 0x02
[   45.792599] r8168 0000:05:00.0 enp5s0: test_phy_ocp ResetPhyType = 0x02
[   62.849560] r8168 0000:05:00.0 enp5s0: test_phy_ocp ResetPhyType = 0x02
[   79.910964] r8168 0000:05:00.0 enp5s0: test_phy_ocp ResetPhyType = 0x02

Last edited by laudin (2023-05-22 20:32:21)

Offline

#2 2023-05-22 19:06:22

seth
Member
Registered: 2012-09-03
Posts: 52,561

Re: [SOLVED] Ethernet not working RTL8111/8168/8411

sudo ip link

Don't sudo what does not need to be sudo'd.
Also the r8168 log you printed suggests it is actually available as enp5s0?

Here are the logs for r8168:

Please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'f:1=<-' ix.io

Also

ip a

and the output of

find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f

If you've no other network connection on that device, redirect the journal into a file instead of ix.io and upload that file somewhere however you can.

Online

#3 2023-05-22 20:31:17

laudin
Member
Registered: 2017-01-28
Posts: 16

Re: [SOLVED] Ethernet not working RTL8111/8168/8411

Thanks for you fast response.
In the meantime I have read this page https://wiki.archlinux.org/title/Talk:N … n/Ethernet where he hints to iommu, which was the solution for me.
After activating iommu via kernel command line the ethernet link works as expected.
Anyway thanks for you help.

Offline

#4 2023-05-22 20:41:52

Fixxer
Member
From: Poland
Registered: 2011-08-29
Posts: 217

Re: [SOLVED] Ethernet not working RTL8111/8168/8411

I have had similar issues with Gigabyte motherboard long time ago. BIOS setting IOMMU to "on" is still sufficient (rev 06). Check your BIOS settings.

Offline

#5 2023-05-22 21:06:57

laudin
Member
Registered: 2017-01-28
Posts: 16

Re: [SOLVED] Ethernet not working RTL8111/8168/8411

IOMMU option in the bios was already enabled.

Offline

Board footer

Powered by FluxBB