You are not logged in.

#1 2023-05-23 09:14:22

Fetchmyselfadam
Member
Registered: 2023-05-23
Posts: 3

New kernel not loading (Old one is?) [SOLVED]

I just performed a full system upgrade. this updated the kernel, too.
There are modules in the tree for the new kernel, but the old kernel is being booted, of which does Not contain any modules.
I use EFISTUB to boot.
I need the new kernel to load.
Help???

Last edited by Fetchmyselfadam (2023-05-23 11:21:20)

Offline

#2 2023-05-23 09:36:04

Fetchmyselfadam
Member
Registered: 2023-05-23
Posts: 3

Re: New kernel not loading (Old one is?) [SOLVED]

I completely apologize for my mishaps..

Hard to explain by me... but I had /boot on the root filesystem.
However I had all of my linux images on a separate /boot partition.
I installed the kernel update onto the /boot that is on the root filesystem.

I mounted the separate boot partition to the root then I reinstalled the kernel.

Thank you for the pre-delievered help wink

Offline

#3 2023-05-23 11:09:08

seth
Member
Registered: 2012-09-03
Posts: 54,271

Re: New kernel not loading (Old one is?) [SOLVED]

If it helps you, it's a rather common mistake.
You probably want to clear the mountpoint (the unmounted /boot directory) to avoid future confusion.

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

#4 2023-05-23 11:21:00

Fetchmyselfadam
Member
Registered: 2023-05-23
Posts: 3

Re: New kernel not loading (Old one is?) [SOLVED]

Yep, I did that... thanks seth.

Offline

Board footer

Powered by FluxBB