You are not logged in.

#1 2023-05-22 10:03:12

Halano
Member
From: Egypt
Registered: 2023-02-07
Posts: 18
Website

Having a black screen after boot into bash

Here my grub boot menu

menuentry 'Linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-2acd4337-33c5-4bea-b232-b369371aa4ef' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos4'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  2acd4337-33c5-4bea-b232-b369371aa4ef
	else
	  search --no-floppy --fs-uuid --set=root 2acd4337-33c5-4bea-b232-b369371aa4ef
	fi
	#echo	'Loading Linux linux ...'
	linux	/boot/vmlinuz-linux root=UUID=2acd4337-33c5-4bea-b232-b369371aa4ef rw  loglevel=3 quiet
	#echo	'Loading initial ramdisk ...'
	init=/bin/bash
}

I want to boot into sh or bash prompt,but i get black screen ?
or even if there way to boot into tty without that bloatware systemd.


HalanoSiblee The Smart Moth

Offline

#2 2023-05-22 10:29:45

schard
Forum Moderator
From: Hannover
Registered: 2016-05-06
Posts: 2,013
Website

Re: Having a black screen after boot into bash

root=/bin/bash is a parameter for the linux kernel, not for Grub2.
Hence you'd want to place it on the same line as the other kernel parameters.

Update:
It's init=/bin/bash of course.

Last edited by schard (2023-05-23 13:42:25)


macro_rules! yolo { { $($tokens:tt)* } => { unsafe { $($tokens)* } }; }

Offline

#3 2023-05-23 11:23:56

Halano
Member
From: Egypt
Registered: 2023-02-07
Posts: 18
Website

Re: Having a black screen after boot into bash

it didn't work still have black screen
Can you show me example ?


HalanoSiblee The Smart Moth

Offline

#4 2023-05-23 12:41:09

seth
Member
Registered: 2012-09-03
Posts: 52,527

Re: Having a black screen after boot into bash

schard wrote:

place it on the same line as the other kernel parameters

This line…

linux	/boot/vmlinuz-linux root=UUID=2acd4337-33c5-4bea-b232-b369371aa4ef rw  loglevel=3 quiet
schard also wrote:

root=/bin/bash

which is an obvious brainfart, what happens when you start w/ one answer ("put it into the line w/ root=…") and then change yoru mind midway through wink
It's still "init=/bin/bash"

Offline

Board footer

Powered by FluxBB