You are not logged in.

#1 2023-05-24 13:54:53

daniel_shub
Member
Registered: 2012-06-21
Posts: 82

Error: chroot ... is not at version v5

I am trying to chroot into a container with arch-nspawn container and am getting the following error:

$ sudo arch-nspawn /chroot/base-devel/root
==> ERROR: chroot '/chroot/base-devel/root' is not at version v5. Please rebuild.

I am not sure from the error what is not at version v5 and needs to be rebuilt.

$ chroot --version
chroot (GNU coreutils) 9.3
$ systemd-nspawn --version
systemd 253 (253.4-1-arch)
$ pacman -Q devtools
devtools 1:1.0.0-1

Offline

#2 2023-05-24 13:56:51

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,544

Re: Error: chroot ... is not at version v5

The chroot itself is not at version 5. It has nothing to do with any of the programs.

Online

#3 2023-05-24 14:01:45

daniel_shub
Member
Registered: 2012-06-21
Posts: 82

Re: Error: chroot ... is not at version v5

Scimmia wrote:

The chroot itself is not at version 5. It has nothing to do with any of the programs.

I had no idea that chroot had versions. Is my only choice to fully reinstall all my chroot environments?

Offline

#4 2023-06-02 10:34:45

analbeard
Member
From: London
Registered: 2014-11-07
Posts: 48

Re: Error: chroot ... is not at version v5

Did you ever figure this out? I'm also hitting the same problem with Paru.


Late 2016 Dell XPS15 | i7-6700HQ | 16GB DDR4 | Samsung PM961 NVMe 512Gb SSD
LightDM/i3 | rEFInd | linux-ck

Offline

#5 2023-06-02 11:16:28

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,846
Website

Re: Error: chroot ... is not at version v5


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB