You are not logged in.

#1 2023-05-24 21:59:04

OsakiTsukiko
Member
Registered: 2023-05-06
Posts: 17

Automounting external drives fails

I recently reinstalled Arch (with gnome) and nautilus won't even display my usbs. They only show up if I open Gnome Disks and if I try to open them I get the following errors:

You do not have permissions necessary to view the contents of "USB NAME"
Message recipient disconnected from message bus without replying

I get the same behavior in PCManFM (tho only the 2nd error shows up)
The only way I found to mount the drives is to use mount /dev/... destination

Thanks, Osaki.


- Thanks, Osaki.

Offline

#2 2023-05-24 22:16:31

seth
Member
Registered: 2012-09-03
Posts: 52,621

Re: Automounting external drives fails

How do you start gnome?

loginctl session-status

Do you get udisks related error in the system journal?

Offline

#3 2023-05-25 02:16:47

GuangDai
Member
Registered: 2022-01-28
Posts: 6

Re: Automounting external drives fails

Offline

#4 2023-05-26 05:54:44

OsakiTsukiko
Member
Registered: 2023-05-06
Posts: 17

Re: Automounting external drives fails

> How do you start gnome? 
gdm (gdm-prime) starts it as far as I know

> loginctl session-status 

3 - osaki (1000)
           Since: Fri 2023-05-26 08:11:52 EEST; 32min ago
          Leader: 1145 (gdm-session-wor)
            Seat: seat0; vc2
             TTY: tty2
         Service: gdm-password; type x11; class user
           State: active
            Unit: session-3.scope
                  ├─1145 "gdm-session-worker [pam/gdm-password]"
                  ├─1186 /usr/lib/gdm-x-session --run-script /usr/bin/gnome-session
                  ├─1188 /usr/lib/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -novtswitch -verbose 3
                  └─1202 /usr/lib/gnome-session-binary

May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0):
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0): DFP-2: disconnected
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0): DFP-2: Internal DisplayPort
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0): DFP-2: 2670.0 MHz maximum pixel clock
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0):
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0): DFP-3: disconnected
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0): DFP-3: Internal TMDS
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0): DFP-3: 165.0 MHz maximum pixel clock
May 26 08:20:38 yoru /usr/lib/gdm-x-session[1188]: (--) NVIDIA(GPU-0):

> Do you get udisks related error in the system journal? 

May 26 08:39:57 yoru systemd[1]: Starting Disk Manager...
May 26 08:39:57 yoru udisksd[7875]: udisks daemon version 2.9.4 starting
May 26 08:39:57 yoru dbus-daemon[561]: [system] Successfully activated service 'org.freedesktop.UDisks2'
May 26 08:39:57 yoru systemd[1]: Started Disk Manager.
May 26 08:39:57 yoru udisksd[7875]: Acquired the name org.freedesktop.UDisks2 on the system message bus
May 26 08:39:57 yoru dleyna-renderer-service[7750]: dLeyna: Exit
May 26 08:39:57 yoru dleyna-renderer-service[7864]: dLeyna: Exit
May 26 08:39:57 yoru dleyna-renderer-service[7826]: dLeyna: Exit
May 26 08:39:58 yoru udisksd[7875]: Error reading global mount options config file /etc/udisks2/mount_options.conf: Key file does not start with a group
May 26 08:39:58 yoru ntfs-3g[7900]: Version 2022.10.3 external FUSE 29
May 26 08:39:58 yoru ntfs-3g[7900]: Mounted /dev/sda (Read-Write, label "MyUSB", NTFS 3.1)
May 26 08:39:58 yoru udisksd[7875]: udisksd: libmount/src/hook_mount.c:480: hook_attach_target: Assertion `api->fd_tree >= 0' failed.
May 26 08:39:58 yoru ntfs-3g[7900]: Cmdline options: rw,uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,windows_names
May 26 08:39:58 yoru ntfs-3g[7900]: Mount options: uhelper=udisks2,nodev,nosuid,allow_other,nonempty,relatime,rw,default_permissions,fsname=/dev/sda,blkdev,blksize=4096
May 26 08:39:58 yoru ntfs-3g[7900]: Global ownership and permissions enforced, configuration type 7
May 26 08:39:58 yoru dbus-daemon[1183]: [session uid=1000 pid=1183] Activating service name='org.gnome.Shell.HotplugSniffer' requested by ':1.14' (uid=1000 pid=1263 comm="/usr/bin/gnome-shell")
May 26 08:39:58 yoru dbus-daemon[1183]: [session uid=1000 pid=1183] Successfully activated service 'org.gnome.Shell.HotplugSniffer'
May 26 08:39:58 yoru systemd[1]: Started Process Core Dump (PID 7901/UID 0).
May 26 08:39:58 yoru systemd-coredump[7909]: [?] Process 7875 (udisksd) of user 0 dumped core.

Thread stack traces, (pastebin link part 1)

May 26 08:39:57 yoru dleyna-renderer-service[7826]: dLeyna: Exit
May 26 08:39:58 yoru udisksd[7875]: Error reading global mount options config file /etc/udisks2/mount_options.conf: Key file does not start with a group
May 26 08:39:58 yoru ntfs-3g[7900]: Version 2022.10.3 external FUSE 29
May 26 08:39:58 yoru ntfs-3g[7900]: Mounted /dev/sda (Read-Write, label "MyUSB", NTFS 3.1)
May 26 08:39:58 yoru udisksd[7875]: udisksd: libmount/src/hook_mount.c:480: hook_attach_target: Assertion `api->fd_tree >= 0' failed.
May 26 08:39:58 yoru ntfs-3g[7900]: Cmdline options: rw,uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,windows_names
May 26 08:39:58 yoru ntfs-3g[7900]: Mount options: uhelper=udisks2,nodev,nosuid,allow_other,nonempty,relatime,rw,default_permissions,fsname=/dev/sda,blkdev,blksize=4096
May 26 08:39:58 yoru ntfs-3g[7900]: Global ownership and permissions enforced, configuration type 7
May 26 08:39:58 yoru dbus-daemon[1183]: [session uid=1000 pid=1183] Activating service name='org.gnome.Shell.HotplugSniffer' requested by ':1.14' (uid=1000 pid=1263 comm="/usr/bin/gnome-shell")
May 26 08:39:58 yoru dbus-daemon[1183]: [session uid=1000 pid=1183] Successfully activated service 'org.gnome.Shell.HotplugSniffer'
May 26 08:39:58 yoru systemd[1]: Started Process Core Dump (PID 7901/UID 0).
May 26 08:39:58 yoru systemd-coredump[7909]: [?] Process 7875 (udisksd) of user 0 dumped core.

More thread stack traces (pastebin link part 2)

Thread stack traces: https://pastebin.com/QCZksbru


- Thanks, Osaki.

Offline

#5 2023-05-26 05:58:36

OsakiTsukiko
Member
Registered: 2023-05-06
Posts: 17

Re: Automounting external drives fails

Also, this seems to only occur with NTFS


- Thanks, Osaki.

Offline

#6 2023-05-26 07:26:11

seth
Member
Registered: 2012-09-03
Posts: 52,621

Re: Automounting external drives fails

Yeah, see the thread linked in #3 and please report this one as duplicate.

Offline

#7 2023-05-27 14:48:47

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 19,860

Re: Automounting external drives fails

I saw the other thread, but don't want to conflate the two.  Did the referenced link solve the issue?  If so, I'll close this thread.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#8 2023-05-28 09:20:03

OsakiTsukiko
Member
Registered: 2023-05-06
Posts: 17

Re: Automounting external drives fails

Yes, downgrading the package solved my issue, you can close this thread, thanks!


- Thanks, Osaki.

Offline

#9 2023-05-28 15:26:21

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 19,860

Re: Automounting external drives fails

Cool.  Closing.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB