You are not logged in.

#1 2023-08-07 18:44:04

quickishfm
Member
Registered: 2021-04-08
Posts: 4

[SOLVED] Issue with dolphin-emu seemingly stuck on old version

Hello,
I reproduce the same problem as seen here: https://bugs.archlinux.org/task/78865,  trying to open dolphin-emu. While it appears that bug is already fixed, I am on the latest version of dolphin-emu (in fact I reinstalled from the repo just now) but still see the error "dolphin-emu: error while loading shared libraries: libsfml-network.so.2.5: cannot open shared object file: No such file or directory"

The output of "pacman -Qi dolphin-emu" is as follows:

Name            : dolphin-emu
Version         : 1:5.0.r19433.34527cadcc-5
Description     : A Gamecube / Wii / Triforce emulator
Architecture    : x86_64
URL             : https://dolphin-emu.org
Licenses        : GPL2
Groups          : None
Provides        : None
Depends On      : alsa-lib  bluez-libs  enet  gcc-libs  glibc  hidapi  libavcodec.so=60-64  libavformat.so=60-64
                  libavutil.so=58-64  libcurl.so=4-64  libevdev  libfmt.so=10-64  libgl  libminiupnpc.so=17-64
                  libpulse  libsfml-network.so=2.6-64  libsfml-system.so=2.6-64  libswscale.so=7-64
                  libudev.so=1-64  libusb-1.0.so=0-64  libx11  libxi  libxrandr  lzo  minizip-ng  pugixml  qt6-base
                  sfml  zlib
Optional Deps   : pulseaudio: PulseAudio backend [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 37.96 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Sun 23 Jul 2023 11:21:44 BST
Install Date    : Mon 07 Aug 2023 19:35:14 BST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

I'm not sure why this is the case, can anyone help me with this?

Last edited by quickishfm (2023-08-10 19:31:53)

Offline

#2 2023-08-07 19:01:09

loqs
Member
Registered: 2014-03-06
Posts: 16,831

Re: [SOLVED] Issue with dolphin-emu seemingly stuck on old version

What is the output of the following? (The second command requires pax-utils)

type -a dolphin-emu
lddtree /usr/bin/dolphin-emu

Edit:
Please use code tags for commands and their outputs.

Last edited by loqs (2023-08-07 19:01:27)

Offline

#3 2023-08-07 19:21:35

quickishfm
Member
Registered: 2021-04-08
Posts: 4

Re: [SOLVED] Issue with dolphin-emu seemingly stuck on old version

loqs wrote:

What is the output of the following? (The second command requires pax-utils)

type -a dolphin-emu
lddtree /usr/bin/dolphin-emu

Edit:
Please use code tags for commands and their outputs.

type -a dolphin-emu

gives me

dolphin-emu is /usr/local/bin/dolphin-emu
dolphin-emu is /usr/bin/dolphin-emu

I notice there's actually 2, which means it may be leftovers from a previous build from a long time ago as I don't recall building from source recently.

lddtree dolphin-emu

gives me

/usr/bin/dolphin-emu (interpreter => /lib64/ld-linux-x86-64.so.2)
    libQt6Widgets.so.6 => /usr/lib/libQt6Widgets.so.6
    libasound.so.2 => /usr/lib/libasound.so.2
    libpulse.so.0 => /usr/lib/libpulse.so.0
        libpulsecommon-16.1.so => /usr/lib/pulseaudio/libpulsecommon-16.1.so
            libsndfile.so.1 => /usr/lib/libsndfile.so.1
                libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2
                libFLAC.so.12 => /usr/lib/libFLAC.so.12
                libopus.so.0 => /usr/lib/libopus.so.0
                libmpg123.so.0 => /usr/lib/libmpg123.so.0
                libmp3lame.so.0 => /usr/lib/libmp3lame.so.0
                libvorbis.so.0 => /usr/lib/libvorbis.so.0
                libogg.so.0 => /usr/lib/libogg.so.0
            libxcb.so.1 => /usr/lib/libxcb.so.1
                libXau.so.6 => /usr/lib/libXau.so.6
                libXdmcp.so.6 => /usr/lib/libXdmcp.so.6
            libsystemd.so.0 => /usr/lib/libsystemd.so.0
                libcap.so.2 => /usr/lib/libcap.so.2
                libgcrypt.so.20 => /usr/lib/libgcrypt.so.20
                    libgpg-error.so.0 => /usr/lib/libgpg-error.so.0
                liblz4.so.1 => /usr/lib/liblz4.so.1
            libasyncns.so.0 => /usr/lib/libasyncns.so.0
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3
    libspeexdsp.so.1 => /usr/lib/libspeexdsp.so.1
    libXi.so.6 => /usr/lib/libXi.so.6
        libXext.so.6 => /usr/lib/libXext.so.6
    libevdev.so.2 => /usr/lib/libevdev.so.2
    libudev.so.1 => /usr/lib/libudev.so.1
    libsfml-network.so.2.6 => /usr/lib/libsfml-network.so.2.6
    libsfml-system.so.2.6 => /usr/lib/libsfml-system.so.2.6
    liblzo2.so.2 => /usr/lib/liblzo2.so.2
    libbluetooth.so.3 => /usr/lib/libbluetooth.so.3
    libhidapi-hidraw.so.0 => /usr/lib/libhidapi-hidraw.so.0
    libbz2.so.1.0 => /usr/lib/libbz2.so.1.0
    liblzma.so.5 => /usr/lib/liblzma.so.5
    libzstd.so.1 => /usr/lib/libzstd.so.1
    libX11.so.6 => /usr/lib/libX11.so.6
    libavformat.so.60 => /usr/lib/libavformat.so.60
        libxml2.so.2 => /usr/lib/libxml2.so.2
            libicuuc.so.73 => /usr/lib/libicuuc.so.73
                libicudata.so.73 => /usr/lib/libicudata.so.73
        libmodplug.so.1 => /usr/lib/libmodplug.so.1
        libopenmpt.so.0 => /usr/lib/libopenmpt.so.0
            libvorbisfile.so.3 => /usr/lib/libvorbisfile.so.3
        libbluray.so.2 => /usr/lib/libbluray.so.2
            libfontconfig.so.1 => /usr/lib/libfontconfig.so.1
                libexpat.so.1 => /usr/lib/libexpat.so.1
            libfreetype.so.6 => /usr/lib/libfreetype.so.6
                libpng16.so.16 => /usr/lib/libpng16.so.16
                libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0
                libfreetype.so.6 => !!! circular loop !!!
                    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0
                        libpcre2-8.so.0 => /usr/lib/libpcre2-8.so.0
                    libgraphite2.so.3 => /usr/lib/libgraphite2.so.3
                libbrotlidec.so.1 => /usr/lib/libbrotlidec.so.1
                    libbrotlicommon.so.1 => /usr/lib/libbrotlicommon.so.1
        libgmp.so.10 => /usr/lib/libgmp.so.10
        libz.so.1 => /usr/lib/libz.so.1
        libgnutls.so.30 => /usr/lib/libgnutls.so.30
            libp11-kit.so.0 => /usr/lib/libp11-kit.so.0
                libffi.so.8 => /usr/lib/libffi.so.8
            libbrotlienc.so.1 => /usr/lib/libbrotlienc.so.1
            libidn2.so.0 => /usr/lib/libidn2.so.0
            libunistring.so.5 => /usr/lib/libunistring.so.5
            libtasn1.so.6 => /usr/lib/libtasn1.so.6
            libnettle.so.8 => /usr/lib/libnettle.so.8
            libhogweed.so.6 => /usr/lib/libhogweed.so.6
        libsrt.so.1.5 => /usr/lib/libsrt.so.1.5
            libcrypto.so.3 => /usr/lib/libcrypto.so.3
        libssh.so.4 => /usr/lib/libssh.so.4
    libavcodec.so.60 => /usr/lib/libavcodec.so.60
        libswresample.so.4 => /usr/lib/libswresample.so.4
            libsoxr.so.0 => /usr/lib/libsoxr.so.0
                libgomp.so.1 => /usr/lib/libgomp.so.1
        libvpx.so.8 => /usr/lib/libvpx.so.8
        libwebpmux.so.3 => /usr/lib/libwebpmux.so.3
        libwebp.so.7 => /usr/lib/libwebp.so.7
            libsharpyuv.so.0 => /usr/lib/libsharpyuv.so.0
        libdav1d.so.6 => /usr/lib/libdav1d.so.6
        libopencore-amrwb.so.0 => /usr/lib/libopencore-amrwb.so.0
        librsvg-2.so.2 => /usr/lib/librsvg-2.so.2
            libcairo-gobject.so.2 => /usr/lib/libcairo-gobject.so.2
            libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0
                libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0
                libjpeg.so.8 => /usr/lib/libjpeg.so.8
                libtiff.so.6 => /usr/lib/libtiff.so.6
            libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0
                libmount.so.1 => /usr/lib/libmount.so.1
                    libblkid.so.1 => /usr/lib/libblkid.so.1
            libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0
                libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0
            libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0
                libfribidi.so.0 => /usr/lib/libfribidi.so.0
                libthai.so.0 => /usr/lib/libthai.so.0
                    libdatrie.so.1 => /usr/lib/libdatrie.so.1
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0
        libcairo.so.2 => /usr/lib/libcairo.so.2
            libXrender.so.1 => /usr/lib/libXrender.so.1
            libxcb-render.so.0 => /usr/lib/libxcb-render.so.0
            libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0
            libpixman-1.so.0 => /usr/lib/libpixman-1.so.0
        libaom.so.3 => /usr/lib/libaom.so.3
        libgsm.so.1 => /usr/lib/libgsm.so.1
        libjxl.so.0.8 => /usr/lib/libjxl.so.0.8
            libhwy.so.1 => /usr/lib/libhwy.so.1
        libjxl_threads.so.0.8 => /usr/lib/libjxl_threads.so.0.8
        libopencore-amrnb.so.0 => /usr/lib/libopencore-amrnb.so.0
        libopenjp2.so.7 => /usr/lib/libopenjp2.so.7
        librav1e.so.0 => /usr/lib/librav1e.so.0
        libspeex.so.1 => /usr/lib/libspeex.so.1
        libSvtAv1Enc.so.1 => /usr/lib/libSvtAv1Enc.so.1
        libtheoraenc.so.1 => /usr/lib/libtheoraenc.so.1
        libtheoradec.so.1 => /usr/lib/libtheoradec.so.1
        libx264.so.164 => /usr/lib/libx264.so.164
        libx265.so.199 => /usr/lib/libx265.so.199
            libmvec.so.1 => /usr/lib/libmvec.so.1
        libxvidcore.so.4 => /usr/lib/libxvidcore.so.4
            libpthread.so.0 => /usr/lib/libpthread.so.0
        libva.so.2 => /usr/lib/libva.so.2
        libmfx.so.1 => /usr/lib/libmfx.so.1
    libswscale.so.7 => /usr/lib/libswscale.so.7
    libavutil.so.58 => /usr/lib/libavutil.so.58
        libva-drm.so.2 => /usr/lib/libva-drm.so.2
        libva-x11.so.2 => /usr/lib/libva-x11.so.2
            libXfixes.so.3 => /usr/lib/libXfixes.so.3
            libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1
            libxcb-dri3.so.0 => /usr/lib/libxcb-dri3.so.0
        libvdpau.so.1 => /usr/lib/libvdpau.so.1
        libdrm.so.2 => /usr/lib/libdrm.so.2
        libOpenCL.so.1 => /usr/lib/libOpenCL.so.1
    libQt6Gui.so.6 => /usr/lib/libQt6Gui.so.6
        libQt6DBus.so.6 => /usr/lib/libQt6DBus.so.6
        libxkbcommon.so.0 => /usr/lib/libxkbcommon.so.0
        libOpenGL.so.0 => /usr/lib/libOpenGL.so.0
            libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0
        libmd4c.so.0 => /usr/lib/libmd4c.so.0
    libQt6Core.so.6 => /usr/lib/libQt6Core.so.6
        libicui18n.so.73 => /usr/lib/libicui18n.so.73
        libdouble-conversion.so.3 => /usr/lib/libdouble-conversion.so.3
        libb2.so.1 => /usr/lib/libb2.so.1
        libpcre2-16.so.0 => /usr/lib/libpcre2-16.so.0
    libenet.so.7 => /usr/lib/libenet.so.7
    libcurl.so.4 => /usr/lib/libcurl.so.4
        libnghttp2.so.14 => /usr/lib/libnghttp2.so.14
        libssh2.so.1 => /usr/lib/libssh2.so.1
        libpsl.so.5 => /usr/lib/libpsl.so.5
        libssl.so.3 => /usr/lib/libssl.so.3
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2
            libkrb5.so.3 => /usr/lib/libkrb5.so.3
            libk5crypto.so.3 => /usr/lib/libk5crypto.so.3
            libcom_err.so.2 => /usr/lib/libcom_err.so.2
            libkrb5support.so.0 => /usr/lib/libkrb5support.so.0
            libkeyutils.so.1 => /usr/lib/libkeyutils.so.1
            libresolv.so.2 => /usr/lib/libresolv.so.2
    libEGL.so.1 => /usr/lib/libEGL.so.1
    libGLX.so.0 => /usr/lib/libGLX.so.0
    libminiupnpc.so.17 => /usr/lib/libminiupnpc.so.17
    libpugixml.so.1 => /usr/lib/libpugixml.so.1
    libfmt.so.10 => /usr/lib/libfmt.so.10
    libXrandr.so.2 => /usr/lib/libXrandr.so.2
    libusb-1.0.so.0 => /usr/lib/libusb-1.0.so.0
    libstdc++.so.6 => /usr/lib/libstdc++.so.6
    libm.so.6 => /usr/lib/libm.so.6
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1
    libc.so.6 => /usr/lib/libc.so.6

After removing dolphin-emu from the repo, I ran

which dolphin-emu

which indicated that the leftover dolphin-emu binary was present in /usr/local/bin. In there was also dolphin-emu-nogui and dolphin-tool which I have manually deleted. After reinstalling from the repo, Dolphin seems to work as intended. Thanks for the lead to help me diagnose the issue. I should have known it was a leftover binary but forgot that I once installed from source.

Offline

#4 2023-08-07 22:04:49

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 4,587

Re: [SOLVED] Issue with dolphin-emu seemingly stuck on old version

Please remember to mark your thread [SOLVED] (edit the title of your first post).


How to post. A sincere effort to use modest and proper language and grammar is a sign of respect toward the community.

Offline

#5 2023-08-10 19:32:09

quickishfm
Member
Registered: 2021-04-08
Posts: 4

Re: [SOLVED] Issue with dolphin-emu seemingly stuck on old version

Thank you, I reworded the title to fit within the limit.

Offline

Board footer

Powered by FluxBB