You are not logged in.

#1 2023-08-20 11:16:04

quiqueck
Member
Registered: 2013-04-15
Posts: 70

[Solved] Qemu VM won't start successfully anymore

Last time i started my (Windows 2k) VM successfully on 2023-08-11. After some system upgrades this VM doesen't start anymore successfully. That is it starts but it seems the graphical system can't be started, there is only the black screen with a running progressbar and some text shown "Starting Windows". Normally after this screen the background become bluish and the initialization is running further. In the state of the "black screen" i have also tested to start without graphics, but this won´t work also. So i am not sure if its the graphical system which do not work.

The system upgrades since then did not upgrade qemu itself.

After downgrading the system to the last time  the VM has started successfully, the VM starts without any problems. So there must be something else that broke this VM.

To get an idea which upgrade causes this i started to downgrade the system date by date and tested if the VM may start and it looks the upgrade which i did close after the VM has started successfully the last time is the culprit.

Any idea which package may cause this?

Here are the upgraded packages from this upgrade:

[2023-08-11T17:44:52+0200] [PACMAN] Running 'pacman -Syu'
[2023-08-11T17:44:52+0200] [PACMAN] synchronizing package lists
[2023-08-11T17:44:58+0200] [PACMAN] starting full system upgrade
[2023-08-11T17:53:58+0200] [ALPM] running '60-mkinitcpio-remove.hook'...
[2023-08-11T17:53:58+0200] [ALPM] running '71-dkms-remove.hook'...
[2023-08-11T17:53:58+0200] [ALPM] transaction started
[2023-08-11T17:53:58+0200] [ALPM] upgraded amd-ucode (20230625.ee91452d-5 -> 20230804.7be2766d-2)
[2023-08-11T17:53:58+0200] [ALPM] upgraded libldap (2.6.4-2 -> 2.6.6-1)
[2023-08-11T17:53:58+0200] [ALPM] upgraded audit (3.1.1-1 -> 3.1.2-1)
[2023-08-11T17:53:58+0200] [ALPM] upgraded enchant (2.3.4-2 -> 2.5.0-1)
[2023-08-11T17:53:58+0200] [ALPM] upgraded systemd-libs (254-1 -> 254.1-1)
[2023-08-11T17:53:58+0200] [ALPM] upgraded libxml2 (2.11.4-1 -> 2.11.5-1)
[2023-08-11T17:53:58+0200] [ALPM] upgraded sdl2 (2.28.1-1 -> 2.28.2-1)
[2023-08-11T17:53:58+0200] [ALPM] upgraded systemd (254-1 -> 254.1-1)
[2023-08-11T17:53:59+0200] [ALPM] upgraded libjpeg-turbo (2.1.5.1-1 -> 3.0.0-1)
[2023-08-11T17:53:59+0200] [ALPM] upgraded gtk-update-icon-cache (1:4.10.4-1 -> 1:4.10.5-1)
[2023-08-11T17:53:59+0200] [ALPM] upgraded libproxy (0.5.3-1 -> 0.5.3-2)
[2023-08-11T17:53:59+0200] [ALPM] upgraded firefox (116.0.1-1 -> 116.0.2-1)
[2023-08-11T17:53:59+0200] [ALPM] upgraded firefox-i18n-de (116.0.1-1 -> 116.0.2-1)
[2023-08-11T17:53:59+0200] [ALPM] upgraded fuse-common (3.15.1-1 -> 3.16.1-1)
[2023-08-11T17:53:59+0200] [ALPM] upgraded fuse3 (3.15.1-1 -> 3.16.1-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded gimp-help-de (2.10.0-6 -> 2.10.34-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded perl (5.36.1-2 -> 5.38.0-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded graphviz (8.1.0-1 -> 8.1.0-2)
[2023-08-11T17:54:01+0200] [ALPM] upgraded gtkmm3 (3.24.7-1 -> 3.24.8-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded openssh (9.3p2-1 -> 9.4p1-2)
[2023-08-11T17:54:01+0200] [ALPM] upgraded gvfs (1.50.5-1 -> 1.50.6-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded imagemagick (7.1.1.15-1 -> 7.1.1.15-2)
[2023-08-11T17:54:01+0200] [ALPM] upgraded qt5-base (5.15.10+kde+r145-1 -> 5.15.10+kde+r147-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded ktextaddons (1.4.0-1 -> 1.4.1-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded libinih (56-1 -> 57-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded libgexiv2 (0.14.1-1 -> 0.14.2-1)
[2023-08-11T17:54:01+0200] [ALPM] upgraded libpipewire (1:0.3.76-2 -> 1:0.3.77-1)
[2023-08-11T17:54:02+0200] [ALPM] upgraded linux (6.4.8.arch1-1 -> 6.4.9.arch1-1)
[2023-08-11T17:54:02+0200] [ALPM] upgraded linux-firmware-whence (20230625.ee91452d-5 -> 20230804.7be2766d-2)
[2023-08-11T17:54:02+0200] [ALPM] upgraded linux-firmware (20230625.ee91452d-5 -> 20230804.7be2766d-2)
[2023-08-11T17:54:03+0200] [ALPM] upgraded linux-headers (6.4.8.arch1-1 -> 6.4.9.arch1-1)
[2023-08-11T17:54:03+0200] [ALPM] upgraded lshw (B.02.19.2-5 -> B.02.19.2-6)
[2023-08-11T17:54:03+0200] [ALPM] upgraded net-snmp (5.9.1-6 -> 5.9.1-7)
[2023-08-11T17:54:04+0200] [ALPM] upgraded opera (101.0.4843.33-1 -> 101.0.4843.43-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-encode-locale (1.05-10 -> 1.05-11)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-error (0.17029-4 -> 0.17029-5)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-ipc-system-simple (1.30-4 -> 1.30-5)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-file-basedir (0.09-2 -> 0.09-3)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-uri (5.19-1 -> 5.19-2)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-file-desktopentry (0.22-10 -> 0.22-11)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-file-mimeinfo (0.33-1 -> 0.33-2)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-file-which (1.27-2 -> 1.27-3)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-image-exiftool (12.60-1 -> 12.60-3)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-io-tty (1.17-1 -> 1.17-2)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-timedate (2.33-4 -> 2.33-5)
[2023-08-11T17:54:04+0200] [ALPM] upgraded perl-mailtools (2.21-6 -> 2.21-7)
[2023-08-11T17:54:04+0200] [ALPM] upgraded pipewire (1:0.3.76-2 -> 1:0.3.77-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded plasma-workspace (5.27.7-1 -> 5.27.7-2)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-cryptography (41.0.2-1 -> 41.0.3-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-distlib (0.3.6-3 -> 0.3.7-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-filelock (3.12.0-2 -> 3.12.2-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-more-itertools (10.0.1-1 -> 10.1.0-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-pygments (2.15.1-1 -> 2.16.1-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-sphinxcontrib-applehelp (1.0.4-3 -> 1.0.6-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-sphinxcontrib-devhelp (1.0.2-11 -> 1.0.4-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-sphinxcontrib-htmlhelp (2.0.1-3 -> 2.0.3-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-sphinxcontrib-qthelp (1.0.3-11 -> 1.0.5-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-sphinxcontrib-serializinghtml (1.1.5-6 -> 1.1.7-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-trove-classifiers (2023.7.6-1 -> 2023.8.7-1)
[2023-08-11T17:54:04+0200] [ALPM] upgraded python-virtualenv (20.21.0-1 -> 20.24.2-1)
[2023-08-11T17:54:05+0200] [ALPM] upgraded ruby-test-unit (3.5.9-1 -> 3.6.0-1)
[2023-08-11T17:54:05+0200] [ALPM] upgraded subversion (1.14.2-8 -> 1.14.2-9)
[2023-08-11T17:54:05+0200] [ALPM] upgraded systemd-sysvcompat (254-1 -> 254.1-1)
[2023-08-11T17:54:05+0200] [ALPM] upgraded thin-provisioning-tools (1.0.5-1 -> 1.0.6-1)
[2023-08-11T17:54:05+0200] [ALPM] upgraded xdg-dbus-proxy (0.1.4-1 -> 0.1.5-1)
[2023-08-11T17:54:05+0200] [ALPM] transaction completed
[2023-08-11T17:54:06+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2023-08-11T17:54:06+0200] [ALPM] running '30-systemd-catalog.hook'...
[2023-08-11T17:54:06+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2023-08-11T17:54:06+0200] [ALPM] running '30-systemd-hwdb.hook'...
[2023-08-11T17:54:07+0200] [ALPM] running '30-systemd-sysctl.hook'...
[2023-08-11T17:54:07+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2023-08-11T17:54:07+0200] [ALPM] running '30-systemd-udev-reload.hook'...
[2023-08-11T17:54:09+0200] [ALPM] running '30-systemd-update.hook'...
[2023-08-11T17:54:09+0200] [ALPM] running '30-update-mime-database.hook'...
[2023-08-11T17:54:10+0200] [ALPM] running '60-depmod.hook'...
[2023-08-11T17:54:11+0200] [ALPM] running '70-dkms-install.hook'...
[2023-08-11T17:54:11+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET] ==> Using default configuration file: '/etc/mkinitcpio.conf'
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -g /boot/initramfs-linux.img --microcode /boot/amd-ucode.img
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET] ==> Starting build: '6.4.9-arch1-1'
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2023-08-11T17:54:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [kms]
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'xhci_pci'
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: '/boot/initramfs-linux.img'
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET] ==> Using default configuration file: '/etc/mkinitcpio.conf'
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -g /boot/initramfs-linux-fallback.img -S autodetect --microcode /boot/amd-ucode.img
[2023-08-11T17:54:13+0200] [ALPM-SCRIPTLET] ==> Starting build: '6.4.9-arch1-1'
[2023-08-11T17:54:14+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2023-08-11T17:54:14+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2023-08-11T17:54:14+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2023-08-11T17:54:14+0200] [ALPM-SCRIPTLET]   -> Running build hook: [kms]
[2023-08-11T17:54:16+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'ast'
[2023-08-11T17:54:16+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2023-08-11T17:54:16+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'xhci_pci'
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'qed'
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'qla2xxx'
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'wd719x'
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'qla1280'
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'aic94xx'
[2023-08-11T17:54:17+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'bfa'
[2023-08-11T17:54:18+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2023-08-11T17:54:18+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2023-08-11T17:54:19+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2023-08-11T17:54:19+0200] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: '/boot/initramfs-linux-fallback.img'
[2023-08-11T17:54:20+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2023-08-11T17:54:20+0200] [ALPM] running 'dbus-reload.hook'...
[2023-08-11T17:54:20+0200] [ALPM] running 'detect-old-perl-modules.hook'...
[2023-08-11T17:54:20+0200] [ALPM] running 'gio-querymodules.hook'...
[2023-08-11T17:54:20+0200] [ALPM] running 'glib-compile-schemas.hook'...
[2023-08-11T17:54:20+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2023-08-11T17:54:20+0200] [ALPM] running 'gvfsd.hook'...
[2023-08-11T17:54:20+0200] [ALPM] running 'update-desktop-database.hook'...

Last edited by quiqueck (2023-08-20 15:15:56)

Offline

#2 2023-08-20 14:45:37

loqs
Member
Registered: 2014-03-06
Posts: 17,101

Re: [Solved] Qemu VM won't start successfully anymore

Offline

#3 2023-08-20 15:15:31

quiqueck
Member
Registered: 2013-04-15
Posts: 70

Re: [Solved] Qemu VM won't start successfully anymore

Wow, thanks a lot.

Downgrading to

linux-6.4.8.arch1-1-x86_64.pkg.tar.zst

and 

linux-headers-6.4.8.arch1-1-x86_64.pkg.tar.zst

solved it smile

Offline

#4 2023-08-20 15:35:51

loqs
Member
Registered: 2014-03-06
Posts: 17,101

Re: [Solved] Qemu VM won't start successfully anymore

Did you try switching the mitigation to confirm it was the same issue?

Offline

#5 2023-08-20 15:46:33

quiqueck
Member
Registered: 2013-04-15
Posts: 70

Re: [Solved] Qemu VM won't start successfully anymore

You mean starting with kernel parameter

spec_rstack_overflow=off

?

Will try that later.

Offline

#6 2023-08-20 15:51:26

loqs
Member
Registered: 2014-03-06
Posts: 17,101

Re: [Solved] Qemu VM won't start successfully anymore

quiqueck wrote:

You mean starting with kernel parameter

spec_rstack_overflow=off

?

Yes or

spec_rstack_overflow=ibpb

or

spec_rstack_overflow=ibpb-vmexit

so any of the valid values except the default of

spec_rstack_overflow=safe-ret

Offline

#7 2023-08-20 18:16:59

quiqueck
Member
Registered: 2013-04-15
Posts: 70

Re: [Solved] Qemu VM won't start successfully anymore

Updated to the newest kernel.

All is fine with:

spec_rstack_overflow=off
spec_rstack_overflow=ibpb
spec_rstack_overflow=ibpb-vmexit

With this the VM didn't start (hopefully i didn't made a misspelling):

spec_rstack_overflow=vmexit

Last edited by quiqueck (2023-08-20 18:18:19)

Offline

Board footer

Powered by FluxBB