You are not logged in.

#1 2023-09-05 15:17:15

mester
Member
Registered: 2023-09-05
Posts: 14

I have problems with the audio and with dbus in my laptop

I have an ASUS Zenbook 14 OLED and I have problems because I have pipewire with all installed, and I can't listen anything through the speakers and I have problems with dbus and really I don't understand completly my problem but you have under this text the information of wireplumber service

---------------Wireplumber information---------------------------------------
sep 05 17:02:50 asus-arch wireplumber[859]: Failed to get percentage from UPower: org.freedesktop.DBus.Error.NameHasNoOwner
sep 05 17:02:50 asus-arch wireplumber[859]: [0:00:24.132054388] [859] ERROR IPAModule ipa_module.cpp:172 Symbol ipaModuleInfo not found
sep 05 17:02:50 asus-arch wireplumber[859]: [0:00:24.132103740] [859] ERROR IPAModule ipa_module.cpp:292 v4l2-compat.so: IPA module has no valid info
sep 05 17:02:50 asus-arch wireplumber[859]: [0:00:24.132160106] [859]  INFO Camera camera_manager.cpp:284 libcamera v0.1.0
sep 05 17:02:50 asus-arch wireplumber[859]: SPA handle 'api.alsa.acp.device' could not be loaded; is it installed?
sep 05 17:02:50 asus-arch wireplumber[859]: Failed to create 'api.alsa.acp.device' device
sep 05 17:02:50 asus-arch wireplumber[859]: Path Capture is not a volume or mute control
sep 05 17:02:50 asus-arch wireplumber[859]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NameHasNoOwner
sep 05 17:02:50 asus-arch wireplumber[859]: <WpPortalPermissionStorePlugin:0x55ee348fb3e0> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera
sep 05 17:02:50 asus-arch wireplumber[859]: <WpPortalPermissionStorePlugin:0x55ee348fb3e0> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

And the errors of dbus happen much for example:

Error: org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable

Someone can help me

Offline

#2 2023-09-05 15:38:22

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

Please don't post some isolated random lines, that's borderline useless (or completely, wrt org.freedesktop.DBus.Error.ServiceUnknown) - esp. if you suspect amore widespread dbus issue.
Please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Online

#3 2023-09-05 19:12:15

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

I have it here: http://0x0.st/Hp7d.txt

Offline

#4 2023-09-05 19:48:54

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

sep 05 20:47:48 asus-arch systemd[736]: wireplumber@oscar.service: Main process exited, code=exited, status=78/CONFIG
sep 05 20:47:48 asus-arch systemd[736]: wireplumber@oscar.service: Failed with result 'exit-code'.
systemctl --user status wireplumber@oscar.service

There's a bogus "espanso" and "asus-numpad" service and thunar suggests to install thunar-volman and xdg-desktop-portal-gnome spams the journal, too - but nothing that looks like systematic dbus issues.

Online

#5 2023-09-06 13:14:40

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

The thing is that the audio doesn't work and Espanso is a program that I use

Offline

#6 2023-09-06 13:22:46

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

I sometimes have problems with the Wifi and I really I have problems with audio

Offline

#7 2023-09-06 13:25:26

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

Please don't power post - edit your previous post if nobody has yet replied.
I get the audio thing, the comment was because you suspected general dbus issues and espanso is something you don't use or don't use correctly - as it complains about an absent bianry runtime.

Please post the status of the failing wireplumber@oscar.service

Online

#8 2023-09-06 13:34:09

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

This is the output of wireplumber service

sep 06 15:20:32 asus-arch systemd[729]: wireplumber@oscar.service: Scheduled restart job, restart counter is>
sep 06 15:20:32 asus-arch systemd[729]: wireplumber@oscar.service: Start request repeated too quickly.
sep 06 15:20:32 asus-arch systemd[729]: wireplumber@oscar.service: Failed with result 'exit-code'.
sep 06 15:20:32 asus-arch systemd[729]: Failed to start Multimedia Service Session Manager (oscar).

Offline

#9 2023-09-06 13:35:44

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

I've seen the journal and that's not what I asked for.

Online

#10 2023-09-06 13:40:39

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

This the complete output of wireplumber@oscar status:

× wireplumber@oscar.service - Multimedia Service Session Manager (oscar)
     Loaded: loaded (/usr/lib/systemd/user/wireplumber@.service; enabled; preset: enabled)
     Active: failed (Result: exit-code) since Wed 2023-09-06 15:37:42 CEST; 2min 2s ago
   Duration: 7ms
    Process: 30266 ExecStart=/usr/bin/wireplumber -c oscar.conf (code=exited, status=78)
   Main PID: 30266 (code=exited, status=78)
        CPU: 6ms

sep 06 15:37:42 asus-arch systemd[729]: wireplumber@oscar.service: Scheduled restart job, restart counter is>
sep 06 15:37:42 asus-arch systemd[729]: wireplumber@oscar.service: Start request repeated too quickly.
sep 06 15:37:42 asus-arch systemd[729]: wireplumber@oscar.service: Failed with result 'exit-code'.
sep 06 15:37:42 asus-arch systemd[729]: Failed to start Multimedia Service Session Manager (oscar).

Offline

#11 2023-09-06 13:46:39

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

ExecStart=/usr/bin/wireplumber -c oscar.conf

Where does that come from?
Did you follow https://wiki.archlinux.org/title/WirePlumber ?
Is there an oscar.conf?
Edit: and what does it look like?

Last edited by seth (2023-09-06 13:46:54)

Online

#12 2023-09-06 13:48:25

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

I check and I don't the config file that wireplumber uses by default with the service wireplumber@oscar.service.

This is the ouput when I try to execute the command: Unable to find the required configuration file oscar.conf

Last edited by mester (2023-09-06 13:49:05)

Offline

#13 2023-09-06 14:00:19

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

That's your problem (most likely) - disable that service, where did you get the idea to create a wireplumber service with your username as discriminator?
(It'll probably help to know what "tutorial" you followed to screw up your system)

Then report back.
Ftr

I can't listen anything through the speakers

sep 05 20:47:30 asus-arch kernel: snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC294: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
sep 05 20:47:30 asus-arch kernel: snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
sep 05 20:47:30 asus-arch kernel: snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
sep 05 20:47:30 asus-arch kernel: snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
sep 05 20:47:30 asus-arch kernel: snd_hda_codec_realtek hdaudioC1D0:    inputs:

Do you already get sound over the HPs?

aplay -Ll
amixer
speaker-test -c2 -D hw:0
speaker-test -c2 -D hw:1 # should get you an error
mpv -ao alsa thunderstruck.mp3 # don't post that there's no thunderstruck.mp3…

Online

#14 2023-09-06 14:11:21

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

I don't follow any tutorial I only install arch linux and I have the problems with the audio

Offline

#15 2023-09-06 14:20:47

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

The why is/was there a wireplumber@oscar.service ? How did you arrive at that idea?
Is it now disabled? Did you reboot?
Post the outputs for the commands in #13

Online

#16 2023-09-06 15:11:18

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

I reboot the computer but it doesn't work

Offline

#17 2023-09-06 15:12:32

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

seth wrote:

Is it now disabled? …
Post the outputs for the commands in #13

This is going absolutely nowhere.

Online

#18 2023-09-06 15:14:55

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

Yes that service is disabled

Offline

#19 2023-09-06 15:26:03

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

seth wrote:

This is going absolutely nowhere.

Good luck.

Online

#20 2023-09-06 15:39:14

mester
Member
Registered: 2023-09-05
Posts: 14

Re: I have problems with the audio and with dbus in my laptop

It doesn't work and the microphone also

Offline

#21 2023-09-06 16:18:02

seth
Member
Registered: 2012-09-03
Posts: 54,226

Re: I have problems with the audio and with dbus in my laptop

Online

Board footer

Powered by FluxBB