You are not logged in.

#1 2023-09-08 00:41:55

VetheonGames
Member
Registered: 2023-09-08
Posts: 14

aurpublish not finding package name

Hey everyone,

This is my first time posting on the Arch forums, but I've been a daily driver of Arch for several years now.

I've recently decided to start publishing packages to the AUR, but I'm bumping into an issue.

The wiki on publishing to the AUR is sorely lacking actual directions for publishing, I've read through the entire thing multiple times, and tried for the last several hours to get my package published. I've confirmed with friends who have published to AUR that my PKGBUILD is properly formatted, and doesn't contain any syntax errors. They say it should work.

So, in a last ditch effort, I installed `aurpublish` and attempted to use that. Which, definitely simplifies things. However, when I try to run it after following the directions on the wiki (init the repo, add the remote for AUR, etc)...

`aurpublish` gives me this error: "aurpublish: unrecognized package glava-ridged"

The problem is, I'm running this from the root of the local git repo (./aur-packages/glava-ridged/), where the `SRCINFO` and `PKGBUILD` are located. According to everything I've read, this is the correct way to do it, and aurpublish SHOULD look into the pkgbuild file and read the package name from it.

I don't know what it is that I'm doing wrong. Am I just too stupid to publish to the AUR? I'd really love to contribute to it, but I'm about ready to give up on ever figuring this out, as I've already spent the better part of 4 hours failing to do so.

Any help would be much appreciated. You can view my PKGBUILD file below:

# Maintainer: Connor (VetheonGames) <ceo@pixelridgesoftworks.com>

pkgname=glava-ridged
pkgver=1.0.0
pkgrel=1
pkgdesc="GLava-Ridged - OpenGL audio visualizer (Fork of GLava)"
arch=('x86_64')
url="https://git.pixelridgesoftworks.com/PixelRidge-Softworks/glava-ridged.git"
license=('GPL')
depends=('glfw-x11' 'pulseaudio' 'libconfig' 'fftw')
makedepends=('cmake' 'make' 'git')
source=("git+${url}")  # Cloning the entire repo
sha256sums=('SKIP')

build() {
  cd "$srcdir/$pkgname"
  mkdir -p build
  cd build
  cmake ..
  make
}

package() {
  cd "$srcdir/$pkgname/build"
  make DESTDIR="$pkgdir/" install
}

I should also confirm that I have tested the PKGBUILD and the resulting installed program, it all works perfectly.



UPDATE:

I managed to get a different error by changing the way my local repo is laid out. Before, the local git repo was the same directory that held the PKGBUILD. I moved the local git repo to the folder above the one containing my PKGBUILD, and tried to re-run the aurpublish command, this time I got

git push using:  aur:glava-ridged.git master
fatal: no new revisions were found

But that doesn't make a lot of sense either, seeing as this package simply doesn't exist on the AUR. (Glava does, but it's been abandoned as of 2021, my fork also adds features, hence making a new package)
So, if the package doesn't exist on the AUR, what on earth is it looking for changes regarding?
I'm now officially 5 hours+ into figuring this out.

They should really make this easier, or at least produce a step by step guide. Instead of the incredibly vague directions on the wiki.


UPDATE THE SECOND:

I figured out the manual method myself through 6+ hours of trial and error. My package is now published, and I've automated the workflow for publishing new packages.

I managed to figure this out before anyone responded. I'll make a comprehensive guide in another post, and make it available for people to read, because this is really really poorly documented.

Last edited by VetheonGames (2023-09-08 01:31:24)

Offline

#2 2023-09-08 07:17:35

seth
Member
Registered: 2012-09-03
Posts: 53,302

Re: aurpublish not finding package name

https://wiki.archlinux.org/title/AUR_su … positories
Please don't post PSAs, the forum is the entirely wrong context.
If you feel there's something ambigious/unclear in that wiki segment, start a discussion thread on the wiki and point them out there.

Offline

Board footer

Powered by FluxBB