You are not logged in.

#1 2023-09-09 07:51:50

prosteSebastian
Member
Registered: 2023-08-01
Posts: 9

Unable to update grimshot

Hi,
I'm unable to update grimshot. I update it using yay.
Im using arch with hyprland.
I've tried sudo pacman-key --refresh-keysv
The version is:

❯ yay -Q grimshot
grimshot 1.6.1-1

This is the output of yay:

yay    
[sudo] password for s: 
Sorry, try again.
[sudo] password for s: 
:: Synchronizing package databases...
 core                                                              128.1 KiB   332 KiB/s 00:00 [########################################################] 100%
 extra                                                               8.3 MiB  2.79 MiB/s 00:03 [########################################################] 100%
 multilib                                                          143.0 KiB  2.22 MiB/s 00:00 [########################################################] 100%
:: Searching AUR for updates...
:: Searching databases for updates...
 -> Flagged Out Of Date AUR Packages: cava  paru
:: 8 packages to upgrade/install.
8  core/glib2               2.76.5-1    -> 2.76.5-2
7  extra/code               1.81.1-1    -> 1.82.0-1
6  extra/go                 2:1.21.0-1  -> 2:1.21.1-1
5  extra/mesa               1:23.1.6-4  -> 1:23.1.7-1
4  extra/spotify-launcher   0.5.1-1     -> 0.5.1-2
3  extra/vulkan-headers     1:1.3.262-1 -> 1:1.3.264-1
2  extra/vulkan-icd-loader  1.3.255-1   -> 1.3.263-1
1  aur/grimshot             1.6.1-1     -> 1.6.1-5
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems
==> 
Sync Dependency (5): vulkan-icd-loader-1.3.263-1, glib2-2.76.5-2, go-2:1.21.1-1, mesa-1:23.1.7-1, vulkan-headers-1:1.3.264-1
Sync Explicit (2): code-1.82.0-1, spotify-launcher-0.5.1-2
AUR Explicit (1): grimshot-1.6.1-5
:: PKGBUILD up to date, skipping download: grimshot
  1 grimshot                                 (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
  1 grimshot                                 (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
==> Making package: grimshot 1.6.1-5 (Sat 09 Sep 2023 09:49:41 AM CEST)
==> Retrieving sources...
  -> Found grimshot-1.6.1
  -> Found grimshot-1.6.1.1.scd
==> WARNING: Skipping verification of source file PGP signatures.
==> Validating source files with sha256sums...
    grimshot-1.6.1 ... FAILED
    grimshot-1.6.1.1.scd ... FAILED
==> ERROR: One or more files did not pass the validity check!
 -> error downloading sources: /home/s/.cache/yay/grimshot 
	context: exit status 1 
	

:: (1/1) Parsing SRCINFO: grimshot
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (11) ayatana-ido-0.10.1-1  code-1.82.0-1  electron25-25.6.0-1  glib2-2.76.5-2  go-2:1.21.1-1  libayatana-appindicator-0.5.92-2
              libayatana-indicator-0.9.3-1  mesa-1:23.1.7-1  spotify-launcher-0.5.1-2  vulkan-headers-1:1.3.264-1  vulkan-icd-loader-1.3.263-1

Total Download Size:   134.85 MiB
Total Installed Size:  648.16 MiB
Net Upgrade Size:      214.68 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 electron25-25.6.0-1-x86_64                                         60.5 MiB  2.75 MiB/s 00:22 [########################################################] 100%
 go-2:1.21.1-1-x86_64                                               37.6 MiB  3.37 MiB/s 00:11 [########################################################] 100%
 mesa-1:23.1.7-1-x86_64                                             15.2 MiB  3.12 MiB/s 00:05 [########################################################] 100%
 code-1.82.0-1-x86_64                                               14.6 MiB  3.34 MiB/s 00:04 [########################################################] 100%
 glib2-2.76.5-2-x86_64                                               3.8 MiB  2.85 MiB/s 00:01 [########################################################] 100%
 spotify-launcher-0.5.1-2-x86_64                                  1894.1 KiB  3.30 MiB/s 00:01 [########################################################] 100%
 vulkan-headers-1:1.3.264-1-any                                   1139.3 KiB  3.51 MiB/s 00:00 [########################################################] 100%
 vulkan-icd-loader-1.3.263-1-x86_64                                139.0 KiB  1805 KiB/s 00:00 [########################################################] 100%
 ayatana-ido-0.10.1-1-x86_64                                        66.2 KiB   907 KiB/s 00:00 [########################################################] 100%
 libayatana-appindicator-0.5.92-2-x86_64                            48.3 KiB   863 KiB/s 00:00 [########################################################] 100%
 libayatana-indicator-0.9.3-1-x86_64                                39.4 KiB   691 KiB/s 00:00 [########################################################] 100%
 Total (11/11)                                                     134.9 MiB  2.97 MiB/s 00:45 [########################################################] 100%
(11/11) checking keys in keyring                                                               [########################################################] 100%
(11/11) checking package integrity                                                             [########################################################] 100%
(11/11) loading package files                                                                  [########################################################] 100%
(11/11) checking for file conflicts                                                            [########################################################] 100%
(11/11) checking available disk space                                                          [########################################################] 100%
:: Processing package changes...
( 1/11) upgrading vulkan-icd-loader                                                            [########################################################] 100%
( 2/11) upgrading glib2                                                                        [########################################################] 100%
( 3/11) upgrading mesa                                                                         [########################################################] 100%
( 4/11) installing electron25                                                                  [########################################################] 100%
Optional dependencies for electron25
    kde-cli-tools: file deletion support (kioclient5)
    pipewire: WebRTC desktop sharing under Wayland [installed]
    qt5-base: enable Qt5 with --enable-features=AllowQt [installed]
    trash-cli: file deletion support (trash-put)
    xdg-utils: open URLs with desktop’s default (xdg-email, xdg-open) [installed]
( 5/11) upgrading code                                                                         [########################################################] 100%
( 6/11) upgrading go                                                                           [########################################################] 100%
( 7/11) installing ayatana-ido                                                                 [########################################################] 100%
( 8/11) installing libayatana-indicator                                                        [########################################################] 100%
( 9/11) installing libayatana-appindicator                                                     [########################################################] 100%
(10/11) upgrading spotify-launcher                                                             [########################################################] 100%
(11/11) upgrading vulkan-headers                                                               [########################################################] 100%
:: Running post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating icon theme caches...
(3/3) Updating the desktop file MIME type cache...
==> Making package: grimshot 1.6.1-5 (Sat 09 Sep 2023 09:50:36 AM CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found grimshot-1.6.1
  -> Found grimshot-1.6.1.1.scd
==> Validating source files with sha256sums...
    grimshot-1.6.1 ... FAILED
    grimshot-1.6.1.1.scd ... FAILED
==> ERROR: One or more files did not pass the validity check!
 -> error making: grimshot-exit status 1
 -> Failed to install the following packages. Manual intervention is required:
grimshot - exit status 1

Offline

#2 2023-09-09 08:14:13

Thorgrimsson
Member
Registered: 2020-11-05
Posts: 1

Re: Unable to update grimshot

it seems there is a possible solution on the AUR-page of the package. thats why you should look there if you have problems with AUR-packages before posting in the forum:
https://aur.archlinux.org/packages/grimshot

Offline

#3 2023-09-09 13:18:38

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,879
Website

Re: Unable to update grimshot

Post the output from makepkg itself, not from an apparent alias/wrapper for an aur helper.


"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman

Offline

#4 2023-09-10 07:41:53

prosteSebastian
Member
Registered: 2023-08-01
Posts: 9

Re: Unable to update grimshot

Hi,
You mean cd into the grimshot directory and makepkg from there? (sorry, i'm new to this)

Offline

#5 2023-09-10 08:54:10

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 12,131
Website

Re: Unable to update grimshot

Mod note: moving to AUR Issues.


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#6 2023-09-10 14:10:05

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,879
Website

Re: Unable to update grimshot

prosteSebastian wrote:

Hi,
You mean cd into the grimshot directory and makepkg from there? (sorry, i'm new to this)

Yes.  And if you are new to this, you should not use yay at all (arguably no one should).  On top of that "yay" is apparently an alias or another wrapper on your system not the /usr/bin/yay binary provided by the yay package - so we don't even know what command you ran when it failed.


"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman

Offline

#7 2023-09-12 12:46:57

prosteSebastian
Member
Registered: 2023-08-01
Posts: 9

Re: Unable to update grimshot

I hope that im in a right folder big_smile

    ~/.cache/yay/grimshot  on   master ?3                                                                                              at 14:45:57  
❯ makepkg -si
==> Making package: grimshot 1.6.1-5 (Tue 12 Sep 2023 02:46:11 PM CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found grimshot-1.6.1
  -> Found grimshot-1.6.1.1.scd
==> Validating source files with sha256sums...
    grimshot-1.6.1 ... FAILED
    grimshot-1.6.1.1.scd ... FAILED
==> ERROR: One or more files did not pass the validity check!

Last edited by prosteSebastian (2023-09-12 12:52:20)

Offline

#8 2023-09-12 13:15:43

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,879
Website

Re: Unable to update grimshot

You're just using the source material already there from yay - that's the problem.

Start with a fresh clone of the AUR repo somewhere else and it should work fine.

EDIT: This is actually all due to a packaging error by the aur maintainer.  They failed to increment the pkgver when the upstream source changed.  They instead just incremented the pkgrel which is not appropriate for such situations.  Yay fails to detect this problem and uses the new checksums with the old cached source files (which then do not match).

Last edited by Trilby (2023-09-12 13:21:22)


"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman

Offline

#9 2023-09-12 13:46:25

prosteSebastian
Member
Registered: 2023-08-01
Posts: 9

Re: Unable to update grimshot

Trilby wrote:

You're just using the source material already there from yay - that's the problem.

Start with a fresh clone of the AUR repo somewhere else and it should work fine.

EDIT: This is actually all due to a packaging error by the aur maintainer.  They failed to increment the pkgver when the upstream source changed.  They instead just incremented the pkgrel which is not appropriate for such situations.  Yay fails to detect this problem and uses the new checksums with the old cached source files (which then do not match).

Oh i see, that makes sense.
Now it's working correctly, thanks a lot smile.
Have a nice day

Offline

Board footer

Powered by FluxBB