You are not logged in.

#1 2023-09-13 06:12:31

mtubarch
Member
From: Italy
Registered: 2023-02-16
Posts: 43

[SOLVED] Pre-login screen not properly scaled

Fonts and images of GRUB, loading Linux and SDDM are too small. After the login everything is right. I would like to scale the pre-login screen to make it readable. This is neofetch output:

OS: Arch Linux x86_64
Host: TUXEDO InfinityBook Pro Gen7 (MK1) Standard
Kernel: 6.5.2-arch1-1
Uptime: 11 mins
Packages: 1364 (pacman)
Shell: bash 5.1.16
Resolution: 2880x1800
DE: Plasma 5.27.8
WM: kwin
Theme: [Plasma], Breeze [GTK2/3]
Icons: Papirus-Light [Plasma], Papirus-Light [GTK2/3]
Terminal: konsole
CPU: 12th Gen Intel i7-12700H (20) @ 4.600GHz
GPU: Intel Alder Lake-P
Memory: 3819MiB / 15735MiB

The laptop has a 3K HiDPI Omnia Display non-glare 90 Hz (I read on the Wiki that since SDDM version 0.20.0, HiDPI support is enabled by default). The display server protocol is Wayland.
Following the Wiki I created a configuration file in /etc/sddm.conf.d/, in which: 1) I set Theme as breeze, 2) in [General] I also replaced ‘DisplayServer=x11’ with ‘DisplayServer=wayland’. Nothing changed.
What is the cause of this malfunction and what should I do? Thank you very much in advance.

Last edited by mtubarch (2024-03-09 08:27:07)

Offline

#2 2023-09-13 09:05:45

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,108

Re: [SOLVED] Pre-login screen not properly scaled

Try explicitly adding i915 to the MODULES=( i915 ) array in mkinitcpio and regenerating your initramfs to really enable early KMS https://wiki.archlinux.org/title/Kernel … _KMS_start (yes I know the kms hook "should" do that)

And try blacklisting the simple drm garbage by adding:

initcall_blacklist=simpledrm_platform_driver_init

to your kernel parameters.

This won't fix GRUB, since GRUB should be getting the resolution from your UEFI however, double check that and make sure that CSM emulation is disabled in your UEFI.

Last edited by V1del (2023-09-13 09:06:30)

Online

#3 2023-09-13 10:11:14

seth
Member
Registered: 2012-09-03
Posts: 53,284

Re: [SOLVED] Pre-login screen not properly scaled

You'll have to run grub at a lower resolution or create a bigger font: https://wiki.archlinux.org/title/HiDPI#GRUB
Since SDDM is ultimately Qt5, you can try related environment variables, https://wiki.archlinux.org/title/HiDPI#Qt_5

Online

#4 2023-09-13 11:06:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,108

Re: [SOLVED] Pre-login screen not properly scaled

Whoops I totally misread that, if the resolution is fine but scaling the problem follow seth's suggestions.

Online

#5 2023-09-16 07:08:58

mtubarch
Member
From: Italy
Registered: 2023-02-16
Posts: 43

Re: [SOLVED] Pre-login screen not properly scaled

seth wrote:

You'll have to run grub at a lower resolution or create a bigger font: https://wiki.archlinux.org/title/HiDPI#GRUB
Since SDDM is ultimately Qt5, you can try related environment variables, https://wiki.archlinux.org/title/HiDPI#Qt_5

As for GRUB I solved it with a lower resolution. Regarding SDDM I tried:

$ export QT_AUTO_SCREEN_SCALE_FACTOR=1
$ export QT_ENABLE_HIGHDPI_SCALING=1

Nothing changed. Then I tried:

QT_FONT_DPI=96 sddm

and my laptop got freezed (maybe because it is an appropriate command only for X11, while I use Wayland?)
I read this contribution https://www.qt.io/blog/2016/01/26/high- … -in-qt-5-6 mentioned in the Arch Wiki, but I didn't understand what the most appropriate command to use in Wayland is.
Thanks again for the help!

Offline

#6 2023-09-16 07:56:06

seth
Member
Registered: 2012-09-03
Posts: 53,284

Re: [SOLVED] Pre-login screen not properly scaled

You tried when where how?
https://wiki.archlinux.org/title/Environment_variables

Running SDDM out of some GUI session isn't gonna work you and setting a DPI lower than your physical one will only make things smaller.
Also see whether you can control SDDM w/ explicit QT_SCALE_FACTOR or  QT_SCREEN_SCALE_FACTORS

Online

#7 2023-09-17 12:12:53

mtubarch
Member
From: Italy
Registered: 2023-02-16
Posts: 43

Re: [SOLVED] Pre-login screen not properly scaled

Since the problem is limited to sddm, I'd like to intervene as described in https://wiki.archlinux.org/title/Enviro … pplication.
In ~/.local/share/applications, however, I cannot find any .desktop files to work on because the folder is empty.
I found the file /usr/share/applications/kcm_sddm.desktop, in which there is the line of code

Exec=systemsettings kcm_sddm

Do I need to intervene in this file? If so, how should I change it?
Thank you for your patience and best regards.

Offline

#8 2023-09-17 12:17:36

seth
Member
Registered: 2012-09-03
Posts: 53,284

Re: [SOLVED] Pre-login screen not properly scaled

First try https://wiki.archlinux.org/title/SDDM#Enable_HiDPI
Then to set the environment in /usr/share/sddm/scripts/Xsetup (but that might spill into the general context)

Online

#9 2024-03-09 08:26:46

mtubarch
Member
From: Italy
Registered: 2023-02-16
Posts: 43

Re: [SOLVED] Pre-login screen not properly scaled

I make this last post only to mark this old thread as "solved" (the problem was fixed by simply following the Wiki in https://wiki.archlinux.org/title/SDDM#Enable_HiDPI). Thank you, seth.

Offline

#10 2024-03-09 14:03:07

860lacov
Member
Registered: 2020-05-02
Posts: 466

Re: [SOLVED] Pre-login screen not properly scaled

Could you please paste here your config here?
I had to do something like this:

cat /etc/sddm.conf.d/hidpi.conf 
[General]
GreeterEnvironment=QT_SCREEN_SCALE_FACTORS=1,QT_FONT_DPI=120

[Wayland]
EnableHiDPI=true

[X11]
EnableHiDPI=true

But it was trial and error in my case. I could probably remove QT_SCREEN_SCALE_FACTORS=1

Offline

#11 2024-03-09 15:20:06

mtubarch
Member
From: Italy
Registered: 2023-02-16
Posts: 43

Re: [SOLVED] Pre-login screen not properly scaled

In /etc/sddm.conf.d/ I created the configuration file /etc/sddm.conf.d/hidpi.conf, where I wrote:

[Wayland]
EnableHiDPI=true

[General]
GreeterEnvironment=QT_SCREEN_SCALE_FACTORS=2,QT_FONT_DPI=192

That fixed the problem.

Offline

Board footer

Powered by FluxBB