You are not logged in.

#1 2023-09-13 16:46:12

stefano
Member
Registered: 2011-04-09
Posts: 265

Kile required texlive-basic conflicts with texlive-dummy [SOLVED]

I use Tex heavily and I rely on the CTAN installation of texlive. I also have texlive-dummy installed from the AUR (older version, as it is no longer there) to fool a few packages' dependencies, including Kile's.
As of a few months ago, however, Kile refuses to update because it wants to remove texlive-dummy and install texlive-basic instead. I have no intention of duplicating tex installations. How can I get out of the jam?  I have been explicitly excluding Kile from the update list for a few months, but that's not a great solution, of course.

Last edited by stefano (2023-09-13 19:45:20)

Offline

#2 2023-09-13 17:59:00

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,110

Re: Kile required texlive-basic conflicts with texlive-dummy [SOLVED]

You can --assume-installed when updating/installing Kile

man pacman wrote:

[TRANSACTION OPTIONS (APPLY TO -S, -R AND -U)
...
       --assume-installed <package=version>
           Add a virtual package "package" with version "version" to the transaction to satisfy dependencies.
           This allows to disable specific dependency checks without affecting all dependency checks. To disable
           all dependency checking, see the --nodeps option.

Offline

#3 2023-09-13 19:44:03

stefano
Member
Registered: 2011-04-09
Posts: 265

Re: Kile required texlive-basic conflicts with texlive-dummy [SOLVED]

Thank you for the quick reply. I assume it is not possible to add the option in pacman.conf? I didn't find anything to that effect in its man page.

Last edited by stefano (2023-09-13 19:45:36)

Offline

Board footer

Powered by FluxBB