You are not logged in.

#1 2023-09-14 23:10:17

weepr
Member
Registered: 2023-09-12
Posts: 8

Can't get 5.1 surround sound on my setup, only 2.1 works

Hello Arch community,

I've been having some trouble getting my 5.1 surround setup to work properly in arch. The issue is that despite having the correct output set to "Analog 5.1 Surround" in pavucontrol, I only get sound from my left and right speakers and my subwoofer, and when I try setting it to "Digital 5.1 Surround" I get no output at all (neither DTS nor AC3 work).

Solutions I have already tried include removing pipewire and switching to pulseaudio, as well as everything else described in this post:
https://bbs.archlinux.org/viewtopic.php?id=283356
and also in the wiki:
https://wiki.archlinux.org/title/PulseA … nd_systems

However, the best I can get is still 2.1 surround.

Here's a rough diagram of my audio setup:

My desktop (RCA line out)
==>
A/V receiver (RCA input)
==>
My 5 speakers (Speaker wire) and my subwoofer (RCA)

And here's the output of:

aplay -l :

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0 *]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [Q27G1WG4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC1220 Analog [ALC1220 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 1: ALC1220 Digital [ALC1220 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Device [USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: USB [Scarlett Solo USB], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I will be happy to provide any more info if needed.

Thanks in advance!

Offline

#2 2023-09-14 23:46:17

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,375

Re: Can't get 5.1 surround sound on my setup, only 2.1 works

Multiple questions here. What are you playing back? The absolute vast majority of sources is going to be stereo in any case, if you want that upmixed you need to configure it so. how many cables/plugs?  Do you know whether your receiver properly passes the signal, have you played back 5.1 setups with that on anything else (e.g. the same box but with Windows or so?)

Post during active reproduction

amixer -c1 #or whatever index is the card from that aplay output you are playing from.
pactl list cards
pactl list sinks
pactl list sink-outputs

But if you want this from a single RCA plug you'll need to enable a encoder to get all of the other sources to a 5.1

Last edited by V1del (2023-09-14 23:51:33)

Offline

#3 2023-09-15 01:46:08

weepr
Member
Registered: 2023-09-12
Posts: 8

Re: Can't get 5.1 surround sound on my setup, only 2.1 works

My end goal is to play back any source (e.g. youtube, spotify) in 5.1 surround, just as I did in Windows using the same setup. The A/V receiver is connected to my desktop with a single RCA cable.

Here are the outputs you requested during active reproduction (playing music through youtube):

amixer -c2 :

Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 37
  Mono:
  Front Left: Playback 29 [78%] [-8.00dB] [on]
  Front Right: Playback 29 [78%] [-8.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined cvolume cvolume-joined pswitch pswitch-joined cswitch cswitch-joined
  Playback channels: Mono
  Capture channels: Mono
  Limits: Playback 0 - 31 Capture 0 - 35
  Mono: Playback 16 [52%] [-7.00dB] [off] Capture 35 [100%] [23.00dB] [on]
Simple mixer control 'Auto Gain Control',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
pactl list cards :

Card #0
	Name: alsa_card.usb-C-Media_Electronics_Inc._USB_Audio_Device-00
	Driver: module-alsa-card.c
	Owner Module: 6
	Properties:
		alsa.card = "2"
		alsa.card_name = "USB Audio Device"
		alsa.long_card_name = "C-Media Electronics Inc. USB Audio Device at usb-0000:09:00.0-2, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:09:00.0-usb-0:2:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:01.3/0000:02:00.2/0000:03:09.0/0000:09:00.0/usb3/3-2/3-2:1.0/sound/card2"
		udev.id = "usb-C-Media_Electronics_Inc._USB_Audio_Device-00"
		device.bus = "usb"
		device.vendor.id = "0d8c"
		device.vendor.name = "C-Media Electronics, Inc."
		device.product.id = "0014"
		device.product.name = "Audio Adapter (Unitek Y-247A)"
		device.serial = "C-Media_Electronics_Inc._USB_Audio_Device"
		device.string = "2"
		device.description = "Audio Adapter (Unitek Y-247A)"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	Profiles:
		input:mono-fallback: Mono Input (sinks: 0, sources: 1, priority: 1, available: yes)
		output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority: 6500, available: yes)
		output:analog-stereo+input:mono-fallback: Analog Stereo Output + Mono Input (sinks: 1, sources: 1, priority: 6501, available: yes)
		output:iec958-stereo: Digital Stereo (IEC958) Output (sinks: 1, sources: 0, priority: 5500, available: yes)
		output:iec958-stereo+input:mono-fallback: Digital Stereo (IEC958) Output + Mono Input (sinks: 1, sources: 1, priority: 5501, available: yes)
		output:iec958-ac3-surround-51: Digital Surround 5.1 (IEC958/AC3) Output (sinks: 1, sources: 0, priority: 300, available: yes)
		output:iec958-ac3-surround-51+input:mono-fallback: Digital Surround 5.1 (IEC958/AC3) Output + Mono Input (sinks: 1, sources: 1, priority: 301, available: yes)
		output:iec958-dts-surround-51: Digital Surround 5.1 (IEC958/DTS) Output (sinks: 1, sources: 0, priority: 300, available: yes)
		output:iec958-dts-surround-51+input:mono-fallback: Digital Surround 5.1 (IEC958/DTS) Output + Mono Input (sinks: 1, sources: 1, priority: 301, available: yes)
		off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
	Active Profile: output:analog-stereo+input:mono-fallback
	Ports:
		analog-input-mic: Microphone (type: Mic, priority: 8700, latency offset: 0 usec, availability unknown)
			Properties:
				device.icon_name = "audio-input-microphone"
			Part of profile(s): input:mono-fallback, output:analog-stereo+input:mono-fallback, output:iec958-stereo+input:mono-fallback, output:iec958-ac3-surround-51+input:mono-fallback, output:iec958-dts-surround-51+input:mono-fallback
		analog-output-speaker: Speakers (type: Speaker, priority: 10000, latency offset: 0 usec, availability unknown)
			Properties:
				device.icon_name = "audio-speakers"
			Part of profile(s): output:analog-stereo, output:analog-stereo+input:mono-fallback
		iec958-stereo-output: Digital Output (S/PDIF) (type: SPDIF, priority: 0, latency offset: 0 usec, availability unknown)
			Part of profile(s): output:iec958-stereo, output:iec958-stereo+input:mono-fallback, output:iec958-dts-surround-51, output:iec958-dts-surround-51+input:mono-fallback

Card #1
	Name: alsa_card.pci-0000_0a_00.1
	Driver: module-alsa-card.c
	Owner Module: 7
	Properties:
		alsa.card = "0"
		alsa.card_name = "HDA NVidia"
		alsa.long_card_name = "HDA NVidia at 0xfc080000 irq 119"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:0a:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:03.1/0000:0a:00.1/sound/card0"
		device.bus = "pci"
		device.vendor.id = "10de"
		device.vendor.name = "NVIDIA Corporation"
		device.product.id = "10f0"
		device.product.name = "GP104 High Definition Audio Controller"
		device.string = "0"
		device.description = "GP104 High Definition Audio Controller"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Profiles:
		output:hdmi-stereo: Digital Stereo (HDMI) Output (sinks: 1, sources: 0, priority: 38668, available: yes)
		output:hdmi-dts-surround: Digital Surround 5.1 (HDMI/DTS) Output (sinks: 1, sources: 0, priority: 33368, available: yes)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (sinks: 1, sources: 0, priority: 38468, available: yes)
		output:hdmi-dts-surround-extra1: Digital Surround 5.1 (HDMI 2/DTS) Output (sinks: 1, sources: 0, priority: 33368, available: yes)
		output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (sinks: 1, sources: 0, priority: 5700, available: no)
		output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (sinks: 1, sources: 0, priority: 600, available: no)
		output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (sinks: 1, sources: 0, priority: 600, available: no)
		output:hdmi-dts-surround-extra2: Digital Surround 5.1 (HDMI 3/DTS) Output (sinks: 1, sources: 0, priority: 600, available: no)
		output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (sinks: 1, sources: 0, priority: 5700, available: no)
		output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (sinks: 1, sources: 0, priority: 600, available: no)
		output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (sinks: 1, sources: 0, priority: 600, available: no)
		output:hdmi-dts-surround-extra3: Digital Surround 5.1 (HDMI 4/DTS) Output (sinks: 1, sources: 0, priority: 600, available: no)
		off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
	Active Profile: output:hdmi-stereo
	Ports:
		hdmi-output-0: HDMI / DisplayPort (type: HDMI, priority: 5900, latency offset: 0 usec, available)
			Properties:
				device.icon_name = "video-display"
				device.product.name = "C27
         "
			Part of profile(s): output:hdmi-stereo, output:hdmi-dts-surround
		hdmi-output-1: HDMI / DisplayPort 2 (type: HDMI, priority: 5800, latency offset: 0 usec, available)
			Properties:
				device.icon_name = "video-display"
				device.product.name = "Q27G1WG4
    "
			Part of profile(s): output:hdmi-stereo-extra1, output:hdmi-dts-surround-extra1
		hdmi-output-2: HDMI / DisplayPort 3 (type: HDMI, priority: 5700, latency offset: 0 usec, not available)
			Properties:
				device.icon_name = "video-display"
			Part of profile(s): output:hdmi-stereo-extra2, output:hdmi-surround-extra2, output:hdmi-surround71-extra2, output:hdmi-dts-surround-extra2
		hdmi-output-3: HDMI / DisplayPort 4 (type: HDMI, priority: 5600, latency offset: 0 usec, not available)
			Properties:
				device.icon_name = "video-display"
			Part of profile(s): output:hdmi-stereo-extra3, output:hdmi-surround-extra3, output:hdmi-surround71-extra3, output:hdmi-dts-surround-extra3

Card #2
	Name: alsa_card.usb-Focusrite_Scarlett_Solo_USB_Y71MXGY28FDE66-00
	Driver: module-alsa-card.c
	Owner Module: 8
	Properties:
		alsa.card = "3"
		alsa.card_name = "Scarlett Solo USB"
		alsa.long_card_name = "Focusrite Scarlett Solo USB at usb-0000:0b:00.3-3, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:0b:00.3-usb-0:3:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:07.1/0000:0b:00.3/usb5/5-3/5-3:1.0/sound/card3"
		udev.id = "usb-Focusrite_Scarlett_Solo_USB_Y71MXGY28FDE66-00"
		device.bus = "usb"
		device.vendor.id = "1235"
		device.vendor.name = "Focusrite-Novation"
		device.product.id = "8211"
		device.product.name = "Scarlett Solo (3rd Gen.)"
		device.serial = "Focusrite_Scarlett_Solo_USB_Y71MXGY28FDE66"
		device.string = "3"
		device.description = "Scarlett Solo (3rd Gen.)"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	Profiles:
		Direct: Direct Scarlett Solo USB (sinks: 1, sources: 1, priority: 1, available: yes)
		HiFi: Default (sinks: 1, sources: 2, priority: 8000, available: yes)
		off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
	Active Profile: HiFi
	Ports:
		[Out] Direct: Direct Scarlett Solo USB (type: Unknown, priority: 1000, latency offset: 0 usec, availability unknown)
			Part of profile(s): Direct
		[In] Direct: Direct Scarlett Solo USB (type: Unknown, priority: 1000, latency offset: 0 usec, availability unknown)
			Part of profile(s): Direct
		[Out] Line1: Headphones / Line 1-2 (type: Line, priority: 200, latency offset: 0 usec, availability unknown)
			Part of profile(s): HiFi
		[In] Mic2: Input 2 Inst/Line (type: Mic, priority: 100, latency offset: 0 usec, availability unknown)
			Part of profile(s): HiFi
		[In] Mic1: Input 1 Mic (type: Mic, priority: 200, latency offset: 0 usec, availability unknown)
			Part of profile(s): HiFi

Card #3
	Name: alsa_card.pci-0000_0c_00.3
	Driver: module-alsa-card.c
	Owner Module: 9
	Properties:
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xfc900000 irq 121"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:0c:00.3"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:0c:00.3/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.product.id = "1457"
		device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
		device.string = "1"
		device.description = "Family 17h (Models 00h-0fh) HD Audio Controller"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Profiles:
		input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority: 65, available: no)
		output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority: 39268, available: yes)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority: 6565, available: yes)
		output:analog-surround-21: Analog Surround 2.1 Output (sinks: 1, sources: 0, priority: 34068, available: yes)
		output:analog-surround-21+input:analog-stereo: Analog Surround 2.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1365, available: yes)
		output:analog-surround-40: Analog Surround 4.0 Output (sinks: 1, sources: 0, priority: 33968, available: yes)
		output:analog-surround-40+input:analog-stereo: Analog Surround 4.0 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1265, available: yes)
		output:analog-surround-41: Analog Surround 4.1 Output (sinks: 1, sources: 0, priority: 34068, available: yes)
		output:analog-surround-41+input:analog-stereo: Analog Surround 4.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1365, available: yes)
		output:analog-surround-50: Analog Surround 5.0 Output (sinks: 1, sources: 0, priority: 33968, available: yes)
		output:analog-surround-50+input:analog-stereo: Analog Surround 5.0 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1265, available: yes)
		output:analog-surround-51: Analog Surround 5.1 Output (sinks: 1, sources: 0, priority: 34068, available: yes)
		output:analog-surround-51+input:analog-stereo: Analog Surround 5.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1365, available: yes)
		output:iec958-stereo: Digital Stereo (IEC958) Output (sinks: 1, sources: 0, priority: 38268, available: yes)
		output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 5565, available: yes)
		output:iec958-ac3-surround-51: Digital Surround 5.1 (IEC958/AC3) Output (sinks: 1, sources: 0, priority: 300, available: yes)
		output:iec958-ac3-surround-51+input:analog-stereo: Digital Surround 5.1 (IEC958/AC3) Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 365, available: no)
		output:iec958-dts-surround-51: Digital Surround 5.1 (IEC958/DTS) Output (sinks: 1, sources: 0, priority: 33068, available: yes)
		output:iec958-dts-surround-51+input:analog-stereo: Digital Surround 5.1 (IEC958/DTS) Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 365, available: yes)
		off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
	Active Profile: output:analog-surround-51
	Ports:
		analog-input-front-mic: Front Microphone (type: Mic, priority: 8500, latency offset: 0 usec, not available)
			Properties:
				device.icon_name = "audio-input-microphone"
			Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-21+input:analog-stereo, output:analog-surround-40+input:analog-stereo, output:analog-surround-41+input:analog-stereo, output:analog-surround-50+input:analog-stereo, output:analog-surround-51+input:analog-stereo, output:iec958-stereo+input:analog-stereo, output:iec958-ac3-surround-51+input:analog-stereo, output:iec958-dts-surround-51+input:analog-stereo
		analog-input-rear-mic: Rear Microphone (type: Mic, priority: 8200, latency offset: 0 usec, not available)
			Properties:
				device.icon_name = "audio-input-microphone"
			Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-21+input:analog-stereo, output:analog-surround-40+input:analog-stereo, output:analog-surround-41+input:analog-stereo, output:analog-surround-50+input:analog-stereo, output:analog-surround-51+input:analog-stereo, output:iec958-stereo+input:analog-stereo, output:iec958-ac3-surround-51+input:analog-stereo, output:iec958-dts-surround-51+input:analog-stereo
		analog-input-linein: Line In (type: Line, priority: 8100, latency offset: 0 usec, not available)
			Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-21+input:analog-stereo, output:analog-surround-40+input:analog-stereo, output:analog-surround-41+input:analog-stereo, output:analog-surround-50+input:analog-stereo, output:analog-surround-51+input:analog-stereo, output:iec958-stereo+input:analog-stereo, output:iec958-ac3-surround-51+input:analog-stereo, output:iec958-dts-surround-51+input:analog-stereo
		analog-output-lineout: Line Out (type: Line, priority: 9000, latency offset: 0 usec, available)
			Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-21, output:analog-surround-21+input:analog-stereo, output:analog-surround-40, output:analog-surround-40+input:analog-stereo, output:analog-surround-41, output:analog-surround-41+input:analog-stereo, output:analog-surround-50, output:analog-surround-50+input:analog-stereo, output:analog-surround-51, output:analog-surround-51+input:analog-stereo
		analog-output-headphones: Headphones (type: Headphones, priority: 9900, latency offset: 0 usec, not available)
			Properties:
				device.icon_name = "audio-headphones"
			Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo
		iec958-stereo-output: Digital Output (S/PDIF) (type: SPDIF, priority: 0, latency offset: 0 usec, availability unknown)
			Part of profile(s): output:iec958-stereo, output:iec958-stereo+input:analog-stereo, output:iec958-dts-surround-51, output:iec958-dts-surround-51+input:analog-stereo
pactl list sinks :

Sink #0
	State: SUSPENDED
	Name: alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo
	Description: Audio Adapter (Unitek Y-247A) Analog Stereo
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 6
	Mute: no
	Volume: front-left: 46765 /  71% / -8.79 dB,   front-right: 46765 /  71% / -8.79 dB
	       balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo.monitor
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	Properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "USB Audio"
		alsa.id = "USB Audio"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "2"
		alsa.card_name = "USB Audio Device"
		alsa.long_card_name = "C-Media Electronics Inc. USB Audio Device at usb-0000:09:00.0-2, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:09:00.0-usb-0:2:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:01.3/0000:02:00.2/0000:03:09.0/0000:09:00.0/usb3/3-2/3-2:1.0/sound/card2"
		udev.id = "usb-C-Media_Electronics_Inc._USB_Audio_Device-00"
		device.bus = "usb"
		device.vendor.id = "0d8c"
		device.vendor.name = "C-Media Electronics, Inc."
		device.product.id = "0014"
		device.product.name = "Audio Adapter (Unitek Y-247A)"
		device.serial = "C-Media_Electronics_Inc._USB_Audio_Device"
		device.string = "front:2"
		device.buffering.buffer_size = "50000"
		device.buffering.fragment_size = "25000"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Audio Adapter (Unitek Y-247A) Analog Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	Ports:
		analog-output-speaker: Speakers (type: Speaker, priority: 10000, availability unknown)
	Active Port: analog-output-speaker
	Formats:
		pcm

Sink #2
	State: SUSPENDED
	Name: alsa_output.usb-Focusrite_Scarlett_Solo_USB_Y71MXGY28FDE66-00.HiFi__hw_USB__sink
	Description: Scarlett Solo (3rd Gen.) Headphones / Line 1-2
	Driver: module-alsa-card.c
	Sample Specification: s32le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 8
	Mute: no
	Volume: front-left: 65531 / 100% / -0.00 dB,   front-right: 65531 / 100% / -0.00 dB
	       balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.usb-Focusrite_Scarlett_Solo_USB_Y71MXGY28FDE66-00.HiFi__hw_USB__sink.monitor
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE DECIBEL_VOLUME LATENCY 
	Properties:
		alsa.resolution_bits = "32"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "USB Audio"
		alsa.id = "USB Audio"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "3"
		alsa.card_name = "Scarlett Solo USB"
		alsa.long_card_name = "Focusrite Scarlett Solo USB at usb-0000:0b:00.3-3, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:0b:00.3-usb-0:3:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:07.1/0000:0b:00.3/usb5/5-3/5-3:1.0/sound/card3"
		udev.id = "usb-Focusrite_Scarlett_Solo_USB_Y71MXGY28FDE66-00"
		device.bus = "usb"
		device.vendor.id = "1235"
		device.vendor.name = "Focusrite-Novation"
		device.product.id = "8211"
		device.product.name = "Scarlett Solo (3rd Gen.)"
		device.serial = "Focusrite_Scarlett_Solo_USB_Y71MXGY28FDE66"
		device.string = "_ucm0005.hw:USB"
		device.buffering.buffer_size = "100000"
		device.buffering.fragment_size = "50000"
		device.access_mode = "mmap+timer"
		device.profile.name = "HiFi: hw:USB: sink"
		device.profile.description = "Headphones / Line 1-2"
		alsa.mixer_device = "_ucm0005.hw:USB"
		device.description = "Scarlett Solo (3rd Gen.) Headphones / Line 1-2"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	Ports:
		[Out] Line1: Headphones / Line 1-2 (type: Line, priority: 200, availability unknown)
	Active Port: [Out] Line1
	Formats:
		pcm

Sink #5
	State: RUNNING
	Name: alsa_output.pci-0000_0c_00.3.analog-surround-51
	Description: Family 17h (Models 00h-0fh) HD Audio Controller Analog Surround 5.1
	Driver: module-alsa-card.c
	Sample Specification: s16le 6ch 48000Hz
	Channel Map: front-left,front-right,rear-left,rear-right,front-center,lfe
	Owner Module: 9
	Mute: no
	Volume: front-left: 65521 / 100% / -0.01 dB,   front-right: 65521 / 100% / -0.01 dB,   rear-left: 65521 / 100% / -0.01 dB,   rear-right: 65521 / 100% / -0.01 dB,   front-center: 65521 / 100% / -0.01 dB,   lfe: 65521 / 100% / -0.01 dB
	       balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.pci-0000_0c_00.3.analog-surround-51.monitor
	Latency: 75584 usec, configured 75000 usec
	Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	Properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC1220 Analog"
		alsa.id = "ALC1220 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xfc900000 irq 121"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:0c:00.3"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:0c:00.3/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.product.id = "1457"
		device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
		device.string = "surround51:1"
		device.buffering.buffer_size = "150144"
		device.buffering.fragment_size = "8832"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-surround-51"
		device.profile.description = "Analog Surround 5.1"
		device.description = "Family 17h (Models 00h-0fh) HD Audio Controller Analog Surround 5.1"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Ports:
		analog-output-lineout: Line Out (type: Line, priority: 9000, available)
	Active Port: analog-output-lineout
	Formats:
		pcm

Sink #9
	State: SUSPENDED
	Name: alsa_output.pci-0000_0a_00.1.hdmi-stereo
	Description: GP104 High Definition Audio Controller Digital Stereo (HDMI)
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 7
	Mute: no
	Volume: front-left: 65532 / 100% / -0.00 dB,   front-right: 65532 / 100% / -0.00 dB
	       balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.pci-0000_0a_00.1.hdmi-stereo.monitor
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE DECIBEL_VOLUME LATENCY SET_FORMATS 
	Properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "HDMI 0 *"
		alsa.id = "HDMI 0"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "3"
		alsa.card = "0"
		alsa.card_name = "HDA NVidia"
		alsa.long_card_name = "HDA NVidia at 0xfc080000 irq 119"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:0a:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:03.1/0000:0a:00.1/sound/card0"
		device.bus = "pci"
		device.vendor.id = "10de"
		device.vendor.name = "NVIDIA Corporation"
		device.product.id = "10f0"
		device.product.name = "GP104 High Definition Audio Controller"
		device.string = "hdmi:0"
		device.buffering.buffer_size = "50048"
		device.buffering.fragment_size = "2944"
		device.access_mode = "mmap+timer"
		device.profile.name = "hdmi-stereo"
		device.profile.description = "Digital Stereo (HDMI)"
		device.description = "GP104 High Definition Audio Controller Digital Stereo (HDMI)"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Ports:
		hdmi-output-0: HDMI / DisplayPort (type: HDMI, priority: 5900, available)
	Active Port: hdmi-output-0
	Formats:
		pcm
pactl list sink-outputs :

Specify nothing, or one of: modules, sinks, sources, sink-inputs, source-outputs, clients, samples, cards, message-handlers

I then tried:

pactl list source-outputs

And got no output.

Offline

#4 2023-09-15 02:10:56

topcat01
Member
Registered: 2019-09-17
Posts: 127

Re: Can't get 5.1 surround sound on my setup, only 2.1 works

Trying to understand the setup: Do you have 5 RCA cables connecting 5 channels to your AVR + 1 one to your sub, so all output from the computer is analog?

Your Windows setup might have been upmixing stereo to 5.1. Most youtube and/or spotify output will be stereo as V1del mentioned. Have you tried the speaker-test utility?

Edit: Just reread your posts and noticed "single RCA cable". Are you using digital co-axial from computer to AVR and not in fact RCA (they are similar but not exactly the same electrically).

Last edited by topcat01 (2023-09-15 02:15:20)

Offline

#5 2023-09-15 02:16:51

weepr
Member
Registered: 2023-09-12
Posts: 8

Re: Can't get 5.1 surround sound on my setup, only 2.1 works

It's one RCA cable from my desktop to my AVR. The 5 main speakers are connected to the AVR by speaker wire (copper), while the woofer is connected to the AVR via one RCA cable. So yes it should be analog, and I agree that windows was likely upmixing to 5.1. I haven't heard of the speaker-test utility but I'll make sure to try it.

EDIT: You're probably correct, after a quick search, the cable connecting my AVR to my computer is, in fact, digital coaxial

Last edited by weepr (2023-09-15 02:23:28)

Offline

#6 2023-09-15 02:21:00

topcat01
Member
Registered: 2019-09-17
Posts: 127

Re: Can't get 5.1 surround sound on my setup, only 2.1 works

No, in this case you are using digital from computer to AVR, i.e., S/PDIF. A single analog cable cannot carry multiple channels (in this setup). Your receiver shows Linear PCM as input?

Offline

#7 2023-09-15 03:02:31

weepr
Member
Registered: 2023-09-12
Posts: 8

Re: Can't get 5.1 surround sound on my setup, only 2.1 works

Yes, I apologize for the confusion. I got it confused with RCA because it has the red and white connectors going into the AVR.

Offline

#8 2023-09-16 04:58:08

weepr
Member
Registered: 2023-09-12
Posts: 8

Re: Can't get 5.1 surround sound on my setup, only 2.1 works

Update: I have been messing around with my asound.conf file and pavucontrol, but still can't upmix the stereo output to 5.1, and "speaker-test -c2 -twav" only plays from my front left and front right speakers.

Here is my current asound.conf file:

# http://alsa.opensrc.org/SurroundSound
# http://alsa.opensrc.org/Low-pass_filter_for_subwoofer_channel_%28HOWTO%29
# Arch Linux:  pacman -S ladspa blop swh-plugins libsamplerate tap-plugins cmt
# speaker-test -D upmix_20to51 -c 2 -t wav
# listplugins
# analyseplugin cmt
# http://plugin.org.uk/ladspa-swh/docs/ladspa-swh.html
pcm.lowpass_21to21 {
    type ladspa
    slave.pcm upmix_21to51
    path "/usr/lib/ladspa"
    channels 3
    plugins {
      0 {
         id 1098  # Identity (Audio) (1098/identity_audio)
         policy duplicate
         input.bindings.0 "Input";
         output.bindings.0 "Output";
      }

      1 {
         id 1052  # High-pass filter
         policy none
         input.bindings.0 "Input";
         output.bindings.0 "Output";
         input {
            controls [ 100 ]
         }
      }

      2 {
         id 1052  # High-pass filter
         policy none
         input.bindings.1 "Input";
         output.bindings.1 "Output";
         input {
            controls [ 100 ]
         }
      }

      3 {
         id 1051  # Low-pass filter
         policy none
         input.bindings.2 "Input";
         output.bindings.2 "Output";
         input {
            controls [ 100 ]
         }
      }

   }
}


pcm.upmix_20to51 {
   type plug
   slave.pcm "lowpass_21to21"
   slave.channels 3
   ttable {
      0.0     1       # left channel
      1.1     1       # right channel
      0.2     0.5     # mix left and right ...
      1.2     0.5     # ... channel for subwoofer
   }
}


pcm.upmix_21to51 {
   type plug
   slave.pcm surround51
   slave.channels 6
   ttable {
      0.0     1       # front left
      1.1     1       # front right
      0.2     1       # rear left
      1.3     1       # rear right

      # Front left/right to center.
      0.4     0.5
      1.4     0.5

      # Subwoofer, more powerful to compensate for bass-removal from other speakers.
      # Would normally be 1.
      2.5     2
    }
}

And here is the file located at /usr/share/alsa/pcm/default.conf:

#
# Default output
#

pcm.!default {
    type route
## forwards to the mixer pcm defined below
    slave.pcm dmix51
    slave.channels 6

## "Native Channels" stereo, swap left/right
    ttable.0.1 1
    ttable.1.0 1
## original normal left/right commented out
#    ttable.0.0 1
#    ttable.1.1 1

## route "native surround" so it still works but weaken signal (+ RL/RF swap) 
## because my rear speakers are more like random than really behind me
    ttable.2.3 0.7
    ttable.3.2 0.7
    ttable.4.4 0.7
    ttable.5.5 0.7

## stereo => quad speaker "upmix" for "rear" speakers + swap L/R
    ttable.0.3 1
    ttable.1.2 1

## stereo L+R => join to Center & Subwoofer 50%/50%
    ttable.0.4 0.5
    ttable.1.4 0.5
    ttable.0.5 0.5
    ttable.1.5 0.5
## to test: "$ speaker-test -c6 -twav" and: "$ speaker-test -c2 -twav"
}

pcm.dmix51 {
	type dmix
	ipc_key 1024
# let multiple users share
	ipc_key_add_uid false 
# IPC permissions (octal, default 0600)
# I think changing this fixed something - but I'm not sure what.
	ipc_perm 0660 # 
	slave {
## this is specific to my hda_intel. Often hd:0 is just allready it; To find: $ aplay -L 
		pcm surround51 
# this rate makes my soundcard crackle
#		rate 44100
# this rate stops flash in firefox from playing audio, but I do not need that
       rate 48000
       channels 6
## Any other values in the 4 lines below seem to make my soundcard crackle, too
       period_time 0
       period_size 1024
       buffer_time 0
       buffer_size 4096
	}
}

Any additional help on this issue would be appreciated. Thanks again.

Offline

#9 2023-09-19 13:54:20

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,375

Re: Can't get 5.1 surround sound on my setup, only 2.1 works

Don't mess around with alsa configurations, this won't be reflected in pipewire and pulse clients. Remove that config. Your primary goal will be to get the 5.1 DTS or AC3 digital signals to work correctly. That's the only way you can pass a 5.1 signal over a stereo (digital) channel. For plain upmixing a simple (pulse) config is sufficient, but you need to get the 5.1 compressed nodes running. If you are on pulse and get crackling with the 5.1 AC3/DTS options, try adding

tsched=0

to the

load-module module-udev-detect

line in your /etc/pulse/default.pa

Potentially check: https://wiki.archlinux.org/title/PulseA … S_via_ALSA though it is my understanding that most of this should be provided by current alsa-plugin versions anyway.

Last edited by V1del (2023-09-19 13:55:55)

Offline

Board footer

Powered by FluxBB