You are not logged in.

#1 2004-04-04 12:44:02

From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772

KDE 3.2.1 needs Qt 3.3.1 (dependency required)

The kdeartwork-3.2.1-1 build requires Qt 3.3.1 to allow KDE to use the Plastik theme (and all the other not-built-in themes).
kdeartwork depends on kdelibs, but, from my experience, KDE 3.2.1 works fine without Qt 3.3.1 (with 3.3.0, in my case).

So, I can't actually say kdelibs should depend on Qt 3.3.1. I see it more like kdeartworks should depend on Qt 3.3.1, even though it does not look right. (There might be other packs compiled against 3.3.1 though)

The KDE Requirement list ( says that KDE Requires Qt >=3.2.3. In my opinion, all the KDE packs should be built against the same Qt lib, and that lib should be set as a dependency for kdelibs.


Board footer

Powered by FluxBB