You are not logged in.

#1 2023-09-18 12:17:43

KGS9
Member
Registered: 2023-09-18
Posts: 15

"Failed to connect to bus: No medium found" in systemctl --user

I install pipewire  pipewire-pulse, and  follow wiki to enable the service with

systemctl --now enable pipewire --user
systemctl --now enable pipewire-pulse --user

I get this message

Failed to connect to bus: No medium found

the $DBUS_SESSION_BUS_ADDRESS is "unix:path=/run/user/1000/bus", i think that's important

Offline

#2 2023-09-18 12:21:54

KGS9
Member
Registered: 2023-09-18
Posts: 15

Re: "Failed to connect to bus: No medium found" in systemctl --user

And i try other use ""systemctl --user" command
e.g.

systemctl --user list-units
systemctl --user status
systemctl --user show

there all give me

Failed to connect to bus: No medium found

Offline

#3 2023-09-18 15:36:04

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: "Failed to connect to bus: No medium found" in systemctl --user

(dbus-send --session --print-reply --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.ListNames; loginctl session-status; ps fax) | curl -F 'file=@-' 0x0.st

Offline

#4 2023-09-19 02:44:55

KGS9
Member
Registered: 2023-09-18
Posts: 15

Re: "Failed to connect to bus: No medium found" in systemctl --user

seth wrote:
(dbus-send --session --print-reply --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.ListNames; loginctl session-status; ps fax) | curl -F 'file=@-' 0x0.st

http://0x0.st/HOp_.txt

Offline

#5 2023-09-19 06:46:47

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: "Failed to connect to bus: No medium found" in systemctl --user

You can talk to the session daemon and there's no dbus-launch eating your lunch.
Please post your ~/.xinitrc for the usual suspect (and you can also try to cut out greetd and log into agetty and startx from there, assuming your xinitrc is fine)

Offline

#6 2023-09-19 10:13:47

KGS9
Member
Registered: 2023-09-18
Posts: 15

Re: "Failed to connect to bus: No medium found" in systemctl --user

seth wrote:

You can talk to the session daemon and there's no dbus-launch eating your lunch.
Please post your ~/.xinitrc for the usual suspect (and you can also try to cut out greetd and log into agetty and startx from there, assuming your xinitrc is fine)

I think that's greetd problem, because my xinitrc has only two row

export LANG=zh_CN.UTF-8
exec awesome

but... why is that?

Offline

#7 2023-09-19 11:57:56

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: "Failed to connect to bus: No medium found" in systemctl --user

Last link below, pay attention to what parts from the default xinitrc to incorporate at least.
You might also want to re-use the TTY (as described in the xserverrc section on the same page)

Offline

#8 2023-09-28 13:15:20

KGS9
Member
Registered: 2023-09-18
Posts: 15

Re: "Failed to connect to bus: No medium found" in systemctl --user

seth wrote:

Last link below, pay attention to what parts from the default xinitrc to incorporate at least.
You might also want to re-use the TTY (as described in the xserverrc section on the same page)

I can't fix this...
I try disable greetd, copy default xinitrc to home dir, try in other TTY start xorg but it all can't fix.
Can I delate some config for dbus, generate new default config to fix this question?

PS: Attach my xinitrc

#!/bin/sh
export LANG=zh_CN.UTF-8

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"
fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs
if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

exec awesome

Offline

#9 2023-09-28 13:22:35

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: "Failed to connect to bus: No medium found" in systemctl --user

The updated xinitrc is ok.

strace -f -tt -o /tmp/sysctl.strace systemctl --user list-units

Then post /tmp/sysctl.strace

Offline

#10 2023-09-28 13:53:00

KGS9
Member
Registered: 2023-09-18
Posts: 15

Re: "Failed to connect to bus: No medium found" in systemctl --user

seth wrote:

Last link below, pay attention to what parts from the default xinitrc to incorporate at least.
You might also want to re-use the TTY (as described in the xserverrc section on the same page)

Thanks you help,  I have fix this, the reason for this issue is that my XDG variable is not defined for certain reasons.

Offline

#11 2023-09-28 14:02:42

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: "Failed to connect to bus: No medium found" in systemctl --user

Some reason being greetd? seatd?

Don't gloss over that.

Offline

Board footer

Powered by FluxBB