You are not logged in.

#1 2023-11-11 03:12:26

jucramirezay
Member
Registered: 2023-11-11
Posts: 2

Error snort

Good night, I hope you are well

I am trying to install snort (3.1.71.0-1) on Arch Linux, but I have one problem. At the moment I make the arch install command (makepkg snort) over the snort package (downloaded by the arch repository https://aur.archlinux.org/packages/snort) I have an error related with libdaq:

==> Making package: snort 3.1.71.0-1 (Fri 10 Nov 2023 03:39:58 PM -05)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> libdaq
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

The real problem is that I have installed libdaq, my /usr/local/lib contain the next libdaq folders:

daq                                  libdaq.so                              libdaq_static_afpacket.a
libdaq_static_bpf.la         libdaq_static_fst.a                libdaq_static_gwlb.la libdaq_static_pcap.a       libdaq_static_savefile.la       pkgconfig
libdaq.a                           libdaq.so.3                            libdaq_static_afpacket.la      libdaq_static_dump.a      libdaq_static_fst.la                libdaq_static_nfq.a              libdaq_static_pcap.la      libdaq_static_trace.a             libdaq.la 
libdaq.so.3.0.0                libdaq_static_bpf.a                libdaq_static_dump.la libdaq_static_gwlb.a       libdaq_static_nfq.la               libdaq_static_savefile.a libdaq_static_trace.la

I don't know what the problem is. I also installed libdaq from arch linux repo (downloaded from https://aur.archlinux.org/packages/libdaq). I don't know how to solve it, I Don't know why snort doesn't recognize libdaq installation. I installed libdaq with the steps in this page https://github.com/snort3/libdaq/tree/v3.0.12.

./bootstrap
./configure
make
make install

I hope you can help me, I don't know how to solve it. Thank you for your help.

Offline

#2 2023-11-11 03:53:45

Awebb
Member
Registered: 2010-05-06
Posts: 6,262

Re: Error snort

If you have installed libdaq manually in /usr/local, then pacman doesn't have a chance to know that. Why did you use make/make install steps to install libdaq, when downloading the tarball from the AUR and building/installing it with makepkg is what you know to do with the other package?

Offline

#3 2023-11-11 04:53:26

jucramirezay
Member
Registered: 2023-11-11
Posts: 2

Re: Error snort

I have the same problem installing libdaq, but with libnetfilter_queue-git dependency, when I try to install libdaq from arch linux repo with makepkg libdaq.
==> Making package: libdaq 3.0.13-1 (Fri 10 Nov 2023 06:33:03 PM -05)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> libnetfilter_queue
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.
I installed libnetfilter_queue-git from arch linux repo (https://aur.archlinux.org/packages/libn … _queue-git) but I have the last error when I try installing libdaq.
Note: libnetfilter_queue-git was installed correctly with makepkg command

Offline

#4 2023-11-11 04:57:27

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,326

Re: Error snort

pacman -Q libnetfilter_queue

Why are you using the -git version instead of the one in extra? What command are you using to build?

Last edited by Scimmia (2023-11-11 04:59:05)

Online

Board footer

Powered by FluxBB