You are not logged in.

#1 2023-09-16 17:25:06

Registered: 2019-08-14
Posts: 99

Equalizer Can't Start

My audio is working fine, but equalizer won't run.

Alsamixer works no problem. To get audio working, i had to change card from 0 to 1 in .asoundrc

pcm.!default {
	type hw
	card 1

ctl.!default {
	type hw           
	card 1

I installed equalizer according to … #Equalizer

I Installed the alsaequal AUR package, created /etc/asound.conf, and

$ pacman -Q | grep alsa
alsa-card-profiles 1:0.3.80-1
alsa-lib 1.2.10-2
alsa-plugins 1:
alsa-ucm-conf 1.2.10-2
alsa-utils 1.2.10-1
alsaequal v0.7.1-1


$ alsamixer -D equal
Failed to load plugin "": cannot open shared object file: No such file or directory

I installed caps (used to be in AUR, now in main repo)

But still getting same error.


$ listplugins 
Warning: You do not have a LADSPA_PATH environment variable set. Defaulting to /usr/lib/ladspa/.
	Simple Low Pass Filter (1041/lpf)
	Simple High Pass Filter (1042/hpf)
	Simple Delay Line (1043/delay_5s)
	C* Noisegate - Attenuating hum and noise (2602/Noisegate)
	C* Compress - Compressor and saturating limiter (1772/Compress)
	C* CompressX2 - Stereo compressor and saturating limiter (2598/CompressX2)
	C* ToneStack - Classic amplifier tone stack emulation (2589/ToneStack)
	C* AmpVTS - Idealised guitar amplification (2592/AmpVTS)
	C* CabinetIII - Simplistic loudspeaker cabinet emulation (2601/CabinetIII)
	C* CabinetIV - Idealised loudspeaker cabinet (2606/CabinetIV)
	C* Plate - Versatile plate reverb (1779/Plate)
	C* PlateX2 - Versatile plate reverb, stereo inputs (1795/PlateX2)
	C* Saturate - Various static nonlinearities, 8x oversampled (1771/Saturate)
	C* Spice - Not an exciter (2603/Spice)
	C* SpiceX2 - Not an exciter either (2607/SpiceX2)
	C* ChorusI - Mono chorus/flanger (1767/ChorusI)
	C* PhaserII - Mono phaser (2586/PhaserII)
	C* AutoFilter - Self-modulating resonant filter (2593/AutoFilter)
	C* Scape - Stereo delay with chromatic resonances (2588/Scape)
	C* Eq10 - 10-band equaliser (1773/Eq10)
	C* Eq10X2 - Stereo 10-band equaliser (2594/Eq10X2)
	C* Eq4p - 4-band parametric shelving equaliser (2608/Eq4p)
	C* EqFA4p - 4-band parametric eq (2609/EqFA4p)
	C* Wider - Stereo image synthesis (1788/Wider)
	C* Narrower - Stereo image width reduction (2595/Narrower)
	C* Sin - Sine wave generator (1781/Sin)
	C* White - Noise generator (1785/White)
	C* Fractal - Audio stream from deterministic chaos (1774/Fractal)
	C* Click - Metronome (1769/Click)
	C* CEO - Chief Executive Oscillator (1770/CEO)
	Sine Oscillator (Freq:audio, Amp:audio) (1044/sine_faaa)
	Sine Oscillator (Freq:audio, Amp:control) (1045/sine_faac)
	Sine Oscillator (Freq:control, Amp:audio) (1046/sine_fcaa)
	Sine Oscillator (Freq:control, Amp:control) (1047/sine_fcac)
	Mono Amplifier (1048/amp_mono)
	Stereo Amplifier (1049/amp_stereo)
	White Noise Source (1050/noise_white)

I ran the statement here, but accidentally neglected to use "/usr/lib32/ladspa/"

I don't know how or if i need to back out of the above (cuz accidentally neglected to use "/usr/lib32/ladspa/"), or if that's even the fix for the EQ.

But still getting:

$ listplugins 
Warning: You do not have a LADSPA_PATH environment variable set. Defaulting to /usr/lib/ladspa/.

Lenovo IdeaCenter

$ lscpu
Architecture:            x86_64
  CPU op-mode(s):        32-bit, 64-bit
  Address sizes:         48 bits physical, 48 bits virtual
  Byte Order:            Little Endian
CPU(s):                  2
  On-line CPU(s) list:   0,1
Vendor ID:               AuthenticAMD
  Model name:            AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G
    CPU family:          21
    Model:               112
    Thread(s) per core:  1
    Core(s) per socket:  2
    Socket(s):           1
    Stepping:            0
    Frequency boost:     enabled
    CPU(s) scaling MHz:  47%
    CPU max MHz:         3000.0000
    CPU min MHz:         1400.0000
    BogoMIPS:            5991.62
    Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe
                         1gb rdtscp lm constant_tsc rep_good acc_power nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse
                         4_1 sse4_2 movbe popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xo
                         p skinit wdt lwp fma4 tce nodeid_msr tbm perfctr_core perfctr_nb bpext ptsc mwaitx cpb hw_pstate ssbd ibpb vmmcall fsgsbase bmi1 avx
                         2 smep bmi2 xsaveopt arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_
                         vmsave_vmload vgif overflow_recov
Virtualization features: 
  Virtualization:        AMD-V
Caches (sum of all):     
  L1d:                   64 KiB (2 instances)
  L1i:                   128 KiB (2 instances)
  L2:                    2 MiB (2 instances)
  NUMA node(s):          1
  NUMA node0 CPU(s):     0,1
  Gather data sampling:  Not affected
  Itlb multihit:         Not affected
  L1tf:                  Not affected
  Mds:                   Not affected
  Meltdown:              Not affected
  Mmio stale data:       Not affected
  Retbleed:              Mitigation; untrained return thunk; SMT disabled
  Spec rstack overflow:  Not affected
  Spec store bypass:     Mitigation; Speculative Store Bypass disabled via prctl
  Spectre v1:            Mitigation; usercopy/swapgs barriers and __user pointer sanitization
  Spectre v2:            Mitigation; Retpolines, IBPB conditional, STIBP disabled, RSB filling, PBRSB-eIBRS Not affected
  Srbds:                 Not affected
  Tsx async abort:       Not affected

arch installed with archinstall

Last edited by atomikegg (2023-09-17 17:20:11)


#2 2023-11-14 07:58:08

Registered: 2023-11-14
Posts: 1

Re: Equalizer Can't Start

According to you can solve this by exporting the LADSPA_PATH. It did solve the issue for me, but I also had previously installed `alsa-plugins` and `ladspa`.

"exporting the environment variable


should fix the issue."


Board footer

Powered by FluxBB