You are not logged in.

#1 2023-05-19 17:37:21

Vencez
Member
Registered: 2023-05-13
Posts: 2

[SOLVED] Intel graphics - driver not working properly

Hello everyone,

I recently installed Arch Linux on my new HP Pavilion 15-eg2051nc computer, but I'm having trouble getting the graphics card driver to work. The GPU on my computer is the Intel Corporation Alder Lake-P Integrated G.

I started by installing Mesa and followed the instructions on the ArchWiki. I also tried adding or changing options in the /etc/X11/xorg.conf.d/20-intel.conf file, but none of these helped.

glxinfo -B

outputs the following:

name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel (0x8086)
    Device: Mesa Intel(R) Graphics (ADL GT2) (0x46a6)
    Version: 23.0.3
    Accelerated: yes
    Video memory: 15666MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.6
    Max compat profile version: 4.6
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Graphics (ADL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.0.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.0.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.0.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

which seems to be fine. However, when I run glxgears, the gears in the application don't rotate.

I also couldn't find spot any error after running

cat .local/share/xorg/Xorg.0.log | grep -i intel

which shows the following:

[   562.561] (==) Matched intel as autoconfigured driver 0                                                                                                     
[   562.561] (II) LoadModule: "intel"                                                                                                                          
[   562.561] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so                                                                                           
[   562.562] (II) Module intel: vendor="X.Org Foundation"                                                                                                      
[   562.562] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:                                                                                     
[   562.563] (II) intel: Driver for Intel(R) HD Graphics                                                                                                       
[   562.563] (II) intel: Driver for Intel(R) Iris(TM) Graphics                                                                                                 
[   562.563] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics                                                                                             
[   562.563] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.                                                                                 6.0 20201103                                                                                                                                                   
[   562.563] (II) intel(0): SNA compiled from 2.99.917-923-gb74b67f0                                                                                           
[   562.564] (WW) intel(0): Unknown chipset                                                                                                                    
[   562.564] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, av                                                                                 x, avx2; using a maximum of 12 threads                                                                                                                         
[   562.564] (II) intel(0): Creating default Display subsection in Screen sect                                                                                 ion                                                                                                                                                            
[   562.564] (==) intel(0): Depth 24, (--) framebuffer bpp 32                                                                                                  
[   562.564] (==) intel(0): RGB weight 888                                                                                                                     
[   562.564] (==) intel(0): Default visual is TrueColor                                                                                                        
[   562.565] (II) intel(0): Output eDP1 has no monitor section                                                                                                 
[   562.565] (**) intel(0): Found backlight control interface intel_backlight                                                                                  (type 'raw') for output eDP1                                                                                                                                   
[   562.565] (II) intel(0): Enabled output eDP1                                                                                                                
[   562.565] (II) intel(0): Output HDMI1 has no monitor section                                                                                                
[   562.565] (II) intel(0): Enabled output HDMI1                                                                                                               
[   562.565] (II) intel(0): Output DP1 has no monitor section
[   562.565] (II) intel(0): Enabled output DP1
[   562.565] (II) intel(0): Output DP2 has no monitor section
[   562.565] (II) intel(0): Enabled output DP2
[   562.565] (II) intel(0): Output DP3 has no monitor section
[   562.565] (II) intel(0): Enabled output DP3
[   562.565] (II) intel(0): Output DP4 has no monitor section
[   562.566] (II) intel(0): Enabled output DP4
[   562.566] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[   562.566] (II) intel(0): Output VIRTUAL1 has no monitor section
[   562.566] (II) intel(0): Enabled output VIRTUAL1
[   562.566] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
[   562.566] (==) intel(0): TearFree enabled
[   562.566] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[   562.566] (==) intel(0): DPI set to (96, 96)
[   562.567] (II) intel(0): SNA initialized with generic backend
[   562.567] (==) intel(0): Backing store enabled
[   562.567] (==) intel(0): Silken mouse enabled
[   562.567] (II) intel(0): HW Cursor enabled
[   562.567] (==) intel(0): DPMS enabled
[   562.567] (==) intel(0): Display hotplug detection enabled
[   562.567] (II) intel(0): Textured video not supported on this hardware or backend
[   562.567] (II) intel(0): [DRI2] Setup complete
[   562.567] (II) intel(0): [DRI2]   DRI driver: i965
[   562.567] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[   562.567] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[   562.567] (II) intel(0): hardware support for Present enabled
[   562.581] (EE) intel(0): Failed to submit rendering commands (Invalid argument), disabling acceleration.
[   562.581] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[   562.594] (II) intel(0): Setting screen physical size to 508 x 285
[   562.685] (II) config/udev: Adding input device Intel HID events (/dev/input/event5)
[   562.685] (**) Intel HID events: Applying InputClass "evdev keyboard catchall"
[   562.685] (**) Intel HID events: Applying InputClass "libinput keyboard catchall"
[   562.685] (**) Intel HID events: Applying InputClass "system-keyboard"
[   562.685] (II) Using input driver 'libinput' for 'Intel HID events'
[   562.686] (**) Intel HID events: always reports core events
[   562.686] (II) event5  - Intel HID events: is tagged by udev as: Keyboard
[   562.686] (II) event5  - Intel HID events: device is a keyboard
[   562.686] (II) event5  - Intel HID events: device removed
[   562.687] (**) Intel HID 5 button array: Applying InputClass "system-keyboard"
[   562.687] (II) Using input driver 'libinput' for 'Intel HID 5 button array'
[   562.688] (**) Intel HID 5 button array: always reports core events
[   562.688] (II) event6  - Intel HID 5 button array: is tagged by udev as: Keyboard
[   562.689] (II) event6  - Intel HID 5 button array: device is a keyboard
[   562.689] (II) event6  - Intel HID 5 button array: device removed
[   562.689] (II) XINPUT: Adding extended input device "Intel HID 5 button array" (type: KEYBOARD, id 12)
[   562.689] (II) event6  - Intel HID 5 button array: is tagged by udev as: Keyboard
[   562.689] (II) event6  - Intel HID 5 button array: device is a keyboard
[   564.574] (II) intel(0): EDID vendor "BOE", prod id 2688
[   564.574] (II) intel(0): Printing DDC gathered Modelines:
[   564.574] (II) intel(0): Modeline "1920x1080"x0.0  143.76  1920 1968 2000 2124  1080 1083 1089 1128 +hsync -vsync (67.7 kHz eP)
[   564.574] (II) intel(0): Modeline "1920x1080"x0.0   95.84  1920 1968 2000 2124  1080 1083 1089 1128 +hsync -vsync (45.1 kHz e)

Temporarily, I have replaced mesa with mesa-amber, which removed some parts of Mesa due to their mutual conflict. While using mesa-amber resolves the issue with the rotating gears, the GPU performance is not good and glxinfo produces errors saying that libGL was not loaded/found.

Do you have any ideas on how to fix this problem?

Last edited by Vencez (2023-05-23 10:53:32)

Offline

#2 2023-05-19 23:33:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,594

Re: [SOLVED] Intel graphics - driver not working properly

Switch back to mesa and remove xf86-video-intel and the config file you created for it. the latter is not maintained for GPUs newer than 2011ish

Last edited by V1del (2023-05-19 23:35:38)

Offline

#3 2023-05-20 15:59:33

Vencez
Member
Registered: 2023-05-13
Posts: 2

Re: [SOLVED] Intel graphics - driver not working properly

It works, thanks a lot.

Offline

#4 2023-05-21 15:29:26

seth
Member
Registered: 2012-09-03
Posts: 50,772

Re: [SOLVED] Intel graphics - driver not working properly

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

#5 2023-11-15 20:00:31

murpsam
Member
Registered: 2023-11-14
Posts: 3

Re: [SOLVED] Intel graphics - driver not working properly

V1del wrote:

Switch back to mesa and remove xf86-video-intel and the config file you created for it. the latter is not maintained for GPUs newer than 2011ish

Currently having a similar issue, when I try to 'switch back' to mesa i get this error:

sudo pacman -S mesa
resolving dependencies...
looking for conflicting packages...
:: mesa and mesa-amber are in conflict. Remove mesa-amber? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing mesa-amber breaks dependency 'mesa-amber' required by lib32-mesa-amber

lib32-mesa-amber even though i just installed it today has dependencies in every program? I literally can't remove it..

Offline

#6 2023-11-15 20:34:59

seth
Member
Registered: 2012-09-03
Posts: 50,772

Re: [SOLVED] Intel graphics - driver not working properly

This is entirely off-topic but you'll have to "pacman -S mesa lib32-mesa" to replace both packages at once.

Offline

Board footer

Powered by FluxBB