You are not logged in.

#1 2023-11-14 22:47:07

Registered: 2016-12-20
Posts: 28

Device not found when booting into LVM over LUKS

Edit: It's fixed already, it was a human mistake caused by lack of sleep and caffeine overdose. I didn't have the correct device id on  /etc/default/grub.
Can some admin delete this thread? It's not helpful for anyone.

I just made a fresh install on a laptop. I'm trying to boot into it, but I'm not able to open the encrypted partition when the system is booting. It never asks me for my password or anything.

The error I get when booting is:

ERROR: device '/dev/MyVolGroup/root' not found. Skipping fsck.
:: mounting '/dev/MyVolGroup/root' on real root
mount: /new_root: no valid filesystem type specified.
ERROR: Failed to mount '/dev/MyVolGroup/root' on real root


My fstab:

My /etc/default/grub:

My mkinitcpio.conf:

Not really sure what I'm missing here...

Last edited by hardrock (2023-11-15 09:19:34)


#2 2023-11-19 15:11:26

Registered: 2015-08-28
Posts: 201

Re: Device not found when booting into LVM over LUKS

I'd put [SOLVED] in the subject, so people know you solved it by fixing a typo in /etc/default/grub.

We all make these kinds of mistakes often enough, don't feel bad.  Someone may find this topic and double-check their own work.


Board footer

Powered by FluxBB