You are not logged in.

#1 2023-11-11 23:49:15

mauzy
Member
Registered: 2023-11-11
Posts: 6

[Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

Hey there!

System Information:

Kernel:   6.1.61-1-lts
DE:          Plasma 5.27.9
CPU:       13th Gen Intel i7, [Iris Xe Graphics]
RAM:      16 GB
- Recently switched from X to Wayland

Description:

When closing my laptop and storing it in my bag I noticed it would sometimes get hot. When opening the laptop, the battery is significantly drained and it appears a key was depressed in the login field. This key is usually the 'y' key or ';' (I don't believe there is much significance there). Upon logging in, my track-pad is disabled (because its off during typing) but my touch screen is fully functional. When navigating to a text box with the touchscreen, a key is still activated until I press that key.

The following error or similar is what appears every time this happens:
kwin_libinput: Libinput: event0  - Lid Switch: client bug: event processing lagging behind by 624ms, your system is too slow

sudo journalctl -b -p 3 output:

Nov 10 12:41:19 IgnisVeritas kernel: pci 0000:00:07.0: DPC: RP PIO log size 0 is invalid
Nov 10 12:41:19 IgnisVeritas kernel: pci 0000:00:07.2: DPC: RP PIO log size 0 is invalid
Nov 10 12:41:20 IgnisVeritas kernel: spi-nor spi0.0: unrecognized JEDEC id bytes: c2 75 17 c2 75 17
Nov 10 12:41:20 IgnisVeritas kernel: spi-nor spi0.1: unrecognized JEDEC id bytes: 20 40 18 20 40 18
Nov 10 12:41:22 IgnisVeritas kernel: Bluetooth: hci0: Malformed MSFT vendor event: 0x02
Nov 10 12:41:32 IgnisVeritas pipewire[1306]: spa.alsa: '_ucm0001.hw:sofhdadsp,5': playback open failed: Device or resource busy
Nov 10 12:41:32 IgnisVeritas pulseaudio[1415]: Failed to find a working profile.
Nov 10 12:41:32 IgnisVeritas pulseaudio[1415]: Failed to load module "module-alsa-card" (argument: "device_id="0" name="pci-0000_00_1f.3-platform-skl_hda_dsp_generic" card_name="alsa_card.pci-0000_00_1f>
Nov 10 12:41:32 IgnisVeritas pipewire[1306]: spa.alsa: '_ucm0002.hw:sofhdadsp,4': playback open failed: Device or resource busy
Nov 10 12:41:32 IgnisVeritas pipewire[1306]: spa.alsa: '_ucm0002.hw:sofhdadsp,3': playback open failed: Device or resource busy
Nov 10 12:42:10 IgnisVeritas systemd[928]: Failed to start setaswallpaper.
Nov 10 12:42:31 IgnisVeritas systemd[928]: Failed to start setaswallpaper.
Nov 10 12:42:40 IgnisVeritas systemd[928]: Failed to start setaswallpaper.
Nov 10 12:49:36 IgnisVeritas systemd[928]: Failed to start setaswallpaper.
Nov 10 13:00:20 IgnisVeritas kernel: ACPI Error: No handler for Region [RTCM] (000000001bd2623e) [SystemCMOS] (20220331/evregion-130)
Nov 10 13:00:20 IgnisVeritas kernel: ACPI Error: Region SystemCMOS (ID=5) has no handler (20220331/exfldio-261)
Nov 10 13:00:20 IgnisVeritas kernel: ACPI Error: Aborting method \_SB.PC00.LPCB.H_EC._Q36 due to previous error (AE_NOT_EXIST) (20220331/psparse-529)
Nov 10 13:21:12 IgnisVeritas kwin_wayland[969]: kwin_libinput: Libinput: client bug: timer event12 keyboard: scheduled expiry is in the past (-396ms), your system is too slow
Nov 10 13:21:12 IgnisVeritas kwin_wayland[969]: kwin_libinput: Libinput: client bug: timer event12 keyboard: scheduled expiry is in the past (-83ms), your system is too slow
Nov 10 13:21:12 IgnisVeritas kwin_wayland[969]: kwin_libinput: Libinput: client bug: timer event12 keyboard: scheduled expiry is in the past (-71ms), your system is too slow
Nov 11 13:47:30 IgnisVeritas kwin_wayland[969]: kwin_libinput: Libinput: event0  - Lid Switch: client bug: event processing lagging behind by 624ms, your system is too slow
Additional Information

From what I found, this libinput error is generic and many posts say that it can be safely ignored but I do believe it is consistent with the issue I am having. I am thinking that there is some process that is somehow blocking this signal and making it wait. Though, after watching my system resources I haven't been able to find anything significant. This could be because it is an intermittent issue.

Applications that I almost always have open:

  • Firefox

  • VScode

  • Kitty Terminal Emulator

  • Virt-Manager/Qemu

  • Discord

Any information or pointers would be greatly appreciated!
I've only been on this operating system for a few months and I'm new to forum posting. If you have any critiques on my post they would also be appreciated smile

Thank you so much for your time! I hope you're having a wonderful day smile

Last edited by mauzy (2023-11-25 19:57:43)

Offline

#2 2023-11-12 15:32:43

seth
Member
Registered: 2012-09-03
Posts: 51,056

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

Please don't post pictures of text, post the text.
Also don't embed oversized images, the board has a 250x250 rule.
Edit your post itr.

It would seem that the system either doesn't fall asleep or wakes up and from the symptoms it sounds as if the lid is pressing down some key(s)

Please post your complete system journal for and affected boot, eg.

sudo journalctl -b -1 | curl -F 'file=@-' 0x0.st

for the previous ("-1") one.

Offline

#3 2023-11-12 18:23:26

mauzy
Member
Registered: 2023-11-11
Posts: 6

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

Thank you.

Here is a link to my full logs created as described: http://0x0.st/HvHt.txt

After reading through it; I saw the lid closed, network manager disconnected its stuff and the laptop went to sleep. Then it returned from sleep. I did set it to go into hibernation to try to solve this problem but to no avail. Is it returning from sleep to hibernate? I should perhaps research exactly how sleep and hibernate work. It seems to do this once more before the lid opens and the "system too slow" error appears.

Nov 10 13:21:12 IgnisVeritas systemd-sleep[7245]: System returned from sleep state.
Nov 10 13:21:12 IgnisVeritas kernel: PM: suspend exit
Nov 10 13:21:12 IgnisVeritas kwin_wayland[969]: kwin_libinput: Libinput: client bug: timer event12 keyboard: scheduled expiry is in the past (-396ms), your system is too slow
Nov 10 13:21:12 IgnisVeritas kwin_wayland[969]: kwin_libinput: Libinput: client bug: timer event12 keyboard: scheduled expiry is in the past (-83ms), your system is too slow
Nov 10 13:21:12 IgnisVeritas kwin_wayland[969]: kwin_libinput: Libinput: client bug: timer event12 keyboard: scheduled expiry is in the past (-71ms), your system is too slow
Nov 10 13:21:12 IgnisVeritas systemd[1]: systemd-suspend-then-hibernate.service: Deactivated successfully.
Nov 10 13:21:12 IgnisVeritas systemd[1]: Finished Suspend; Hibernate if not used for a period of time.
Nov 10 13:21:12 IgnisVeritas systemd[1]: Stopped target Sleep.
Nov 10 13:21:12 IgnisVeritas systemd[1]: Reached target Suspend; Hibernate if not used for a period of time.
Nov 10 13:21:12 IgnisVeritas systemd[1]: Stopped target Suspend; Hibernate if not used for a period of time.
Nov 10 13:21:12 IgnisVeritas systemd-logind[587]: Operation 'sleep' finished. 

Later in the logs before a reboot, systemd core dumps but I didn't notice the same issue on login.

Still learning, please forgive my ignorance.

Last edited by mauzy (2023-11-13 19:14:12)

Offline

#4 2023-11-12 20:40:42

seth
Member
Registered: 2012-09-03
Posts: 51,056

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

That could be the cause, you don't have a resume parameter in the kernel commandline, so you cannot properly hibernate (and you're not)
https://wiki.archlinux.org/title/Power_ … ibernation

Next to that

Nov 10 13:21:11 IgnisVeritas kernel: PM: suspend entry (s2idle)
Nov 10 13:31:13 IgnisVeritas kernel: PM: suspend entry (s2idle)
Nov 11 11:58:44 IgnisVeritas kernel: PM: suspend entry (s2idle)

you're not going to "deep" sleep, check /sys/power/mem_sleep

Nov 10 13:21:10 IgnisVeritas systemd-logind[587]: Lid closed.
…
Nov 10 13:21:11 IgnisVeritas systemd-sleep[7245]: Entering sleep state 'suspend'...
…
Nov 10 13:21:12 IgnisVeritas systemd-sleep[7245]: System returned from sleep state.

Friday there was a 1s sleep? The system woke immediately?

Nov 10 13:31:13 IgnisVeritas systemd-sleep[7499]: Entering sleep state 'suspend'...
-
Nov 11 11:58:43 IgnisVeritas systemd-sleep[7499]: System returned from sleep state.

10 minutes later the system went to sleep for almost a day?

Nov 11 11:58:44 IgnisVeritas systemd-sleep[7641]: Entering sleep state 'suspend'...
…
Nov 11 13:47:30 IgnisVeritas systemd-logind[587]: Lid opened.
…
Nov 11 13:47:30 IgnisVeritas systemd-sleep[7641]: System returned from sleep state.

and then returned to sleep for another ~2h

Finally:

Nov 10 12:41:19 IgnisVeritas kernel:  nvme0n1: p1 p2 p3 p4 p5 p6 p7 p8

There're several partitions. Is there  a parallel windows installation?
=> 3rd link below. Mandatory.
Disable it (it's NOT the BIOS setting!) and reboot windows and linux twice for voodo reasons.


On a formal not, please use [code][/code] tags. Edit your post in this regard.

Offline

#5 2023-11-15 00:19:48

mauzy
Member
Registered: 2023-11-11
Posts: 6

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

Yes, I have a dual boot configuration with Windows 11. I have confirmed that fast boot is off. I spent a good amount of time researching and practicing installation of Arch Linux before going through with it :P . I am confident the install is correct.

I added the resume hook and kernel parameter for hibernate to my swap partition. I then confirmed hibernate works properly. However, I checked my power options and noticed neither hibernate nor hybrid sleep was set for the lid close action; just sleep.

I noticed in the log:

Nov 10 13:31:13 IgnisVeritas systemd[1]: Starting Suspend; Hibernate if not used for a period of time...

Since hibernate was not possible before without the kernel parameter perhaps it was causing some weird stuff to happen. It is odd it will try to hibernate when only sleep is selected and that it could be linked to the libinput error. I will monitor the system for a few days and mark this thread resolved if issue is not persisting.

Thank you for your time and help! :)

Offline

#6 2023-11-17 22:57:21

mauzy
Member
Registered: 2023-11-11
Posts: 6

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

After some more testing I found I was receiving the following error:

Nov 17 16:30:47 IgnisVeritas systemd-logind[589]: Lid closed.
Nov 17 16:30:47 IgnisVeritas org_kde_powerdevil[1206]: org.kde.powerdevil: Failed to start suspend job "org.freedesktop.login1.SleepVerbNotSupported" "Sleep verb \"suspend-then-hibernate\" not supported"
Nov 17 16:30:48 IgnisVeritas systemd-logind[589]: Lid opened.
Nov 17 16:30:57 IgnisVeritas kwin_wayland[974]: This plugin does not support raise()
Nov 17 16:31:06 IgnisVeritas systemd[931]: app-org.kde.kjournaldbrowser-ceba2d4a9ca84b068c8bf8d4e5913728.scope: Consumed 4.922s CPU time.
Nov 17 16:31:11 IgnisVeritas rtkit-daemon[1008]: Supervising 11 threads of 4 processes of 1 users.
Nov 17 16:31:11 IgnisVeritas rtkit-daemon[1008]: Supervising 11 threads of 4 processes of 1 users.
Nov 17 16:32:35 IgnisVeritas systemd[931]: app-kitty-957897c59fc94988815938afa4901ed1.scope: Consumed 40.385s CPU time.
Nov 17 16:34:35 IgnisVeritas systemd-logind[589]: Lid closed.
Nov 17 16:34:36 IgnisVeritas org_kde_powerdevil[1206]: org.kde.powerdevil: Failed to start suspend job "org.freedesktop.login1.SleepVerbNotSupported" "Sleep verb \"suspend-then-hibernate\" not supported"
Nov 17 16:34:38 IgnisVeritas systemd-logind[589]: Lid opened.
Nov 17 16:34:41 IgnisVeritas systemd-logind[589]: Lid closed.
Nov 17 16:34:41 IgnisVeritas org_kde_powerdevil[1206]: org.kde.powerdevil: Failed to start suspend job "org.freedesktop.login1.SleepVerbNotSupported" "Sleep verb \"suspend-then-hibernate\" not supported"
Nov 17 16:34:43 IgnisVeritas systemd-logind[589]: Lid opened.
Nov 17 16:34:46 IgnisVeritas systemd-logind[589]: Lid closed.
Nov 17 16:34:46 IgnisVeritas org_kde_powerdevil[1206]: org.kde.powerdevil: Failed to start suspend job "org.freedesktop.login1.SleepVerbNotSupported" "Sleep verb \"suspend-then-hibernate\" not supported"
Nov 17 16:34:51 IgnisVeritas systemd-logind[589]: Lid opened.

I highly suspect this is because I do not have enough space on my swap partition. My solution will be to increase my swap partition or making a swap file. Either way. I will mark this as solved.

Offline

#7 2023-11-18 08:05:48

seth
Member
Registered: 2012-09-03
Posts: 51,056

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

After having added the resume hook (which is crucial for hibernation) please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Offline

#8 2023-11-18 20:43:58

mauzy
Member
Registered: 2023-11-11
Posts: 6

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

Here is my most recent boot log:
http://0x0.st/HvGi.txt

As well as the previous boot:
http://0x0.st/HvGo.txt

My swap partition only has 2GB allocated to it. I believe that is why it is unable to sleep on lid close when there is more than 2GB of RAM utilization.

Offline

#9 2023-11-18 21:17:08

seth
Member
Registered: 2012-09-03
Posts: 51,056

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

The powerdevil warning is in neither.
On sleep-then-hibernates, but you woke it from the sleep by opening the lid?

My swap partition only has 2GB allocated to it. I believe that is why it is unable to sleep on lid close when there is more than 2GB of RAM utilization.

But that can easily become an issue regardless, yes.

Offline

#10 2023-11-21 02:36:24

mauzy
Member
Registered: 2023-11-11
Posts: 6

Re: [Solved] Heating in Sleep - System too slow - Lenovo Yoga 7i

You are totally right. My apologies. Those logs are unfortunately lost now.

I was confident that allocating more space to my swap partition would solve the issue. I admittedly had difficulty in making that change so I decided to reinstall Arch. I also decided to use the hardened kernel but everything else is the same.

Despite all of this, the issue persists and this time with the hardened kernel which outputs the following:

Nov 20 14:17:47 IgnisVeritas kernel: ACPI: EC: interrupt blocked
Nov 20 14:17:47 IgnisVeritas kernel: ACPI: button: The lid device is not compliant to SW_LID.
Nov 20 14:17:47 IgnisVeritas kernel: ACPI: EC: interrupt unblocked
...
Nov 20 14:17:47 IgnisVeritas kwin_wayland[758]: kwin_libinput: Libinput: event2  - AT Translated Set 2 keyboard: client bug: event processing lagging behind by 915ms, your system is too slow

Full boot log

After some more research I found that "Powerdevil may not inhibit all logind settings (such as the lid close action for laptops)" in KDE#Power_management

Per Power_management#Power_managers, I changed the following in  in /etc/systemd/logind.conf

HandleLidSwitch=suspend  HandleLidSwitchExternalPower=suspend  HandleLidSwitchDocked=ignore

I also see there is an accuracy dispute of someone that may have a similar issue here where they change

LidSwitchIgnoreInhibited=yes

to

LidSwitchIgnoreInhibited=no

However, they are using XFCE4 and xfce4-power-man whereas I am using KDE and powerdevil.

I will keep these changes for now and monitor the system. If these changes do not solve the problem I will try the fix that worked for the 2016 post.

Offline

Board footer

Powered by FluxBB