You are not logged in.

#1 2023-09-14 20:10:04

level_9
Member
Registered: 2023-09-13
Posts: 7

Internal mic not working neither detected [SOLVED]

Hello folks. I've recently installed Arch following the installation guide. My current installed packages are alsa-utils, pipeware, pipeware-jack, wireplumber and pipeware-pulse. In pavucontrol under input devices, port is always showing 'Microphone (unplugged)'. When I connect my headphone (3.5 mm) the microphone is detected but still it doesn't record any sound. However when I set 'Headphone Mic Jack' to 'Mic In' it records my voice (but sound input is very low). I've tried setting my profile to 'analog stereo duplex' but only either 'Mic In' or 'Headphone Out' works at a time not both at a time. I don't know which command output should be helpful so please tell me and I'll post the outputs. Thanks!!!

Last edited by level_9 (2023-12-23 14:19:05)

Offline

#2 2023-09-14 22:01:41

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,707

Re: Internal mic not working neither detected [SOLVED]

What hardware/mainboard?

Post

arecord -lL
amixer -c0 #Or whatever's the recording card according to arecord -l index
pactl list cards
pactl list sources
#During recording
pactl list source-outputs

in [ code ] tags.

Offline

#3 2023-09-15 06:59:47

level_9
Member
Registered: 2023-09-13
Posts: 7

Re: Internal mic not working neither detected [SOLVED]

Name: Asus vivobook go 15
Model: E1504FA
Processor: AMD Ryzen 3 7320U with Radeon graphics
Memory: 8gb

--------------------------------------------------------------------------

$ arecord -lL

null
    Discard all samples (playback) or generate zero samples (capture)
pipewire
    PipeWire Sound Server
default
    Default ALSA Output (currently PipeWire Media Server)
sysdefault:CARD=Generic_1
    HD-Audio Generic, ALC897 Analog
    Default Audio Device
front:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC897 Analog
    Front output / input
**** List of CAPTURE Hardware Devices ****
card 1: Generic_1 [HD-Audio Generic], device 0: ALC897 Analog [ALC897 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0 

$ amixer -c1

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 83 [95%] [-3.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'Headphone Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control 'Headphone Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [30.00dB]
  Front Right: 3 [100%] [30.00dB]
Simple mixer control 'Headphone Mic Jack Mode',0
  Capabilities: enum
  Items: 'Headphone Out' 'Mic In'
  Item0: 'Headphone Out'
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 254 [100%] [-0.20dB]
  Front Right: Playback 254 [100%] [-0.20dB]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 63 [100%] [30.00dB] [on]
  Front Right: Capture 63 [100%] [30.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'

$ pactl list cards

Name: alsa_card.pci-0000_03_00.1
	Driver: alsa
	Owner Module: n/a
	Properties:
		api.acp.auto-port = "false"
		api.acp.auto-profile = "false"
		api.alsa.card = "0"
		api.alsa.card.longname = "HD-Audio Generic at 0xd05c8000 irq 79"
		api.alsa.card.name = "HD-Audio Generic"
		api.alsa.path = "hw:0"
		api.alsa.use-acp = "true"
		api.dbus.ReserveDevice1 = "Audio0"
		device.api = "alsa"
		device.bus = "pci"
		device.bus_path = "pci-0000:03:00.1"
		device.description = "Rembrandt Radeon High Definition Audio Controller"
		device.enum.api = "udev"
		device.icon_name = "audio-card-analog-pci"
		device.name = "alsa_card.pci-0000_03_00.1"
		device.nick = "HD-Audio Generic"
		device.plugged.usec = "5466986"
		device.product.id = "0x1640"
		device.product.name = "Rembrandt Radeon High Definition Audio Controller"
		device.subsystem = "sound"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:03:00.1/sound/card0"
		device.vendor.id = "0x1002"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
		media.class = "Audio/Device"
		factory.id = "14"
		client.id = "35"
		object.id = "44"
		object.serial = "44"
		object.path = "alsa:pcm:0"
		alsa.card = "0"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xd05c8000 irq 79"
		alsa.driver_name = "snd_hda_intel"
		device.string = "0"
	Profiles:
		off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
		output:hdmi-stereo: Digital Stereo (HDMI) Output (sinks: 1, sources: 0, priority: 5900, available: no)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (sinks: 1, sources: 0, priority: 800, available: no)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (sinks: 1, sources: 0, priority: 800, available: no)
		pro-audio: Pro Audio (sinks: 1, sources: 0, priority: 1, available: yes)
	Active Profile: off
	Ports:
		hdmi-output-0: HDMI / DisplayPort (type: HDMI, priority: 5900, latency offset: 0 usec, availability group: Legacy 1, not available)
			Properties:
				port.type = "hdmi"
				port.availability-group = "Legacy 1"
				device.icon_name = "video-display"
				card.profile.port = "0"
			Part of profile(s): output:hdmi-stereo, output:hdmi-surround, output:hdmi-surround71

Card #45
	Name: alsa_card.pci-0000_03_00.6
	Driver: alsa
	Owner Module: n/a
	Properties:
		api.acp.auto-port = "false"
		api.acp.auto-profile = "false"
		api.alsa.card = "1"
		api.alsa.card.longname = "HD-Audio Generic at 0xd05c0000 irq 80"
		api.alsa.card.name = "HD-Audio Generic"
		api.alsa.path = "hw:1"
		api.alsa.use-acp = "true"
		api.dbus.ReserveDevice1 = "Audio1"
		device.api = "alsa"
		device.bus = "pci"
		device.bus_path = "pci-0000:03:00.6"
		device.description = "Family 17h/19h HD Audio Controller"
		device.enum.api = "udev"
		device.icon_name = "audio-card-analog-pci"
		device.name = "alsa_card.pci-0000_03_00.6"
		device.nick = "HD-Audio Generic"
		device.plugged.usec = "5489578"
		device.product.id = "0x15e3"
		device.product.name = "Family 17h/19h HD Audio Controller"
		device.subsystem = "sound"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1"
		device.vendor.id = "0x1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		media.class = "Audio/Device"
		factory.id = "14"
		client.id = "35"
		object.id = "45"
		object.serial = "45"
		object.path = "alsa:pcm:1"
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xd05c0000 irq 80"
		alsa.driver_name = "snd_hda_intel"
		device.string = "1"
	Profiles:
		off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority: 6565, available: yes)
		output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority: 6500, available: yes)
		input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority: 65, available: no)
		pro-audio: Pro Audio (sinks: 1, sources: 1, priority: 1, available: yes)
	Active Profile: output:analog-stereo+input:analog-stereo
	Ports:
		analog-input-headphone-mic: Microphone (type: Mic, priority: 8700, latency offset: 0 usec, availability group: Legacy 1, not available)
			Properties:
				port.type = "mic"
				port.availability-group = "Legacy 1"
				device.icon_name = "audio-input-microphone"
				card.profile.port = "0"
			Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo
		analog-output-speaker: Speakers (type: Speaker, priority: 10000, latency offset: 0 usec, availability group: Legacy 2, availability unknown)
			Properties:
				port.type = "speaker"
				port.availability-group = "Legacy 2"
				device.icon_name = "audio-speakers"
				card.profile.port = "1"
			Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo
		analog-output-headphones: Headphones (type: Headphones, priority: 9900, latency offset: 0 usec, availability group: Legacy 1, not available)
			Properties:
				port.type = "headphones"
				port.availability-group = "Legacy 1"
				device.icon_name = "audio-headphones"
				card.profile.port = "2"
			Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo

$ pactl list sources

Source #54
	State: SUSPENDED
	Name: alsa_output.pci-0000_03_00.6.analog-stereo.monitor
	Description: Monitor of Family 17h/19h HD Audio Controller Analog Stereo
	Driver: PipeWire
	Sample Specification: s32le 2ch 48000Hz
	Channel Map: front-left,front-right
	Owner Module: 4294967295
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor of Sink: alsa_output.pci-0000_03_00.6.analog-stereo
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE DECIBEL_VOLUME LATENCY 
	Properties:
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.class = "generic"
		alsa.device = "0"
		alsa.driver_name = "snd_hda_intel"
		alsa.id = "ALC897 Analog"
		alsa.long_card_name = "HD-Audio Generic at 0xd05c0000 irq 80"
		alsa.name = "ALC897 Analog"
		alsa.resolution_bits = "16"
		alsa.subclass = "generic-mix"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		api.alsa.card.longname = "HD-Audio Generic at 0xd05c0000 irq 80"
		api.alsa.card.name = "HD-Audio Generic"
		api.alsa.path = "front:1"
		api.alsa.pcm.card = "1"
		api.alsa.pcm.stream = "playback"
		audio.channels = "2"
		audio.position = "FL,FR"
		card.profile.device = "3"
		device.api = "alsa"
		device.class = "monitor"
		device.id = "45"
		device.profile.description = "Analog Stereo"
		device.profile.name = "analog-stereo"
		device.routes = "2"
		factory.name = "api.alsa.pcm.sink"
		media.class = "Audio/Sink"
		device.description = "Family 17h/19h HD Audio Controller"
		node.name = "alsa_output.pci-0000_03_00.6.analog-stereo"
		node.nick = "ALC897 Analog"
		node.pause-on-idle = "false"
		object.path = "alsa:pcm:1:front:1:playback"
		priority.driver = "1009"
		priority.session = "1009"
		factory.id = "18"
		clock.quantum-limit = "8192"
		client.id = "35"
		node.driver = "true"
		factory.mode = "merge"
		audio.adapt.follower = ""
		library.name = "audioconvert/libspa-audioconvert"
		object.id = "54"
		object.serial = "54"
		node.max-latency = "16384/48000"
		api.alsa.period-size = "1024"
		api.alsa.period-num = "32"
		api.alsa.headroom = "0"
		api.acp.auto-port = "false"
		api.acp.auto-profile = "false"
		api.alsa.card = "1"
		api.alsa.use-acp = "true"
		api.dbus.ReserveDevice1 = "Audio1"
		device.bus = "pci"
		device.bus_path = "pci-0000:03:00.6"
		device.enum.api = "udev"
		device.icon_name = "audio-card-analog-pci"
		device.name = "alsa_card.pci-0000_03_00.6"
		device.nick = "HD-Audio Generic"
		device.plugged.usec = "5489578"
		device.product.id = "0x15e3"
		device.product.name = "Family 17h/19h HD Audio Controller"
		device.subsystem = "sound"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1"
		device.vendor.id = "0x1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.string = "1"
	Ports:
		analog-output-speaker: Speakers (type: Speaker, priority: 10000, availability group: Legacy 2, availability unknown)
		analog-output-headphones: Headphones (type: Headphones, priority: 9900, availability group: Legacy 1, not available)
	Active Port: analog-output-speaker
	Formats:
		pcm

Source #55
	State: SUSPENDED
	Name: alsa_input.pci-0000_03_00.6.analog-stereo
	Description: Family 17h/19h HD Audio Controller Analog Stereo
	Driver: PipeWire
	Sample Specification: s32le 2ch 48000Hz
	Channel Map: front-left,front-right
	Owner Module: 4294967295
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor of Sink: n/a
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE DECIBEL_VOLUME LATENCY 
	Properties:
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.class = "generic"
		alsa.device = "0"
		alsa.driver_name = "snd_hda_intel"
		alsa.id = "ALC897 Analog"
		alsa.long_card_name = "HD-Audio Generic at 0xd05c0000 irq 80"
		alsa.name = "ALC897 Analog"
		alsa.resolution_bits = "16"
		alsa.subclass = "generic-mix"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		api.alsa.card.longname = "HD-Audio Generic at 0xd05c0000 irq 80"
		api.alsa.card.name = "HD-Audio Generic"
		api.alsa.path = "front:1"
		api.alsa.pcm.card = "1"
		api.alsa.pcm.stream = "capture"
		audio.channels = "2"
		audio.position = "FL,FR"
		card.profile.device = "0"
		device.api = "alsa"
		device.class = "sound"
		device.id = "45"
		device.profile.description = "Analog Stereo"
		device.profile.name = "analog-stereo"
		device.routes = "1"
		factory.name = "api.alsa.pcm.source"
		media.class = "Audio/Source"
		device.description = "Family 17h/19h HD Audio Controller"
		node.name = "alsa_input.pci-0000_03_00.6.analog-stereo"
		node.nick = "ALC897 Analog"
		node.pause-on-idle = "false"
		object.path = "alsa:pcm:1:front:1:capture"
		priority.driver = "2009"
		priority.session = "2009"
		factory.id = "18"
		clock.quantum-limit = "8192"
		client.id = "35"
		node.driver = "true"
		factory.mode = "split"
		audio.adapt.follower = ""
		library.name = "audioconvert/libspa-audioconvert"
		object.id = "55"
		object.serial = "55"
		node.max-latency = "16384/48000"
		api.alsa.period-size = "1024"
		api.alsa.period-num = "32"
		api.alsa.headroom = "32"
		api.acp.auto-port = "false"
		api.acp.auto-profile = "false"
		api.alsa.card = "1"
		api.alsa.use-acp = "true"
		api.dbus.ReserveDevice1 = "Audio1"
		device.bus = "pci"
		device.bus_path = "pci-0000:03:00.6"
		device.enum.api = "udev"
		device.icon_name = "audio-card-analog-pci"
		device.name = "alsa_card.pci-0000_03_00.6"
		device.nick = "HD-Audio Generic"
		device.plugged.usec = "5489578"
		device.product.id = "0x15e3"
		device.product.name = "Family 17h/19h HD Audio Controller"
		device.subsystem = "sound"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1"
		device.vendor.id = "0x1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.string = "1"
	Ports:
		analog-input-headphone-mic: Microphone (type: Mic, priority: 8700, availability group: Legacy 1, not available)
	Active Port: analog-input-headphone-mic
	Formats:
		pcm

$ pactl list source-outputs

It prints nothing, just blank output!!!

Last edited by level_9 (2023-11-17 15:31:53)

Offline

#4 2023-09-23 17:40:41

level_9
Member
Registered: 2023-09-13
Posts: 7

Re: Internal mic not working neither detected [SOLVED]

Hello!!!

Offline

#5 2023-11-17 15:31:02

level_9
Member
Registered: 2023-09-13
Posts: 7

Re: Internal mic not working neither detected [SOLVED]

Updated to kernel 6.6 but the issue is still here...

Offline

#6 2023-11-17 16:05:22

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,707

Re: Internal mic not working neither detected [SOLVED]

Doesn't look good https://www.reddit.com/r/ASUS/comments/ … 15_laptop/ ... plain detection wise things are there, if this is just up to the verb table, I suggest you try a firmware/UEFI update, they sometimes contain fixes here.

Offline

#7 2023-11-17 18:37:34

level_9
Member
Registered: 2023-09-13
Posts: 7

Re: Internal mic not working neither detected [SOLVED]

Did UEFI update but nothing fixed. Thanks for your help neutral.

Last edited by level_9 (2023-11-17 18:39:05)

Offline

#8 2023-12-21 16:20:24

level_9
Member
Registered: 2023-09-13
Posts: 7

Re: Internal mic not working neither detected [SOLVED]

Yooo finally got mic support for my laptop. I was doing some digging around and found that I'd need to recompile my kernel after adding my device to acp6x_mach quirk table. So I did a last software upgrade before doing so and boom the upgrade did the job. Anyone who has the same model can upgrade to get their mic working. This post now can be marked solved.

Offline

#9 2023-12-21 16:25:01

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,707

Re: Internal mic not working neither detected [SOLVED]

Glad to hear, please do so by prepending [SOLVED] to the title in your first post.

Offline

Board footer

Powered by FluxBB