You are not logged in.

#1 2023-12-23 09:58:35

genericity
Member
Registered: 2014-09-20
Posts: 29

Temporary fixes if you are using Plasma 6.0 Beta 2 from kde-unstable

[UPDATE: Fixes for 1 and 2 are now in kde-unstable and no longer needed.]

1. Blank screen when lockscreen and logout:

git clone https://gitlab.archlinux.org/archlinux/packaging/packages/plasma-integration.git
cd plasma-integration
git checkout kde-unstable

Replace PKGBUILD with https://gist.github.com/jinliu/950cdc8c … bbed55eaa5, then

makepkg -si

2. Recent file not recorded:

git clone https://gitlab.archlinux.org/archlinux/packaging/packages/kactivitymanagerd.git
cd kactivitymanagerd
git checkout kde-unstable

Replace PKGBUILD with https://gist.github.com/jinliu/4f643294 … 6f56dd8d1a, then

makepkg -si
systemctl --user restart plasma-kactivitymanagerd.service

3. Dolphin empty dirs have expander arrows:

git clone https://gitlab.archlinux.org/archlinux/packaging/packages/dolphin.git
cd dolphin
git checkout kde-unstable

Replace PKGBUILD with https://gist.github.com/jinliu/6f477493 … 76ab025cf2, then

makepkg -si

Last edited by genericity (2023-12-23 14:35:27)

Offline

#2 2023-12-23 10:53:37

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,098

Re: Temporary fixes if you are using Plasma 6.0 Beta 2 from kde-unstable

Thanks. It would be much more useful if you submitted merge requests, though (backporting the relevant commits instead of packaging git head)

Offline

#3 2023-12-23 11:10:34

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,846
Website

Re: Temporary fixes if you are using Plasma 6.0 Beta 2 from kde-unstable

Mod note: Moving to [testing].


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2023-12-23 11:11:06

genericity
Member
Registered: 2014-09-20
Posts: 29

Re: Temporary fixes if you are using Plasma 6.0 Beta 2 from kde-unstable

arojas wrote:

Thanks. It would be much more useful if you submitted merge requests, though (backporting the relevant commits instead of packaging git head)

Sorry, but I don't know where to submit MRs. To some private repos for kde-unstable? Or export these commits as patches?

Anyway, do we really want to do backports for a beta release in an unstable repo?

Offline

#5 2023-12-23 11:13:42

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,098

Re: Temporary fixes if you are using Plasma 6.0 Beta 2 from kde-unstable

genericity wrote:

Sorry, but I don't know where to submit MRs. To some private repos for kde-unstable? Or export these commits as patches?

To the respective Arch packaging repos (targeting the kde-unstable branch)

Anyway, do we really want to do backports for a beta release in an unstable repo?

For critical issues such as 1, we definitely do (already done). Otherwise people will keep reporting it. Maybe not for 3.

Last edited by arojas (2023-12-23 11:14:35)

Offline

#6 2023-12-23 11:44:50

genericity
Member
Registered: 2014-09-20
Posts: 29

Re: Temporary fixes if you are using Plasma 6.0 Beta 2 from kde-unstable

arojas wrote:

Anyway, do we really want to do backports for a beta release in an unstable repo?

For critical issues such as 1, we definitely do (already done). Otherwise people will keep reporting it. Maybe not for 3.

Makes sense. Then I'll just keep 2 and 3 to myself (and people like-minded). It seems much simpler to modify official PKGBUILDs than to use *-git packages and rebuild everything.

Offline

#7 2023-12-23 14:16:39

sergekorol
Member
Registered: 2021-04-13
Posts: 18

Re: Temporary fixes if you are using Plasma 6.0 Beta 2 from kde-unstable

Are all these still needed since this mornings(for me) package updates?
9  kde-unstable/kactivitymanagerd    5.91.0-1   -> 5.91.0-2
8  kde-unstable/plasma-integration   5.91.0-1   -> 5.91.0-2
7  kde-unstable/plasma5-integration  5.91.0-1   -> 5.91.0-2

Offline

#8 2023-12-23 14:33:28

genericity
Member
Registered: 2014-09-20
Posts: 29

Re: Temporary fixes if you are using Plasma 6.0 Beta 2 from kde-unstable

sergekorol wrote:

Are all these still needed since this mornings(for me) package updates?
9  kde-unstable/kactivitymanagerd    5.91.0-1   -> 5.91.0-2
8  kde-unstable/plasma-integration   5.91.0-1   -> 5.91.0-2
7  kde-unstable/plasma5-integration  5.91.0-1   -> 5.91.0-2

No. 1 and 2 are no longer needed.

Offline

Board footer

Powered by FluxBB