You are not logged in.

#1 2024-01-19 02:54:45

NoRecognition84
Member
Registered: 2024-01-19
Posts: 1

Problems with mic when using Discord

When I want to VC with my friends, I have to boot to Windows to use Discord there because no one can hear me when using Discord for Linux.  I've tried both installing it via AUR and Flatpak with the same results.  Not too sure what info to provide, but here's inxi output to start.

$ inxi -F
System:
  Host: somethingsomething Kernel: 6.7.0-zen3-1-zen arch: x86_64 bits: 64
    Desktop: GNOME v: 45.3 Distro: Arch Linux
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX B550-I GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 3402
    date: 09/21/2023
CPU:
  Info: 8-core model: AMD Ryzen 7 5700X bits: 64 type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 2238 min/max: 2200/4662 cores: 1: 2200 2: 2200 3: 2200
    4: 2200 5: 2823 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
    13: 2200 14: 2200 15: 2200 16: 2200
Graphics:
  Device-1: AMD Navi 24 [Radeon RX 6400/6500 XT/6500M] driver: amdgpu
    v: kernel
  Device-2: Microsoft LifeCam Cinema driver: snd-usb-audio,uvcvideo
    type: USB
  Display: x11 server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4 driver:
    X: loaded: modesetting dri: radeonsi gpu: amdgpu
    resolution: <missing: xdpyinfo/xrandr> resolution: 2560x1440
  API: EGL v: 1.5 drivers: radeonsi,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.3-arch1.1
    renderer: AMD Radeon RX 6500 XT (radeonsi navi24 LLVM 16.0.6 DRM 3.56
    6.7.0-zen3-1-zen)
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Microsoft LifeCam Cinema driver: snd-usb-audio,uvcvideo
    type: USB
  Device-4: AudioQuest DragonFly Black v1.5
    driver: hid-generic,snd-usb-audio,usbhid type: USB
  API: ALSA v: k6.7.0-zen3-1-zen status: kernel-api
  Server-1: PulseAudio v: 17.0 status: active
Network:
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi
  IF: wlan0 state: up mac: f4:ce:23:05:4d:e4
  Device-2: Intel Ethernet I225-V driver: igc
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: 3c:7c:3f:28:98:01
  IF-ID-1: virbr0 state: down mac: 52:54:00:77:0d:aa
Bluetooth:
  Device-1: Intel AX210 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 state: up address: F4:CE:23:05:4D:E8 bt-v: 5.3
Drives:
  Local Storage: total: 12.98 TiB used: 8.29 TiB (63.8%)
  ID-1: /dev/nvme0n1 model: Predator SSD GM7000 2TB size: 1.86 TiB
  ID-2: /dev/nvme1n1 vendor: TeamGroup model: TM8FP4002T size: 1.86 TiB
  ID-3: /dev/sda vendor: Silicon Power model: SPCC Solid State Disk
    size: 1.86 TiB type: USB
  ID-4: /dev/sdb model: General USB Flash Disk size: 116.06 GiB type: USB
  ID-5: /dev/sdc vendor: Western Digital model: WD80EZAZ-11TDBA0
    size: 7.28 TiB type: USB
Partition:
  ID-1: / size: 1.86 TiB used: 584.21 GiB (30.6%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-2: /boot size: 511 MiB used: 150.1 MiB (29.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 1.86 TiB used: 584.21 GiB (30.6%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-4: /var/log size: 1.86 TiB used: 584.21 GiB (30.6%) fs: btrfs
    dev: /dev/nvme0n1p2
Swap:
  ID-1: swap-1 type: zram size: 4 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.5 C mobo: 36.0 C gpu: amdgpu temp: 49.0 C
  Fan Speeds (rpm): fan-1: 699 fan-2: 674 fan-5: 685 gpu: amdgpu fan: 0
Info:
  Processes: 429 Uptime: 9m Memory: total: 32 GiB available: 31.25 GiB
  used: 4.28 GiB (13.7%) Shell: Bash inxi: 3.3.31

Offline

#2 2024-01-19 09:37:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,093

Re: Problems with mic when using Discord

When having a discord call open (... can also just be the mic/voice test in settings) What's your output of

sudo fuser -v
arecord -lL
pactl list cards
pactl list sources
pactl list source-outputs

Please also wrap command outputs in bbcode code tags and adjust your first post accordingly.

Offline

#3 2024-01-19 11:49:20

Arsimael
Member
Registered: 2021-05-09
Posts: 16
Website

Re: Problems with mic when using Discord

I have "pavucontrol" installed to have a look at the audio devices and applications which use audio.

Which audioserver do youo use? Pulseaudio or pipewire?

Offline

#4 2024-01-21 00:52:33

nbqr
Member
Registered: 2013-06-27
Posts: 14

Re: Problems with mic when using Discord

Try opening pavucontrol after joining the voice call.

I also have a problem where no one can hear me on a Discord call, but the issue disappears immediately once i open pavucontrol. I just posted a thread about this.

Offline

Board footer

Powered by FluxBB