You are not logged in.

#1 2024-01-16 14:10:45

Arsimael
Member
Registered: 2021-05-09
Posts: 16
Website

[Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

Hi.
I don't know if anyoine else has this issue, but since it appears on all three machines I own, maybe someone else also experiences this:

System(s):
AMD CPUs, all on Zen 3/4
AMD GPSs, all Radeon 7X00 GPUs, laptop runs on an APU.
All Systems are currently on Kernel 6.7
All Systems use the current mesa driver
All Systems use Plasma and also have gnome installed.

Issue:
Installing/Starting Guild Wars 2 on Lutris or via Steam.
When the launcher starts and updates/checks itself, everything works fine. The launcher finishes it's own check and then restarts to load the login screen and then, the whole screen just freezes.

If I login via ssh and start htop, I see that the GW2 Launcher (running via xwayland) runs one core to 100%. If I kill the GW2 process, the system becomes responsive again.

Things I tried:
- Different Kernel (6.1 LTS, 6.6 LTS, 6.7)
- Different mesa version: (22,23,24-git)


On my "big" pc at home, if I switch to Gnome (wayland) I can start and play Guild Wars 2 without any problem, on plasma, it freezes.
On my "small" pc at my second home, it's the same issue.
On my Laptop, It doesn't matter if its Gnome, or Plasma, it freezes everywhere,
Any Idea on how to debug this?

PCs: Standard "Build by myself" PCs.
Laptop: HP Probook 455

##edit:
If I start the game in X11 mode, the launcher pops up, but then also freezes the ui. The difference is I can still switch via CTRL+ALT+F3 , login on an console and kill the executable.

Last edited by Arsimael (2024-01-31 18:41:16)

Offline

#2 2024-01-16 15:39:26

just4arch
Member
Registered: 2023-01-07
Posts: 91

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

Do you have window decorations enabled in winecfg?
If yes try disabling them.

Offline

#3 2024-01-16 18:54:51

Arsimael
Member
Registered: 2021-05-09
Posts: 16
Website

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

I tried. Same issue. Sadly.
Also tried if theres a difference between the steam and the Standalone Version. - Same issue on both versions.

Interestingly: The Elder Scrolls Online Launcher, which has a similar appearance, works just fine.

Last edited by Arsimael (2024-01-16 18:58:51)

Offline

#4 2024-01-16 19:29:31

just4arch
Member
Registered: 2023-01-07
Posts: 91

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

Sorry, I just double checked and it's the option below the decorations that triggers this for me:
"Allow the window manager to control the windows"
I disabled both and it worked, but retesting it's this one causing trouble.

Offline

#5 2024-01-16 21:27:06

Arsimael
Member
Registered: 2021-05-09
Posts: 16
Website

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

That fixed the freezes. Thank you.

##Edit:
Ok, the freezes are gone, and I can start the game, but now I don't get focus.
I can control my character via mouse, but I cant enter anything via keyboard. If I have any other tool open in the background, like notepadqq or kwriter, I can see thewt whatever I type gets typed into the tool in the background.

Do you had the problem too?

Last edited by Arsimael (2024-01-16 22:26:00)

Offline

#6 2024-01-17 04:57:54

just4arch
Member
Registered: 2023-01-07
Posts: 91

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

Arsimael wrote:

Ok, the freezes are gone, and I can start the game, but now I don't get focus.
I can control my character via mouse, but I cant enter anything via keyboard. If I have any other tool open in the background, like notepadqq or kwriter, I can see thewt whatever I type gets typed into the tool in the background.

Do you had the problem too?

Interesting, I thought both had the same cause, as ticking off both boxes in winecfg alleviated those issues for me - pretty much any game seemed affected.
I'm using the testing repo and wine-staging, so there might have been some updates which haven't reached stable yet, if you want to give that a try.

I'll have to try with a fresh prefix to double check there isn't anything else needed.

Offline

#7 2024-01-17 20:26:37

Swarfega
Member
Registered: 2011-08-19
Posts: 104

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

I've just installed Arch today, coming from openSUSE, and experiencing the same thing. I figured the whole OS was dead as nothing seems to respond but the last time I tried I had Spotify playing and the music continued playing fine.
Other games are OK. GW2 is my main game though.

Was this working until recently? Did I just pick a really bad day to move to Arch? sad

Last edited by Swarfega (2024-01-17 20:27:10)

Offline

#8 2024-01-17 21:45:38

just4arch
Member
Registered: 2023-01-07
Posts: 91

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

Bad timing I'd say, as it was running rather nicely... once.

For the time being, it's a moving target for me, too many updates/variables (kernel, mesa, X, wine, GW2).
I got it working a few days ago, but when I just tried with a fresh wine prefix it's completely borked again (blank window after launcher, but workaround below).

Alt+F2 into another TTY and "wineserver -k" or kill the .exe to get out of the frozen desktop.

What currently works here:

winetricks tahoma dxvk
winecfg => Graphics => Window settings => enable all 3 checkboxes and set Desktop size to the desired size or screen resolution

Offline

#9 2024-01-18 16:29:33

Arsimael
Member
Registered: 2021-05-09
Posts: 16
Website

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

Sadly, no fix for me.
Seems like I need to switch to gnome if I want to play GW2 for now.

Offline

#10 2024-01-30 22:17:28

impostor
Member
Registered: 2024-01-30
Posts: 1

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

Quick disclaimer I'm on Manjaro so I will be promptly scolded and banned by arch purists but...

I found the solution to the problem: https://forum.manjaro.org/t/system-free … s-2/155048

Apparently, version 0.43 of `pixman` causes the behavior you described. I experienced the exact same, and downgrading pixman worked!

```
sudo pacman -Syyu manjaro-downgrade
sudo manjaro-downgrade pixman
```
went with the latest 0.42.* version and guild wars 2 stars well now.

I had previously applied additional advice from other forums: using protontricks -> winecfg -> gw2 -> graphics -> use virtual desktop -- but that was bad, it caused my keyboard inputs to no longer register into the game.

Try the downgrade! Hope it works for you, too!

Last edited by impostor (2024-01-30 22:17:58)

Offline

#11 2024-01-30 23:26:09

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,093

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

According to the very thread you linked it should  be fixed on the current pixman package 0.43.2

But thanks for the heads-up, but this also shows why we can't help with threads that come with the OP from Manjaro. If you still needed to do that workaround then your Manjaro baseline is outdated in comparison to Arch

@Arsimael does this still happen with the current pixman package?

Last edited by V1del (2024-01-30 23:30:19)

Offline

#12 2024-01-31 08:11:50

Arsimael
Member
Registered: 2021-05-09
Posts: 16
Website

Re: [Solved] [Guild Wars 2] DE freezes when starting game (Wayland)

Tried on my Laptop (extra/pixman 0.43.2-1):
No freezes, game starts, Problem solved.
Will try on my Gaming Station as soon as I am back from work.

##Edit:

Works on my main System aswell. Problem seems to be fixed.

Last edited by Arsimael (2024-01-31 18:40:56)

Offline

Board footer

Powered by FluxBB