You are not logged in.

#1 2024-02-04 11:21:26

SeagullFish
Member
Registered: 2023-08-10
Posts: 23

Trigger rally: error loading shared libraries

Hello.

I am trying to run the computer game Trigger Rally, but it refuses to start. If I click the associated button on the applications menu, nothing seems to happen. From the menu editor, I see that the button runs «/usr/games/trigger-rally». Trying to run that command in a terminal gives me the following output:

[foo@bar ~]$ /usr/games/trigger-rally
/usr/games/trigger-rally: error while loading shared libraries: libtinyxml2.so.9: cannot open shared object file: No such file or directory

Searching the web gave me no exact answer to what causes this error, although I found this page which discusses a possible similar issue. I quote:

julianoes wrote:

Ok I get it. Gazebo tries to access the wrong lib version.

ls -l /usr/lib | grep tinyxml2
lrwxrwxrwx 1 root root        16 Nov 18 17:46 libtinyxml2.so -> libtinyxml2.so.7
lrwxrwxrwx 1 root root        20 Nov 18 17:46 libtinyxml2.so.7 -> libtinyxml2.so.7.0.1
-rwxr-xr-x 1 root root    100312 Nov 18 17:46 libtinyxml2.so.7.0.1

On my computer, I get this output:

[foo@bar ~]$ ls -l /usr/lib | grep tinyxml2
lrwxrwxrwx   1 root root        17 jan.   2 07:17 libtinyxml2.so -> libtinyxml2.so.10
lrwxrwxrwx   1 root root        21 jan.   2 07:17 libtinyxml2.so.10 -> libtinyxml2.so.10.0.0
-rwxr-xr-x   1 root root     92320 jan.   2 07:17 libtinyxml2.so.10.0.0

I seem to have a newer version of tinyxml2. Apart from that, I seem to get the same output as «Julianoes». However, I don’t understand what he is pointing out that is wrong in his case. Hence, I also don’t know how to correct the error in neither his nor my case.

Any ideas, anyone?

Offline

#2 2024-02-04 13:57:43

seth
Member
Registered: 2012-09-03
Posts: 48,710

Re: Trigger rally: error loading shared libraries

https://aur.archlinux.org/packages/trigger-rally-svn ?
You'll have to rebuild that.

The /usr/games/trigger-rally is linked against an older version of libtinyxml2.so
Do NOT add a symlink! If this is somehow a binary-only version of the game you can get the older library from the https://wiki.archlinux.org/title/Ala and LD_PRELOAD it or put it into a special location and add thet to the LD_LIBRARY_PATH

Offline

#3 2024-02-04 14:40:39

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,683
Website

Re: Trigger rally: error loading shared libraries

Mod note: moving to AUR Issues


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB