You are not logged in.

#1 2022-02-08 15:02:04

samyhaff
Member
Registered: 2022-02-08
Posts: 1

Microphone not working

Hello,

I've been having major issues with my mic on my thinkpad T14s Gen 1 running arch.
It used to work perfectly when I got my laptop but after some updates it stopped working.

Firstly it was no longer listed in pulseaudio sources. Now it's back, however when trying it, I can't hear anything except for a static noise (which diaspears when muting the mic).

Here are some commands and their output:

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: Generic_1 [HD-Audio Generic], device 0: ALC257 Analog [ALC257 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ pactl list sources
Source #0
        State: SUSPENDED
        Name: alsa_input.hw_1_0
        Description: Family 17h (Models 10h-1fh) HD Audio Controller
        Driver: module-alsa-source.c
        Sample Specification: s16le 2ch 44100Hz
        Channel Map: front-left,front-right
        Owner Module: 5
        Mute: no
        Volume: front-left: 99957 / 153% / 11.00 dB,   front-right: 99957 / 153% / 11.00 dB
                balance 0.00
        Base Volume: 65536 / 100% / 0.00 dB
        Monitor of Sink: n/a
        Latency: 0 usec, configured 0 usec
        Flags: HARDWARE DECIBEL_VOLUME LATENCY
        Properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC257 Analog"
                alsa.id = "ALC257 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "1"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xfd3c0000 irq 105"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:06:00.6"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:06:00.6/sound/card1"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "15e3"
                device.product.name = "Family 17h (Models 10h-1fh) HD Audio Controller"
                device.string = "hw:1,0"
                device.buffering.buffer_size = "352768"
                device.buffering.fragment_size = "176384"
                device.access_mode = "mmap+timer"
                device.description = "Family 17h (Models 10h-1fh) HD Audio Controller"
                device.icon_name = "audio-input-microphone-pci"
        Formats:
                pcm

Source #2
        State: SUSPENDED
        Name: alsa_output.pci-0000_06_00.6.analog-stereo.monitor
        Description: Monitor of Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo
        Driver: module-alsa-card.c
        Sample Specification: s16le 2ch 48000Hz
        Channel Map: front-left,front-right
        Owner Module: 25
        Mute: no
        Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        Base Volume: 65536 / 100% / 0.00 dB
        Monitor of Sink: alsa_output.pci-0000_06_00.6.analog-stereo
        Latency: 0 usec, configured 0 usec
        Flags: DECIBEL_VOLUME LATENCY
        Properties:
                device.description = "Monitor of Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo"
                device.class = "monitor"
                alsa.card = "1"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xfd3c0000 irq 105"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:06:00.6"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:06:00.6/sound/card1"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "15e3"
                device.product.name = "Family 17h (Models 10h-1fh) HD Audio Controller"
                device.string = "1"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        Formats:
                pcm

Thanks in advance for your help.

Last edited by samyhaff (2022-02-08 15:14:46)

Offline

#2 2024-02-04 02:00:05

WoL
Member
Registered: 2023-07-27
Posts: 2

Re: Microphone not working

My laptop is Swift SF314-54 V1.18 and i also have this problem

```
$ pactl list sources
Source #48
        State: SUSPENDED
Source #49
    State: SUSPENDED
```

idk how to resume this

Offline

#3 2024-02-04 02:03:20

WoL
Member
Registered: 2023-07-27
Posts: 2

Re: Microphone not working

also: i tried this but not working

sudo cat /etc/modprobe.d/swift3.conf     

options snd-intel-dspcfg.dsp_driver=1
#options snd-hda-intel power_save=1
#options snd-hda-intel model=laptop-dmic

Offline

#4 2024-02-04 18:40:17

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,154

Re: Microphone not working

The correct syntax would be

 options snd-intel-dspcfg dsp_driver=1

but that will guaranteed disable the mic if you're on a system where using this option would be necessary.

Generally instead of necroing this two year old thread with different hardware, open your own and post

sudo fuser 
sudo dmesg | grep -E 'snd|sof'
arecord -lL
pactl list cards
pactl list sources

in code tags

Closing this old thread

Offline

Board footer

Powered by FluxBB