You are not logged in.

#1 2024-02-06 17:54:49

Registered: 2012-04-21
Posts: 38

[SOLVED] Pipewire inputs stuttering with some applications

Hello all,

I don't understand how audio works too well, please bear with me big_smile

I get microphone stutter/crackle in some applications (Steam voice chat, games running through WINE Phasmophobia, Lethal Company) but microphone is clear in other applications (Cheese, OBS, Discord)

I have tried:
- Multiple microphones, all have same result
- Issue does not occur on PopOS (also Pipewire), I notice that there is a difference in input quant rate between Arch (quant 2048) PopOS (quant 256) but setting quant rate via "pw-metadata -n settings 0 clock.force-quantum 512" does not change input stream quant rates.

- Pipewire + Wireplumber are at default settings (both PopOS and Arch)
- no difference that I can see in quant rate or freq from `pw-top` between (eg) Discord (good) and Steam voice (bad)
- uname -a Linux amaryllis 6.7.0-arch3-1 #1 SMP PREEMPT_DYNAMIC Sat, 13 Jan 2024 14:37:14 +0000 x86_64 GNU/Linux`
- inxi -Ax:

  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: speed: 2.5 GT/s lanes: 4
    bus-ID: 04:00.1 chip-ID: 10de:10f0
  Device-3: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-4.3:7
    chip-ID: 046d:085c
  Device-4: Audio-Technica ATR2500x-USB Microphone
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 bus-ID: 5-2.1:3 chip-ID: 0909:004e
  API: ALSA v: k6.7.0-arch3-1 status: kernel-api
  Server-1: sndiod v: N/A status: off
  Server-2: JACK v: 1.9.22 status: off
  Server-3: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin

Thanks for reading

Last edited by htedrom (2024-02-10 00:03:04)


#2 2024-02-10 00:02:53

Registered: 2012-04-21
Posts: 38

Re: [SOLVED] Pipewire inputs stuttering with some applications

Marking as solved: after reading a lot about how Steam handles audio through Chromium apparently it requests lower latency levels than it needs, causing mic and audio issues. Following I launched Steam with PULSE_LATENCY_MSEC=30 and this resolved the issue in Steam and games launched from Steam.


Board footer

Powered by FluxBB