You are not logged in.

#1 2024-02-04 18:22:21

Kallix_
Member
Registered: 2022-01-09
Posts: 13

Severe FPS drop after archlinux reinstall.

Hello.
The last installation seems okay and there's no problem with that, but I messed up fdisk and forced to reinstall everything. after that everything seems normal until I tried to play minecraft (any version, any kind, any java environment and any settings), no matter what, sometimes I experience severe fps drops, like for 2/3 seconds complete game freeze. and when I switch to full screen, it makes it worse, the game won't render after being frozen, it just keeps there, until re-entering the full screen again to get it updated.

What I tried:
- I tried fixing screen-tearing if that is really related to that severe fps drops, which wasn't.
- I reinstalled NVIDIA drivers, (with DRM, I don't know, but I think it came with the package)
- Disabled nouveau
- I checked GPU temps, everything was normal, below 50 degrees, I even tried limiting FPS on the game itself and disabling any details but it hasn't changed.

Here is my specs:
CPU: Intel i5-10400F (12) @ 4.300GHz
GPU: NVIDIA GeForce GTX 1650
Memory: 15842MiB (DDR4)

Here is the dmesg

The actual problem is with the game, I mean, the game hangs. not the desktop environment. but this started happening just after the re-installation, which leads me to suspect that I somehow somewhere missed something important in installation step with GPU drivers and desktop environment or maybe its a bug. not sure why this happens. but Thank you all, I hope there should be a solution to this.

Last edited by Kallix_ (2024-02-04 18:24:33)

Offline

#2 2024-02-04 21:30:03

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Severe FPS drop after archlinux reinstall.

[    0.311960] [drm] Initialized simpledrm 1.0.0 20200625 for simple-framebuffer.0 on minor 0
[    0.312167] simple-framebuffer simple-framebuffer.0: [drm] fb0: simpledrmdrmfb frame buffer device

Please post your Xorg log, https://wiki.archlinux.org/title/Xorg#General and also "glxinfo -B"
Then enable https://wiki.archlinux.org/title/NVIDIA … de_setting (use the nvidia_drm.modeset=1 kernel parameter, modprobe.conf won't do - and ignore fbdev=1 for now)

Finally, test something else than minecraft, eg. https://archlinux.org/packages/extra/x8 … uerbraten/ or https://archlinux.org/packages/extra/x86_64/warsow/

Offline

#3 2024-02-05 12:58:36

Kallix_
Member
Registered: 2022-01-09
Posts: 13

Re: Severe FPS drop after archlinux reinstall.

seth wrote:
[    0.311960] [drm] Initialized simpledrm 1.0.0 20200625 for simple-framebuffer.0 on minor 0
[    0.312167] simple-framebuffer simple-framebuffer.0: [drm] fb0: simpledrmdrmfb frame buffer device

Please post your Xorg log, https://wiki.archlinux.org/title/Xorg#General and also "glxinfo -B"
Then enable https://wiki.archlinux.org/title/NVIDIA … de_setting (use the nvidia_drm.modeset=1 kernel parameter, modprobe.conf won't do - and ignore fbdev=1 for now)

Finally, test something else than minecraft, eg. https://archlinux.org/packages/extra/x8 … uerbraten/ or https://archlinux.org/packages/extra/x86_64/warsow/

Yea I'll try that and report the results, but I forgot to mention that I can hear the game doing its thing while being frozen which is weird (I mean the sound was responsible) but not the screen, Just for more details.
Here is glxinfo -B output:

name of display: :0
display: :0  screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 4096 MB
    Total available memory: 4096 MB
    Currently available dedicated video memory: 3501 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce GTX 1650/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 545.29.06
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 545.29.06
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 545.29.06
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

Last edited by Kallix_ (2024-02-05 13:00:56)

Offline

#4 2024-02-05 15:10:34

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Severe FPS drop after archlinux reinstall.

Also wrt your last comment: do you use a compositor or compositing WM?

Offline

#5 2024-02-06 12:18:24

Kallix_
Member
Registered: 2022-01-09
Posts: 13

Re: Severe FPS drop after archlinux reinstall.

Here is Xorg log, and yes, Im using picom.

EDIT:
Oh good point, it seems its fixed, I just killed picom, now everything working smoothly and there is no longer game freezes, but why that happens? a bit weird, cuz I am using the exact config recovered from the last installation, take a look, thank you!

Last edited by Kallix_ (2024-02-06 12:21:50)

Offline

#6 2024-02-06 14:55:05

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Severe FPS drop after archlinux reinstall.

The isolated "fbdev=1" is bogus and "nvidia_drm.fbdev=1" isn't a very good idea  (for now, maybe 550xx fixes it)
Remove every single xf86-video-* package, you want nothing of that.

[     4.628] (WW) NVIDIA(0): Avolites Ltd HDTV (DFP-1) does not have an EDID, or its EDID
[     4.628] (WW) NVIDIA(0):     does not contain a maximum image size; cannot compute DPI
[     4.628] (WW) NVIDIA(0):     from Avolites Ltd HDTV (DFP-1)'s EDID.

Please post the output of

xrandr --verbose

But other than that the xorg log looks unsuspicous.

For picom, you're using the render backend, np vsync and the refresh rate is set to autodetect.
Given your edid issues, what if you just hardcode that to eg. 60?

Offline

#7 2024-02-08 09:01:05

Kallix_
Member
Registered: 2022-01-09
Posts: 13

Re: Severe FPS drop after archlinux reinstall.

seth wrote:

The isolated "fbdev=1" is bogus and "nvidia_drm.fbdev=1" isn't a very good idea  (for now, maybe 550xx fixes it)
Remove every single xf86-video-* package, you want nothing of that.

[     4.628] (WW) NVIDIA(0): Avolites Ltd HDTV (DFP-1) does not have an EDID, or its EDID
[     4.628] (WW) NVIDIA(0):     does not contain a maximum image size; cannot compute DPI
[     4.628] (WW) NVIDIA(0):     from Avolites Ltd HDTV (DFP-1)'s EDID.

Please post the output of

xrandr --verbose

But other than that the xorg log looks unsuspicous.

For picom, you're using the render backend, np vsync and the refresh rate is set to autodetect.
Given your edid issues, what if you just hardcode that to eg. 60?

Here is the output:
Click here
And I don't understand what you mean about "hardcode that to eg, 60?" you mean the compositor(picom) FPS? or if I have to, where should I put that?
What compositor you suggest me to use (Im using i3 as desktop environment)

Last edited by Kallix_ (2024-02-08 09:02:11)

Offline

#8 2024-02-08 10:01:50

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Severe FPS drop after archlinux reinstall.

you mean the compositor(picom) FPS?

Yup.  In you picom.conf

refresh-rate = 60

(the key already exists and is set to "0")

Your TV has a native FullHD display (and runs on that) but also includes 4k modes (at 30Hz) and the preferred mode is 1366x768 - and of course there're interlaced timings advertised, too…
You're alternatives are picom and xcompmgr, picom being much fancier and I don't think the compositor is the problem here.

Offline

Board footer

Powered by FluxBB