You are not logged in.

#1 2024-02-09 01:11:27

Registered: 2024-02-08
Posts: 4

[SOLVED] KDE Wayland Nvidia doesn't load when using module options

Up until now i was using the kernel option nvidia_drm.modeset=1 to enable DRM which was working fine but i wanted to try module options to see if it improved anything with the issues i have (perf issues/corruption).

So i tried enabling drm & fbdev by setting those as module options (earlier on, i had one option per line but it changed nothing)

❯ cat /etc/modeset.d/nvidia.conf

options nvidia_drm modeset=1 fbdev=1

(i also set the 4 nvidia modules in mkinitcpio's config as mentioned in the wiki)

❯ cat /etc/mkinitcpio.conf
MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)
HOOKS=(base udev autodetect modconf kms keyboard keymap consolefont block filesystems fsck)

but with drm set like that, kde on a wayland session doesn't load (although apps that i have as autostart do load)

At first i was using the nvidia-beta-kms package but i'm now on the regular nvidia package with the same problem (i've tried disabling the kms hook as mentioned by the wiki but since it had no effect, i re-enabled it) 
Also, i made sure to the rebuild initramfs and update my grub config

here's the logs of a boot with that problem: … 9d3b4bdeef
it seems like the culprit is line 2108:

févr. 09 00:43:21 PC-ANTOINE kwin_wayland_wrapper[938]: MESA-LOADER: failed to open simpledrm: /usr/lib/dri/ cannot open shared object file: No such file or directory (search paths /usr/lib/dri, suffix _dri)

i thought about blacklisting nouveau but i don't think i need to do it since i have the nvidia-utils package that adds the following config that should do it:

❯ cat /usr/lib/modprobe.d/nvidia-utils.conf
blacklist nouveau

Any idea what i could try more than this ?

Also, I should probably mention that i'm running kde 6 but it seems unlikely it's the cause of that problem

Hardware spec:
Operating System: Arch Linux
KDE Plasma Version: 5.93.0
KDE Frameworks Version: 5.249.0
Qt Version: 6.7.0
Kernel Version: 6.7.4-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 7800X3D 8-Core Processor
Memory: 31,1 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2080/PCIe/SSE2
Manufacturer: Micro-Star International Co., Ltd.
Product Name: MS-7E12
System Version: 1.0

Last edited by lifeismana (2024-02-09 13:04:43)


#2 2024-02-09 01:54:08

Forum Moderator
Registered: 2012-10-16
Posts: 21,605

Re: [SOLVED] KDE Wayland Nvidia doesn't load when using module options

You need to add nvidia_drm.modeset=1 to the kernel (commandline) parameters in order to properly disable the simpledrm device. fdev=1 has also been plagued by various bouts of instability you probably don't want to use that yet.


#3 2024-02-09 13:04:15

Registered: 2024-02-08
Posts: 4

Re: [SOLVED] KDE Wayland Nvidia doesn't load when using module options

Indeed that fixed it, the wiki made me think it was one or the other, seems like it was a wrong interpretation on my side.

On a side note, with nvidia 550 (via nvidia-beta-dkms), i'm not having any problem that i didn't have before enabling fdev=1


#4 2024-02-12 22:16:02

Registered: 2024-02-08
Posts: 4

Re: [SOLVED] KDE Wayland Nvidia doesn't load when using module options

eh, took a look it again and i wasn't wrong, with nvidia > 545, kernel option isn't required if you enable fbdev but my mistake was putting that config in the modeset.d folder instead of the modprob.d folder, doing so fixed the boot (without the kernel commandline param)


Board footer

Powered by FluxBB