You are not logged in.

#1 2024-02-08 00:33:09

slytux
Member
From: New York
Registered: 2010-09-25
Posts: 129

[Solved] Realtek firmware fails to load

I am on the latest updates as of today and noticed that the firmware for my realtek NIC is not loading on boot.  I decompressed the relevant firmware file under the /usr/lib/firmware/rtl_nic directory and the error went away on the next boot.

core/linux-firmware 20240115.9b6d0b08-2

The error from dmesg:

r8169 0000:04:00.0: Unable to load firmware rtl_nic/rtl8168e-2.fw (-2)

Last edited by slytux (2024-02-09 03:36:23)

Offline

#2 2024-02-08 11:27:49

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 20,994

Re: [Solved] Realtek firmware fails to load

Are you not using an Arch/repo kernel? Firmware decompression should happen transparently on relevantly setup kernels.

Last edited by V1del (2024-02-08 11:27:59)

Offline

#3 2024-02-08 21:55:46

slytux
Member
From: New York
Registered: 2010-09-25
Posts: 129

Re: [Solved] Realtek firmware fails to load

This can be closed.  I don't see the error with the stock Arch kernel.  I was using my custom kernel config from some time ago.

Last edited by slytux (2024-02-08 21:55:58)

Offline

#4 2024-02-09 00:18:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 20,994

Re: [Solved] Realtek firmware fails to load

Please mark as [SOLVED] by editing the title in your first post.

Offline

#5 2024-02-10 14:18:39

slytux
Member
From: New York
Registered: 2010-09-25
Posts: 129

Re: [Solved] Realtek firmware fails to load

I found the setting to be enabled in the kernel build customization menu.  It is under Device Drivers --> Generic Driver Options --> Firmware Loading Support and under the compression settings.  I am updating from an old kernel config that didn't have it set.  Also, make menuconfig should be put back and left commented in the PKGBUILD in case Arch users want to customize settings.

Offline

Board footer

Powered by FluxBB