You are not logged in.

#1 2024-02-10 21:43:11

From: Germany
Registered: 2024-02-10
Posts: 1

ThinkPad T460 not booting in Ultra Bay


I have a ThinkPad T460 running Arch. I recently got an Ultra Dock. Two monitors are attached via Display Port (DP-2-1 and DP-2-2, determined with xrandr -q).

I cannot successfully boot or reboot the ThinkPad in the Ultra Dock. The displays go dark after the Lenovo boot screen. There seems no booting of the operating system, no connection to network or possibility to SSH-in. I can only turn off the ThinkPad with a long press of the power button.

This is my graphics card and graphics driver:

$ lspci -v
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Skylake GT2 [HD Graphics 520]
        Flags: bus master, fast devsel, latency 0, IRQ 130
        Memory at f0000000 (64-bit, non-prefetchable) [size=16M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at e000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

$ inxi -G                                                                                                                                                                                                                          [20:59:58]
  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
  Device-2: Chicony Integrated Camera driver: uvcvideo type: USB
  Device-3: Logitech Webcam C170 driver: snd-usb-audio,uvcvideo type: USB
  Display: x11 server: v: with: Xwayland v: 23.2.4 driver:
    X: loaded: modesetting dri: iris gpu: i915 resolution: 1: 1920x1200~60Hz
    2: 1920x1200~60Hz 3: N/A
  API: EGL v: 1.5 drivers: iris,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.5-arch1.1
    renderer: Mesa Intel HD Graphics 520 (SKL GT2)

What works as a work-around:
- Boot the ThinkPad OUTSIDE the Ultra Dock
- Enter suspend mode, e.g. by closing lid
- Dock to Ultra Dock (with monitors attached)
- "Wake up" ThinkPad from suspend mode

I already updates UEFI/Bios and the FW of the Ultra Dock - no change. For updating the Ultra Dock I had to temporarily install Windows 10. Booting and rebooting of the ThinkPad in the Ultra Dock with display output via the two Display Ports worked in Windows without issues. Therefore, I ruled out a hardware issue.

The last thing I tried was changing the line GRUB_CMDLINE_LINUX from

  GRUB_CMDLINE_LINUX="video=HDMI-1:e video=eDP-1:e cryptdevice=/dev/sda3:cryptroot"


  GRUB_CMDLINE_LINUX="video=HDMI-1:e video=eDP-1:e video=DP-2-1:e video=DP-2-2:e cryptdevice=/dev/sda3:cryptroot"

and re-installed grub - again, without a positive effect.

Any suggestions how I could solve the problem?

Thanks in advance, rzbrk

Note: This old thread with a similar problem did not help:

Last edited by rzbrk (2024-02-10 21:53:00)


Board footer

Powered by FluxBB