You are not logged in.

#1 2024-02-10 21:46:48

MetalInMyVeins
Member
Registered: 2024-02-03
Posts: 7

cheese (or any camera app) not working

What's wrong:
cheese or any other camera app used to work well some months ago. But now none of them works. Even not in any distro.

Technical Details:

┬─(bla㉿Archpad)──(~)──(03:31:18)
╰───>> cheese

** (cheese:16758): CRITICAL **: 03:31:23.479: cheese_preferences_dialog_on_source_change: assertion '_tmp2_ > ((guint) 0)' failed

(cheese:16758): cheese-CRITICAL **: 03:31:23.479: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed

(cheese:16758): GLib-CRITICAL **: 03:31:23.479: g_variant_new_string: assertion 'string != NULL' failed

(cheese:16758): GLib-CRITICAL **: 03:31:23.479: g_variant_ref_sink: assertion 'value != NULL' failed

(cheese:16758): GLib-GIO-CRITICAL **: 03:31:23.479: g_settings_schema_key_type_check: assertion 'value != NULL' failed

(cheese:16758): GLib-CRITICAL **: 03:31:23.479: g_variant_get_type_string: assertion 'value != NULL' failed

(cheese:16758): GLib-GIO-CRITICAL **: 03:31:23.479: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given

(cheese:16758): GLib-CRITICAL **: 03:31:23.479: g_variant_unref: assertion 'value != NULL' failed

** (cheese:16758): CRITICAL **: 03:31:23.479: cheese_preferences_dialog_setup_resolutions_for_device: assertion 'device != NULL' failed

(cheese:16758): cheese-WARNING **: 03:31:24.558: Failed to allocate required memory.: ../gstreamer/subprojects/gst-plugins-good/sys/v4l2/gstv4l2src.c(949): gst_v4l2src_decide_allocation (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin37/GstV4l2Src:v4l2src2:
Buffer pool activation failed


** (cheese:16758): CRITICAL **: 03:31:24.560: cheese_preferences_dialog_on_source_change: assertion '_tmp2_ > ((guint) 0)' failed

(cheese:16758): cheese-CRITICAL **: 03:31:24.560: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed

(cheese:16758): GLib-CRITICAL **: 03:31:24.560: g_variant_new_string: assertion 'string != NULL' failed

(cheese:16758): GLib-CRITICAL **: 03:31:24.560: g_variant_ref_sink: assertion 'value != NULL' failed

(cheese:16758): GLib-GIO-CRITICAL **: 03:31:24.560: g_settings_schema_key_type_check: assertion 'value != NULL' failed

(cheese:16758): GLib-CRITICAL **: 03:31:24.560: g_variant_get_type_string: assertion 'value != NULL' failed

(cheese:16758): GLib-GIO-CRITICAL **: 03:31:24.560: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given

(cheese:16758): GLib-CRITICAL **: 03:31:24.560: g_variant_unref: assertion 'value != NULL' failed

** (cheese:16758): CRITICAL **: 03:31:24.560: cheese_preferences_dialog_setup_resolutions_for_device: assertion 'device != NULL' failed


┬─(bla㉿Archpad)──(~)──(03:31:30)
╰───>> lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 27c6:55b4 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
Bus 001 Device 004: ID 8087:0029 Intel Corp. AX200 Bluetooth
Bus 001 Device 013: ID 30c9:0014 Luxvisions Innotech Limited Integrated Camera
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub


┬─(bla㉿Archpad)──(~)──(03:38:25)
╰───>> uname -a
Linux Archpad 6.7.4-zen1-1-zen #1 ZEN SMP PREEMPT_DYNAMIC Mon, 05 Feb 2024 22:07:37 +0000 x86_64 GNU/Linux


┬─(bla㉿Archpad)──(~)──(03:39:06)
╰───>> kamoso
Qt Quick Layouts: Detected recursive rearrange. Aborting after two iterations.
Qt Quick Layouts: Detected recursive rearrange. Aborting after two iterations.
qrc:/qml/Config.qml:71: TypeError: Cannot read property 'filters' of null
qrc:/qml/Config.qml:71: TypeError: Cannot read property 'filters' of null
error debugMessage: Failed to allocate required memory.
error: "../gstreamer/subprojects/gst-plugins-good/sys/v4l2/gstv4l2src.c(949): gst_v4l2src_decide_allocation (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:/GstV4l2Src:Integrated Camera: Integrated C:\nBuffer pool activation failed"
Stop

I have already tried solutions like setting up the image capture size to 640X480 etc but none of those solutions work either.
The fingerprint reader doesn't work too but I know that device is not supposed to work on linux cause there's no driver so that's not my problem for now.
Laptop is Thinkpad L14 Gen 1.

Last edited by MetalInMyVeins (2024-02-10 21:51:11)

Offline

#2 2024-02-10 23:01:56

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: cheese (or any camera app) not working

Is the device picked up by any driver?
Please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Assuming the device is there it's likely a permission problem

strace -f -o /tmp/cheese.strace cheese
cat /tmp/cheese.strace | curl -F 'file=@-' 0x0.st # upload it to a pastebin service

Offline

#3 2024-02-11 09:27:29

MetalInMyVeins
Member
Registered: 2024-02-03
Posts: 7

Re: cheese (or any camera app) not working

seth wrote:

Is the device picked up by any driver?
Please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Assuming the device is there it's likely a permission problem

strace -f -o /tmp/cheese.strace cheese
cat /tmp/cheese.strace | curl -F 'file=@-' 0x0.st # upload it to a pastebin service
sudo journalctl -b | curl -F 'file=@-' 0x0.st

https://0x0.st/Hd12.txt

strace -f -o /tmp/cheese.strace cheese
cat /tmp/cheese.strace | curl -F 'file=@-' 0x0.st # upload it to a pastebin service

https://0x0.st/Hd1L.txt

Offline

#4 2024-02-11 09:45:54

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: cheese (or any camera app) not working

Feb 11 15:07:58 Archpad kernel: videodev: Linux video capture interface: v2.00
Feb 11 15:07:58 Archpad kernel: usb 1-7: Found UVC 1.10 device Integrated Camera (30c9:0014)
Feb 11 15:07:58 Archpad kernel: usbcore: registered new interface driver uvcvideo

Camera is there and

4037  newfstatat(AT_FDCWD, "/dev/video0", {st_mode=S_IFCHR|0660, st_rdev=makedev(0x51, 0), ...}, 0) = 0
4037  openat(AT_FDCWD, "/dev/video0", O_RDWR) = 30
4037  ioctl(30, VIDIOC_QUERYCAP, {driver="uvcvideo", card="Integrated Camera: Integrated C", bus_info="usb-0000:00:14.0-7", version=KERNEL_VERSION(6, 7, 4), capabilities=V4L2_CAP_VIDEO_CAPTURE|V4L2_CAP_EXT_PIX_FORMAT|V4L2_CAP_META_CAPTURE|V4L2_CAP_STREAMING|V4L2_CAP_DEVICE_CAPS, device_caps=V4L2_CAP_VIDEO_CAPTURE|V4L2_CAP_EXT_PIX_FORMAT|V4L2_CAP_STREAMING}) = 0
4037  ioctl(30, VIDIOC_ENUMINPUT, {index=0, name="Camera 1", type=V4L2_INPUT_TYPE_CAMERA, audioset=0, tuner=0, std=0, status=0, capabilities=0}) = 0
4037  ioctl(30, VIDIOC_ENUMINPUT, {index=1}) = -1 EINVAL (Invalid argument)
4037  ioctl(30, VIDIOC_ENUMSTD, {index=0}) = -1 ENOTTY (Inappropriate ioctl for device)
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|0 /* V4L2_CID_??? */ => V4L2_CTRL_CLASS_USER+0x1, type=V4L2_CTRL_TYPE_CTRL_CLASS, name="User Controls", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CTRL_CLASS_USER+0x1 => V4L2_CID_BRIGHTNESS, type=V4L2_CTRL_TYPE_INTEGER, name="Brightness", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_BRIGHTNESS => V4L2_CID_CONTRAST, type=V4L2_CTRL_TYPE_INTEGER, name="Contrast", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_CONTRAST => V4L2_CID_SATURATION, type=V4L2_CTRL_TYPE_INTEGER, name="Saturation", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_SATURATION => V4L2_CID_HUE, type=V4L2_CTRL_TYPE_INTEGER, name="Hue", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_HUE => V4L2_CID_AUTO_WHITE_BALANCE, type=V4L2_CTRL_TYPE_BOOLEAN, name="White Balance, Automatic", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_AUTO_WHITE_BALANCE => V4L2_CID_GAMMA, type=V4L2_CTRL_TYPE_INTEGER, name="Gamma", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_GAMMA => V4L2_CID_POWER_LINE_FREQUENCY, type=V4L2_CTRL_TYPE_MENU, name="Power Line Frequency", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_POWER_LINE_FREQUENCY => V4L2_CID_WHITE_BALANCE_TEMPERATURE, type=V4L2_CTRL_TYPE_INTEGER, name="White Balance Temperature", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_WHITE_BALANCE_TEMPERATURE => V4L2_CID_SHARPNESS, type=V4L2_CTRL_TYPE_INTEGER, name="Sharpness", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_SHARPNESS => V4L2_CID_BACKLIGHT_COMPENSATION, type=V4L2_CTRL_TYPE_INTEGER, name="Backlight Compensation", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_BACKLIGHT_COMPENSATION => V4L2_CTRL_CLASS_CAMERA+0x1, type=V4L2_CTRL_TYPE_CTRL_CLASS, name="Camera Controls", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CTRL_CLASS_CAMERA+0x1 => V4L2_CID_EXPOSURE_AUTO, type=V4L2_CTRL_TYPE_MENU, name="Auto Exposure", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_EXPOSURE_AUTO => V4L2_CID_EXPOSURE_ABSOLUTE, type=V4L2_CTRL_TYPE_INTEGER, name="Exposure Time, Absolute", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_EXPOSURE_ABSOLUTE => V4L2_CID_EXPOSURE_AUTO_PRIORITY, type=V4L2_CTRL_TYPE_BOOLEAN, name="Exposure, Dynamic Framerate", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_EXPOSURE_AUTO_PRIORITY}) = -1 EINVAL (Invalid argument)
4037  ioctl(30, VIDIOC_G_STD, 0x7ffd802c0900) = -1 ENOTTY (Inappropriate ioctl for device)
4037  ioctl(30, VIDIOC_G_INPUT, [0])    = 0

you can talk to it

Feb 11 15:08:47 Archpad pipewire[1447]: [0:01:15.438736826] [1447] ERROR IPAModule ipa_module.cpp:172 Symbol ipaModuleInfo not found
Feb 11 15:08:47 Archpad pipewire[1447]: [0:01:15.438747243] [1447] ERROR IPAModule ipa_module.cpp:292 v4l2-compat.so: IPA module has no valid info
Feb 11 15:08:47 Archpad pipewire[1447]: [0:01:15.438784544] [1447]  INFO Camera camera_manager.cpp:284 libcamera v0.2.0
…
Feb 11 15:08:47 Archpad wireplumber[1448]: <WpPortalPermissionStorePlugin:0x5de71e9b5e00> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera
Feb 11 15:08:47 Archpad wireplumber[1448]: <WpPortalPermissionStorePlugin:0x5de71e9b5e00> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

Might be a problem.
Check

wpctl status

and in doubt move away ~/.config/wireplumber/ and ~/.config/pipewire/

Edit: the cam also seems to show up as video0 and video1, try to ecplicitly select the device, https://man.archlinux.org/man/extra/cheese/cheese.1.en
(-d /dev/video1)

Last edited by seth (2024-02-11 09:48:31)

Offline

#5 2024-02-14 15:06:15

MetalInMyVeins
Member
Registered: 2024-02-03
Posts: 7

Re: cheese (or any camera app) not working

seth wrote:
Feb 11 15:07:58 Archpad kernel: videodev: Linux video capture interface: v2.00
Feb 11 15:07:58 Archpad kernel: usb 1-7: Found UVC 1.10 device Integrated Camera (30c9:0014)
Feb 11 15:07:58 Archpad kernel: usbcore: registered new interface driver uvcvideo

Camera is there and

4037  newfstatat(AT_FDCWD, "/dev/video0", {st_mode=S_IFCHR|0660, st_rdev=makedev(0x51, 0), ...}, 0) = 0
4037  openat(AT_FDCWD, "/dev/video0", O_RDWR) = 30
4037  ioctl(30, VIDIOC_QUERYCAP, {driver="uvcvideo", card="Integrated Camera: Integrated C", bus_info="usb-0000:00:14.0-7", version=KERNEL_VERSION(6, 7, 4), capabilities=V4L2_CAP_VIDEO_CAPTURE|V4L2_CAP_EXT_PIX_FORMAT|V4L2_CAP_META_CAPTURE|V4L2_CAP_STREAMING|V4L2_CAP_DEVICE_CAPS, device_caps=V4L2_CAP_VIDEO_CAPTURE|V4L2_CAP_EXT_PIX_FORMAT|V4L2_CAP_STREAMING}) = 0
4037  ioctl(30, VIDIOC_ENUMINPUT, {index=0, name="Camera 1", type=V4L2_INPUT_TYPE_CAMERA, audioset=0, tuner=0, std=0, status=0, capabilities=0}) = 0
4037  ioctl(30, VIDIOC_ENUMINPUT, {index=1}) = -1 EINVAL (Invalid argument)
4037  ioctl(30, VIDIOC_ENUMSTD, {index=0}) = -1 ENOTTY (Inappropriate ioctl for device)
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|0 /* V4L2_CID_??? */ => V4L2_CTRL_CLASS_USER+0x1, type=V4L2_CTRL_TYPE_CTRL_CLASS, name="User Controls", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CTRL_CLASS_USER+0x1 => V4L2_CID_BRIGHTNESS, type=V4L2_CTRL_TYPE_INTEGER, name="Brightness", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_BRIGHTNESS => V4L2_CID_CONTRAST, type=V4L2_CTRL_TYPE_INTEGER, name="Contrast", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_CONTRAST => V4L2_CID_SATURATION, type=V4L2_CTRL_TYPE_INTEGER, name="Saturation", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_SATURATION => V4L2_CID_HUE, type=V4L2_CTRL_TYPE_INTEGER, name="Hue", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_HUE => V4L2_CID_AUTO_WHITE_BALANCE, type=V4L2_CTRL_TYPE_BOOLEAN, name="White Balance, Automatic", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_AUTO_WHITE_BALANCE => V4L2_CID_GAMMA, type=V4L2_CTRL_TYPE_INTEGER, name="Gamma", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_GAMMA => V4L2_CID_POWER_LINE_FREQUENCY, type=V4L2_CTRL_TYPE_MENU, name="Power Line Frequency", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_POWER_LINE_FREQUENCY => V4L2_CID_WHITE_BALANCE_TEMPERATURE, type=V4L2_CTRL_TYPE_INTEGER, name="White Balance Temperature", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_WHITE_BALANCE_TEMPERATURE => V4L2_CID_SHARPNESS, type=V4L2_CTRL_TYPE_INTEGER, name="Sharpness", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_SHARPNESS => V4L2_CID_BACKLIGHT_COMPENSATION, type=V4L2_CTRL_TYPE_INTEGER, name="Backlight Compensation", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_BACKLIGHT_COMPENSATION => V4L2_CTRL_CLASS_CAMERA+0x1, type=V4L2_CTRL_TYPE_CTRL_CLASS, name="Camera Controls", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CTRL_CLASS_CAMERA+0x1 => V4L2_CID_EXPOSURE_AUTO, type=V4L2_CTRL_TYPE_MENU, name="Auto Exposure", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_EXPOSURE_AUTO => V4L2_CID_EXPOSURE_ABSOLUTE, type=V4L2_CTRL_TYPE_INTEGER, name="Exposure Time, Absolute", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_EXPOSURE_ABSOLUTE => V4L2_CID_EXPOSURE_AUTO_PRIORITY, type=V4L2_CTRL_TYPE_BOOLEAN, name="Exposure, Dynamic Framerate", ...}) = 0
4037  ioctl(30, VIDIOC_QUERYCTRL, {id=V4L2_CTRL_FLAG_NEXT_CTRL|V4L2_CID_EXPOSURE_AUTO_PRIORITY}) = -1 EINVAL (Invalid argument)
4037  ioctl(30, VIDIOC_G_STD, 0x7ffd802c0900) = -1 ENOTTY (Inappropriate ioctl for device)
4037  ioctl(30, VIDIOC_G_INPUT, [0])    = 0

you can talk to it

Feb 11 15:08:47 Archpad pipewire[1447]: [0:01:15.438736826] [1447] ERROR IPAModule ipa_module.cpp:172 Symbol ipaModuleInfo not found
Feb 11 15:08:47 Archpad pipewire[1447]: [0:01:15.438747243] [1447] ERROR IPAModule ipa_module.cpp:292 v4l2-compat.so: IPA module has no valid info
Feb 11 15:08:47 Archpad pipewire[1447]: [0:01:15.438784544] [1447]  INFO Camera camera_manager.cpp:284 libcamera v0.2.0
…
Feb 11 15:08:47 Archpad wireplumber[1448]: <WpPortalPermissionStorePlugin:0x5de71e9b5e00> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera
Feb 11 15:08:47 Archpad wireplumber[1448]: <WpPortalPermissionStorePlugin:0x5de71e9b5e00> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

Might be a problem.
Check

wpctl status

and in doubt move away ~/.config/wireplumber/ and ~/.config/pipewire/

Edit: the cam also seems to show up as video0 and video1, try to ecplicitly select the device, https://man.archlinux.org/man/extra/cheese/cheese.1.en
(-d /dev/video1)

Done everything that you have told me to check. Nothing works so far. Also, doung `cheese -d /dev/video0` or `cheese -d /dev/video1` makes the camera to go away from the `lsusb` output temporarily.

Offline

#6 2024-02-14 15:29:29

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: cheese (or any camera app) not working

Please refrain from pointlessly bloating the thread with full quotes.

What's the actual output of "wpctl status" and what gets added to the journal when

`cheese -d /dev/video0` or `cheese -d /dev/video1` makes the camera to go away from the `lsusb` output temporarily

?

Offline

#7 2024-02-14 19:43:16

MetalInMyVeins
Member
Registered: 2024-02-03
Posts: 7

Re: cheese (or any camera app) not working

┬─(metal888㉿Archpad)──(01:05:53)
╰───>> wpctl status
PipeWire 'pipewire-0' [1.0.3, metal888@Archpad, cookie:2612608605]
 └─ Clients:
        31. xdg-desktop-portal                  [1.0.3, metal888@Archpad, pid:1126]
        32. pipewire                            [1.0.3, metal888@Archpad, pid:1482]
        33. WirePlumber                         [1.0.3, metal888@Archpad, pid:1327]
        35. WirePlumber [export]                [1.0.3, metal888@Archpad, pid:1327]
        43. KMix                                [1.0.3, metal888@Archpad, pid:1480]
        48. Plasma PA                           [1.0.3, metal888@Archpad, pid:1208]
        49. easyeffects                         [0.3.69, metal888@Archpad, pid:2]
        89. Chromium input                      [1.0.3, metal888@Archpad, pid:362002]
       110. WEBRTC VoiceEngine                  [1.0.3, metal888@Archpad, pid:361935]
       114. KDE Power Management System         [1.0.3, metal888@Archpad, pid:1250]
       115. tilix                               [1.0.3, metal888@Archpad, pid:327326]
       116. libcanberra                         [1.0.3, metal888@Archpad, pid:1208]
       117. discord                             [1.0.3, metal888@Archpad, pid:361789]
       119. WEBRTC VoiceEngine                  [1.0.3, metal888@Archpad, pid:361935]
       125. wpctl                               [1.0.3, metal888@Archpad, pid:366690]

Audio
 ├─ Devices:
 │      42. Built-in Audio                      [alsa]
 │  
 ├─ Sinks:
 │  *   47. Built-in Audio Analog Stereo        [vol: 0.40]
 │      50. Easy Effects Sink                   [vol: 0.75]
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  *   51. Easy Effects Source                 [vol: 1.00 MUTED]
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:

Video
 ├─ Devices:
 │  
 ├─ Sinks:
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:

Settings
 └─ Default Configured Node Names:
         0. Audio/Sink    bluez_output.B4_9A_95_57_45_BF.1
         1. Audio/Source  alsa_input.pci-0000_00_1f.3.analog-stereo

No camera device found. This happened after i executed `cheese -d /dev/video0` in terminal.

┬─(metal888㉿Archpad)──(01:35:17)
╰───>> lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 27c6:55b4 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
Bus 001 Device 003: ID 8087:0029 Intel Corp. AX200 Bluetooth
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

http://0x0.st/HdR6.txt
http://0x0.st/HdRI.txt

Offline

#8 2024-02-14 21:35:09

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: cheese (or any camera app) not working

What does "go away from the `lsusb` output temporarily" exactly mean? How "temporarily" is "temporarily"?
There's no trace of your webcam in http://0x0.st/HdR6.txt at all (it's just full of openvpn failures)

Also get rid of xf86-video-intel:

Feb 14 13:03:29 Archpad plasmashell[2132]: libva error: /usr/lib/dri/i965_drv_video.so init failed
sudo journactl -f

Then

cheese -d /dev/video0

and post the tail that produces in the journal command above.

Also

/usr/sbin/cheese

are you running this as root???

Offline

#9 2024-02-15 16:55:23

MetalInMyVeins
Member
Registered: 2024-02-03
Posts: 7

Re: cheese (or any camera app) not working

::: Sorry english is not my first. By going away temporarily, i meant for example:
> I execute `lsusb` at 12:01. The webcam is visible along with other connected devices.
> At 12:02, I execute `cheese -d /dev/video0`. The camera fails to work as always.
> I execute `lsusb` again at 12:03. Bt this time the webcam is not in the `lsusb` output. As if there is not integrated camera in my laptop.
> I execute `cheese -d /dev/video0` again at 12:04. This time cheese says "No Device found."
> After waiting for a few minutes, let's say at 12:15, I execute `lsusb` again. But this time the integrated camera has returned back in the `lsusb` output.
> I run cheese again and that fails again.
> Loop continues.

::: Note that this has changed since the other day. Means, `lsusb` doesn't detect the camera anymore no matter when.

::: Got rid of xf86-video-intel like you told me to.

::: After running `sudo journalctl -f; cheese -d /dev/video0`:

sudo journalctl -b | tail | curl -F 'file=@-' 0x0.st

http://0x0.st/HnoF.txt
It's indeed full of openvpn failures.

::: And I only ran cheese as root when you mentioned that it might be permission issue. Other than that, I have always executed cheese without root.

Offline

#10 2024-02-15 20:52:15

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: cheese (or any camera app) not working

You should disable the broken openvpn service so it doesn't spoil the journal.
Then then point of "sudo journalctl -f" is so you can see what happens there when you do something with the camera, the random tail you posted just covers 6 seconds and most of it is the openvpn service but we want to know what happens in response to your actions, whether that's 10 or 100 lines.

However, wrt

'lsusb' doesn't detect the camera anymore no matter when

Does it show up on a different SW stack like grml or knoppix? Can you toggle it in the UEFI?

Offline

Board footer

Powered by FluxBB