You are not logged in.

#1 2024-02-20 02:09:57

d3Xt3r
Member
Registered: 2012-09-08
Posts: 19

[SOLVED] amdgpu keeps freezing after updating to mesa 24.0.1

Note: This is a solved issue, but thought that I'd post here anyways since I haven't seen this exact issue+log posted anywhere else, nor have I seen anyone suggest this "fix" - and confirm that it solved it for them.

If you've also had this issue, or can think of a better solution (or other suggestions/gotchas) feel free to post here. smile
----

Description

After recently upgrading to mesa 24.0.1, I noticed that my system would occasionally freeze for a few seconds when switching workspaces in Wayfire. I was able to reproduce the freezes consistently if I switched the workspaces too quickly.

Logs

journalctl showed these errors during the freeze:

kernel: amdgpu 0000:c5:00.0: amdgpu: [gfxhub] page fault (src_id:0 ring:24 vmid:1 pasid:32770, for process wayfire pid 1278 thread wayfire:cs0 pid 1356)
kernel: amdgpu 0000:c5:00.0: amdgpu:   in page starting at address 0x0000000000000000 from client 10
kernel: amdgpu 0000:c5:00.0: amdgpu: GCVM_L2_PROTECTION_FAULT_STATUS:0x00101430
kernel: amdgpu 0000:c5:00.0: amdgpu:          Faulty UTCL2 client ID: SQC (data) (0xa)
kernel: amdgpu 0000:c5:00.0: amdgpu:          MORE_FAULTS: 0x0
kernel: amdgpu 0000:c5:00.0: amdgpu:          WALKER_ERROR: 0x0
kernel: amdgpu 0000:c5:00.0: amdgpu:          PERMISSION_FAULTS: 0x3
kernel: amdgpu 0000:c5:00.0: amdgpu:          MAPPING_ERROR: 0x0
kernel: amdgpu 0000:c5:00.0: amdgpu:          RW: 0x0
kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx_0.0.0 timeout, but soft recovered

Environment

  • System: Minisforum UM780 XTX

  • CPU: AMD Ryzen 7 7840HS

  • GPU: Radeon 780M

  • DE/WM: Wayfire

Solution

Since the problem started after upgrading my system, and since mesa was the only relevant package among the packages that got upgraded, it was obvious that I should either try downgrading mesa, or switch to the latest git build. I decided to go with the latter. But instead of mesa-git, I chose to install amdonly-gaming-mesa-git (and amdonly-gaming-libva-mesa-driver-git to replace my libva-mesa-driver) - and voilà - problem solved.

Note: I'm not sure what's so special about these packages (ie why it's called "gaming"), but it seems to work fine so far in my limited testing. Plus, it took only a couple of minutes to build on my box, which was a pleasant surprise.

Offline

#2 2024-02-20 11:40:10

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 11,907

Re: [SOLVED] amdgpu keeps freezing after updating to mesa 24.0.1

it took only a couple of minutes to build on my box,

That's because it uses repo llvm instead of a trunk llvm build (which can take an hour or more) .

Keep in mind that the amdonly-gaming packages will perform poorly on systems with both intel + amd graphics .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2024-02-21 11:18:48

Newbieccc
Member
Registered: 2024-02-21
Posts: 1

Re: [SOLVED] amdgpu keeps freezing after updating to mesa 24.0.1

I have to be honest, I created this account just to complain about the bug since I can't report it on the right place. Tho, it's possible that my solution will help someone.

Last night I ran "pacman -Syuu" and didn't noticed mesa updating to 24.0.1, I didn't care since it had never broken anything before. After a while I tried to open a video file and my screen glitched with artefacts or something, so I restarted my system, only to be surprised with a frozen SDDM screen and a couple of glitches. I switched to another tty and managed to run "journalctl -b".
It took me a while to realize that the problem was with the mesa update, but when I realized I tried to solve the problem by installing mesa-git and amdonly-gaming-mesa-git, like you suggested (without success in my case).  After all that, I had to downgrade mesa to the last working version, but I'm still not sure if it is stable, since I noticed some graphical lag during intense activities and some problems with Desktop effects that I solved by downgrading vulkan-radeon as well. I really would like to know what exactly happened.

I'm sorry if I wasn't clear, English is not my first language.

Last edited by Newbieccc (2024-02-21 11:48:56)

Offline

Board footer

Powered by FluxBB