You are not logged in.

#1 2024-03-17 22:18:07

JaymanJuuzou
Member
Registered: 2024-03-17
Posts: 4

[SOLVED] pacman-git is in conflict with pacman.

When I try to update my system with paru, it gives me this:

jay@arch:~/Downloads
➤ paru                                                                                                                                                                                                                                  (base) 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
:: Starting full system upgrade...
 there is nothing to do
:: Looking for PKGBUILD upgrades...
:: Looking for AUR upgrades...
:: Looking for devel upgrades...
:: Resolving dependencies...
:: Calculating conflicts...
:: Calculating inner conflicts...

:: Conflicts found:
    pacman-git: pacman  

:: Conflicting packages will have to be confirmed manually
:: packages not in the AUR: khotkeys  kpeoplevcard  kquickcharts5  lib32-acl  lib32-alsa-lib  lib32-alsa-plugins  lib32-amdvlk  lib32-at-spi2-core  lib32-attr  lib32-brotli  lib32-bzip2  lib32-cairo  lib32-colord  lib32-curl  lib32-dbus  
    lib32-e2fsprogs  lib32-expat  lib32-flac  lib32-fontconfig  lib32-freetype2  lib32-fribidi  lib32-gdk-pixbuf2  lib32-gettext  lib32-giflib  lib32-glib2  lib32-gmp  lib32-gnutls  lib32-gst-plugins-base-libs  lib32-gstreamer  lib32-gtk3
    lib32-harfbuzz  lib32-icu  lib32-json-c  lib32-keyutils  lib32-krb5  lib32-lcms2  lib32-libasyncns  lib32-libcanberra  lib32-libcap  lib32-libcups  lib32-libdatrie  lib32-libdrm  lib32-libelf  lib32-libepoxy  lib32-libffi  
    lib32-libgcrypt  lib32-libglvnd  lib32-libgpg-error  lib32-libgudev  lib32-libidn2  lib32-libjpeg-turbo  lib32-libldap  lib32-libltdl  lib32-libnghttp2  lib32-libnghttp3  lib32-libnl  lib32-libogg  lib32-libpcap  lib32-libpciaccess  
    lib32-libpng  lib32-libpsl  lib32-libpulse  lib32-librsvg  lib32-libsndfile  lib32-libssh2  lib32-libtasn1  lib32-libthai  lib32-libtiff  lib32-libtirpc  lib32-libunistring  lib32-libunwind  lib32-libva  lib32-libvorbis  lib32-libx11
    lib32-libxau  lib32-libxcb  lib32-libxcomposite  lib32-libxcrypt  lib32-libxcrypt-compat  lib32-libxcursor  lib32-libxdamage  lib32-libxdmcp  lib32-libxext  lib32-libxfixes  lib32-libxft  lib32-libxi  lib32-libxinerama  
    lib32-libxkbcommon  lib32-libxml2  lib32-libxrandr  lib32-libxrender  lib32-libxshmfence  lib32-libxslt  lib32-libxss  lib32-libxtst  lib32-libxv  lib32-libxxf86vm  lib32-llvm-libs  lib32-lm_sensors  lib32-mesa  lib32-mpg123  
    lib32-ncurses  lib32-nettle  lib32-nspr  lib32-nss  lib32-ocl-icd  lib32-openal  lib32-openssl  lib32-opus  lib32-orc  lib32-p11-kit  lib32-pam  lib32-pango  lib32-pcre2  lib32-pixman  lib32-sqlite  lib32-systemd  lib32-tdb  
    lib32-util-linux  lib32-v4l-utils  lib32-vulkan-icd-loader  lib32-wayland  lib32-xz  lib32-zlib  lib32-zstd  steam  wine-staging  winetricks  yaourt
:: marked out of date: package-query  snapd-glib
:: orphans: krunner5

Aur (3) pacman-git-6.0.1.r152.g34611a66-1  libpamac-11.6.4-1  megasync-4.12.2.0-1

:: Proceed to review? [Y/n]: y

:: Downloading PKGBUILDs...
 PKGBUILDs up to date
 nothing new to review
fetching devel info...
==> Making package: pacman-git 6.0.1.r152.g34611a66-1 (Sun 17 Mar 2024 04:12:44 PM MDT)
==> Retrieving sources...
  -> Updating pacman git repo...
  -> Found pacman.conf.i686
  -> Found pacman.conf.x86_64
  -> Found pacman.conf.arm
  -> Found makepkg.conf
==> Validating source files with sha256sums...
    pacman ... Skipped
    pacman.conf.i686 ... Passed
    pacman.conf.x86_64 ... Passed
    pacman.conf.arm ... Passed
    makepkg.conf ... Passed
==> Making package: pacman-git 6.0.1.r152.g34611a66-1 (Sun 17 Mar 2024 04:12:47 PM MDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating pacman git repo...
  -> Found pacman.conf.i686
  -> Found pacman.conf.x86_64
  -> Found pacman.conf.arm
  -> Found makepkg.conf
==> Validating source files with sha256sums...
    pacman ... Skipped
    pacman.conf.i686 ... Passed
    pacman.conf.x86_64 ... Passed
    pacman.conf.arm ... Passed
    makepkg.conf ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of pacman git repo...
Cloning into 'pacman'...
done.
==> Starting pkgver()...
==> Updated version: pacman-git 6.1.0.r7.gbae9594a-1
==> Sources are ready.
pacman-git-6.0.1.r152.g34611a66-1: parsing pkg list...
:: pacman-git-6.0.1.r152.g34611a66-1 is up to date -- skipping build
loading packages...
resolving dependencies...
looking for conflicting packages...
:: pacman-git-6.1.0.r7.gbae9594a-1 and pacman-6.1.0-3 are in conflict. Remove pacman? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pacman breaks dependency 'libalpm.so>=14-64' required by paru
loading packages...
resolving dependencies...
looking for conflicting packages...
:: pacman-git-6.1.0.r7.gbae9594a-1 and pacman-6.1.0-3 are in conflict. Remove pacman? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pacman breaks dependency 'libalpm.so>=14-64' required by paru
loading packages...
resolving dependencies...
looking for conflicting packages...
:: pacman-git-6.1.0.r7.gbae9594a-1 and pacman-6.1.0-3 are in conflict. Remove pacman? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pacman breaks dependency 'libalpm.so>=14-64' required by paru
error: packages failed to build: libpamac-11.6.4-1  megasync-4.12.2.0-1

Is there some way to stop paru from trying to install pacman-git? Any help would be greatly appreciated.

Last edited by JaymanJuuzou (2024-03-18 01:00:15)


Femboys are love, femboys are life.

Offline

#2 2024-03-17 22:34:59

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,662

Re: [SOLVED] pacman-git is in conflict with pacman.

Don't update libpamac. Why do you have that installed if you use paru anyway?

Offline

#3 2024-03-17 22:36:45

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,652
Website

Re: [SOLVED] pacman-git is in conflict with pacman.

First, edit your post to replace the quote tags with code tags.

Second, why do you have a bunch of lib32- packages installed but you are not using multilib repos?

Third, if you want to stop paru from trying to install pacman-git, stop using paru (and all those other aur helpers you seem to have installed).

Fourth, tell us what distro you're actually using: anarchy, manjaro, etc?

Last edited by Trilby (2024-03-17 22:37:44)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2024-03-17 22:47:42

JaymanJuuzou
Member
Registered: 2024-03-17
Posts: 4

Re: [SOLVED] pacman-git is in conflict with pacman.

Trilby wrote:

First, edit your post to replace the quote tags with code tags.

Second, why do you have a bunch of lib32- packages installed but you are not using multilib repos?

Third, if you want to stop paru from trying to install pacman-git, stop using paru (and all those other aur helpers you seem to have installed).

Fourth, tell us what distro you're actually using: anarchy, manjaro, etc?

To your second question, no clue. I just wanna update my system man, if I shouldn't use an aur helper to update all my aur packages, then how should I go about doing that? Was working fine just yesterday. I'm using Arch.

Last edited by JaymanJuuzou (2024-03-17 22:48:07)


Femboys are love, femboys are life.

Offline

#5 2024-03-17 22:49:07

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,957
Website

Re: [SOLVED] pacman-git is in conflict with pacman.

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#6 2024-03-18 00:27:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,965

Re: [SOLVED] pacman-git is in conflict with pacman.

Remove libpamac, and update your system.

Offline

#7 2024-03-18 00:37:14

JaymanJuuzou
Member
Registered: 2024-03-17
Posts: 4

Re: [SOLVED] pacman-git is in conflict with pacman.

V1del wrote:

Remove libpamac, and update your system.

My savior, this worked.

Last edited by JaymanJuuzou (2024-03-18 00:37:32)


Femboys are love, femboys are life.

Offline

#8 2024-03-18 00:58:50

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,965

Re: [SOLVED] pacman-git is in conflict with pacman.

While this is the quick fix (technically Scimmia already mentioned that, but a bit less explicit), you should still heed the other advices given here, or the fallouts will eventually bite you.

In any case, please mark as [SOLVED] by editing the title in your first post.

Offline

#9 2024-03-18 01:00:58

JaymanJuuzou
Member
Registered: 2024-03-17
Posts: 4

Re: [SOLVED] pacman-git is in conflict with pacman.

Thank you everyone for the advice! Appreciate you all out there.


Femboys are love, femboys are life.

Offline

Board footer

Powered by FluxBB