You are not logged in.

#1 2024-03-21 00:56:48

Registered: 2021-11-12
Posts: 5

[SOLVED] Kernel panic `` no such file

When I boot the `linux-lts` kernel uki with the following cmdline:

root=/dev/mapper/lvm_cryptroot-lvm_root rootflags=rw,noatime,compression=lz4,background_compression=zstd:7 rw debug=all loglevel=8 earlyprintk=efi,keep log_buf_len=16M

I get

/init: error while loading shared libraries: cannot open share object file: No such file or directory


Secure boot is disabled.
Refind boots up correctly and I can choose and boot windows.

MODULES=(tpm_crb hid usbhid usbcore thunderbolt crypto_user crypto_simd cryptd btrfs vfio-pci)

BINARIES=(bcachefs btrfs)


HOOKS=(base systemd autodetect modconf kms keyboard sd-vconsole block sd-encrypt lvm2 filesystems fsck)
 mkinitcpio preset file for the 'linux' package


PRESETS=('default' 'fallback')

default_options="--splash /usr/share/systemd/bootctl/splash-arch.bmp"

fallback_options="-S autodetect"


Found someone who had a similiar issue but did not document the fix:

Weird it seems like the share lib is contained in the cpio.

# lsinitcpio /boot/initramfs-linux.img | grep systemd-core

Something is really off.
I get lots of uncompression errors.
I tried nosmp maxcpus=1 iommu=soft in many permutations.
The disks smart stats are all good.

Last edited by raldone01 (2024-03-21 17:57:43)


#2 2024-03-21 20:47:09

Registered: 2021-11-12
Posts: 5

Re: [SOLVED] Kernel panic `` no such file

After digging around a lot I found out that random decompression errors no matter which algorithm I used occurred.
The solution was to just update the UEFI from F.20 (2020) to F.40 (2023) something.
This is my laptops model number: OMEN Laptop - 17-cb1278ng
I had to download the driver from HPs website their support assistant did not offer the required update.
On one hand I am very annoyed that the uefi had severe bugs on the other hand I am impressed that hp offers 3 years of uefi updates so far. I hope they continue to offer them for at least another 5-10 years.

Long story:
This was my forth arch install.
Using my guide I have refined and customized with each install I intended to quickly and painlessly set up my other laptop with arch/windows dual boot as well. I intended to use bcachefs as the rootfs since its new and I wanted to evaluate it.
I had hoped to get it right the first time.

Refind booted up fine.
I choose my arch uki and BAM secure boot verification failed.
No matter I will just reenroll the keys but no matter what I tried I just couldn't enroll the with sbctl.

2 hours of painful reboots and chroots later...
Well damn just skip it for now.

Secure boot disabled and on to a new boot attempt. No dice this time refind chainloads the uki but I get only the splash screen then its stuck.
I disable the splash screen but still see no output.
I add the suggested debug options from arch wiki

debug=all loglevel=8 earlyprintk=efi,keep log_buf_len=16M

still no output.
I boot the fallback image and get some output on linux-lts-fallback but not on linux and linux-zen.
It suggest that there is some issue loading libsystemd-core.
3 hours debugging later I arrive at the conclusion that the lib is in the uki and the hash matches my other machines.
I continue to make changes to mkinitcpio.conf and suddenly the error changes to decompression errors.
Next I try various compression settings.
Mhh they all say my image is corrupted but in the chroot I can decompress it just fine and the fat32 fs is also good.

I start to suspect the hardware.

No smart errors on the disk.
A quick memtest later and its good.

Maybe some weird cpu bug.
I try all permutations of

nosmp maxcpus=1/0 iommu=soft noacpi acpi=off

and disable compression/change it around.
Nothing works.

I start to suspect the uefi. I am no stranger to very buggy uefis as all motherboards I own have had severe uefi bugs. Most went unfixed forever.
The other laptop I own is a samsung laptop. These are known for bricking randomly and my new samsung book 360 also has severe uefi bugs when it comes to the bootorder and touch input.

I check the bios version in the uefi F.20 from (2020) and check the hp support assistant. Everything up to date it tells me but I already know that these programs all lie. So I poke around their website and find an uefi update after closing like 10 popups suggesting to just use their great support assistant. Infuriating.

After the uefi update I boot again.
It boots with no issue what so ever even bcachefs loads first try.
All in all this install took me two whole workdays to resolve.
My longest arch install as of yet.

I hope this may help anyone facing a similar issue.
Even if your issue is different the debugging steps may give you some ideas to debug your situation further.
Loads of thanks to @seth. His forum posts helped me a lot.

Last edited by raldone01 (2024-03-21 21:13:23)


Board footer

Powered by FluxBB