You are not logged in.

#1 2024-03-25 20:47:16

VecchiaZimarra
Member
Registered: 2023-03-16
Posts: 12

my hp laptop uefi bios not recognizes anymore the SATA SSD M2

Hello Everyone,

As the title i have i very strange and painful problem: Suddenly the UEFI BIOS of my Hp proobok g4 has stopped recognizing the SDD.
The strange thing is that is that Arch recognizes grub (which however suddenly crashes) but if I try to start the system from live USB the HD is not seen by the OS.

Some Saint Soul can give me some helpful suggestion to restore properly the hard disk?

Last edited by VecchiaZimarra (2024-03-25 20:56:30)

Offline

#2 2024-03-26 07:01:33

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,732
Website

Re: my hp laptop uefi bios not recognizes anymore the SATA SSD M2

Check the firmware options, I think the drive needs to be in AHCI mode for it to be visible to the installer.

Offline

#3 2024-03-27 18:32:35

VecchiaZimarra
Member
Registered: 2023-03-16
Posts: 12

Re: my hp laptop uefi bios not recognizes anymore the SATA SSD M2

Hi thanks 4 the answer.

Unfortunately the drive already seems to be on ahci (not raid) by default and in any case the hp bios does not allow any modification.

Offline

#4 2024-03-27 19:13:52

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,732
Website

Re: my hp laptop uefi bios not recognizes anymore the SATA SSD M2

VecchiaZimarra wrote:

The strange thing is that is that Arch recognizes grub (which however suddenly crashes)

Can you provide more detail here? What happens when you start the machine? What exactly do you see?

Is there a Windows system on the laptop?

Can the firmware check if the drive is working? Can you check the cable and/or connector?

Offline

#5 2024-03-27 19:51:50

VecchiaZimarra
Member
Registered: 2023-03-16
Posts: 12

Re: my hp laptop uefi bios not recognizes anymore the SATA SSD M2

ok this is the situation:
When i start the machine starts the boot process with kernel optsions but it freezes on the initial ramdisk.

so if i try to start to usb live the system boots regulary but the hard disk it's not present.

Therefore i start to recovery mode but hp uefi bios not recognizes the sdd  among the strarting boot units: and i have try to plug in another sata unit with same result.


The hp recovery utility recognizes the hard disk regulary without problems.

I can imagine a problem with motherboard plugs but in this case why starts grub?

Last edited by VecchiaZimarra (2024-03-27 19:55:18)

Offline

Board footer

Powered by FluxBB