You are not logged in.

#1 2024-03-30 07:11:47

razerraz
Member
Registered: 2014-06-27
Posts: 8

[Almost solved] Can't merge to AUR anymore

Hi,

I maintain aur packages for almost 10 years, but since a few days i'm not able to push anything.
The git push command always ends up bloking, without any info about what's going wrong
I've tried to renew my ssh keys pair, reclone the deposit, read several times all the guidelines to find out what I'm doing wrong, without success
Anybody helping me please ?

EDIT:
I'm able to clone a deposit using https url but it blocks when using ssh://
With verbose mode enabled for git and ssh, it blocks at
debug2: channel 0: open confirm rwindow 0 rmax 32768
Everything seems fine until then

EDIT2:
I'm able to push things forcing ipv4 usage by ssh instead of v6. Is the problem on my side ?

Last edited by razerraz (2024-03-30 07:44:35)

Offline

#2 2024-03-30 09:06:49

seth
Member
Registered: 2012-09-03
Posts: 52,199

Re: [Almost solved] Can't merge to AUR anymore

Does IPv6 otherwise properly function?
Can you "ping -6 aur.archlinux.org"?

Offline

#3 2024-03-30 09:14:48

razerraz
Member
Registered: 2014-06-27
Posts: 8

Re: [Almost solved] Can't merge to AUR anymore

Of course ping is working, I get handshakes, key sharing working but it seems to block when data are involved.
I've an history of mtu issues with my provider since it uses 6to4 and 4to6 along the road sometimes, but everything else works with v6 so I doubt It comes from there

Offline

#4 2024-03-30 09:21:47

seth
Member
Registered: 2012-09-03
Posts: 52,199

Re: [Almost solved] Can't merge to AUR anymore

Don't doubt, test wink

sudo ip link set eth0 mtu 1280 # replace eth0 w/ the relevant NIC

Offline

#5 2024-04-05 02:10:47

jthvai
Member
Registered: 2023-11-03
Posts: 13

Re: [Almost solved] Can't merge to AUR anymore

Edit: pushing worked with an unencrypted ed25519 key (without forcing IPv4).

---

I have the same issue; ping -6 aur.archlinux.org works fine. ssh aur@aur.archlinux.org help and so on work fine too.

Forcing IPv4 ssh (with GIT_SSH_COMMAND="ssh -4") doesn't fix the issue for me.

Just for the record, pushing with ssh to GitHub works alright, albeit it is behaving slightly weirdly (prompts my security key twice instead of once).

Here is the end of the log when git-pushing with ssh -vv with an ed25519-sk ssh key, where it hangs:

Authenticated to aur.archlinux.org ([95.216.144.15]:22) using "publickey".
debug2: fd 4 setting O_NONBLOCK
debug2: fd 5 setting O_NONBLOCK
debug1: channel 0: new session [client-session] (inactive timeout: 0)
debug2: channel 0: send open
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: filesystem
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug1: client_input_hostkeys: searching /home/${USER}/.ssh/known_hosts for aur.archlinux.org / (none)
debug1: client_input_hostkeys: searching /home/${USER}/.ssh/known_hosts2 for aur.archlinux.org / (none)
debug1: client_input_hostkeys: hostkeys file /home/${USER}/.ssh/known_hosts2 does not exist
debug1: client_input_hostkeys: no new or deprecated keys from server
debug1: Remote: /usr/local/bin/aurweb-git-auth.sh "%t" "%k":1: key options: command
debug1: Remote: /usr/local/bin/aurweb-git-auth.sh "%t" "%k":1: key options: command
debug2: channel_input_open_confirmation: channel 0: callback start
debug2: fd 3 setting TCP_NODELAY
debug2: client_session2_setup: id 0
debug1: Sending command: git-receive-pack '/perl-pdl.git'
debug2: channel 0: request exec confirm 1
debug1: pledge: fork
debug2: channel_input_open_confirmation: channel 0: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel 0: rcvd adjust 2097152
debug2: channel_input_status_confirm: type 99 id 0
debug2: exec request accepted on channel 0

Last edited by jthvai (2024-04-05 02:23:52)

Offline

Board footer

Powered by FluxBB