You are not logged in.

#1 2024-04-01 19:44:10

Nebulosa
Member
Registered: 2009-08-24
Posts: 46

Building AUR linux-ck with modprobed-db in a clean chroot

Trying to build linux-ck using this edited PKGBUILD:

selected clang, subarch and included modprobed.db which I put in the main folder

$ git diff -U0
diff --git a/PKGBUILD b/PKGBUILD
index 88cd3e8..e811adf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17 +17 @@ _makenconfig=
-_localmodcfg=
+_localmodcfg=y
@@ -20 +20 @@ _localmodcfg=
-_clangbuild=
+_clangbuild=y
@@ -25 +25 @@ _clangbuild=
-_subarch=
+_subarch=26
@@ -105 +105 @@ source=(
-  config  # the main kernel config file
+  modprobed.db config  # modprobed.db file and the main kernel config file
@@ -115 +115 @@ sha256sums=('8d0c8936e3140a0fbdf511ad7a9f21121598f3656743898f47bb9052d37cff68'
-            'SKIP'
+            'SKIP' 'SKIP'
@@ -185 +185 @@ prepare() {
-      if [ -f $HOME/.config/modprobed.db ]; then
+      if [ -f ../modprobed.db ]; then
@@ -187 +187 @@ prepare() {
-        make LLVM=$_LLVM LLVM_IAS=$_LLVM LSMOD="$HOME/.config/modprobed.db" localmodconfig
+        make LLVM=$_LLVM LLVM_IAS=$_LLVM LSMOD="../modprobed.db" localmodconfig

And modprobed.db file

The kernel builds without errors almost everything is fine, except one thing. When I run makepkg -rs it builds the package linux-ck-6.8.1-1-x86_64.pkg.tar.zst as it should - about 15 mb in size and compiles for a couple hours. But when I run pkgctl build with the same PKGBUILD and modprobed.db files -  the same package is generated, but 132 mb in size and the compilation procedure takes twice as long.

PKGBUILD has a command that saves config.last files and I have already compared them, after makepkg and pkgctl, they are identical.
/etc/makepkg.conf and /usr/share/devtools/makepkg.conf.d/x86_64.conf   have not been modified.

It seems that when you build in a clean chroot it compiles with all available kernel modules, despite the modprobed reduction procedure

Any thought or advises?

Offline

Board footer

Powered by FluxBB